aboutsummaryrefslogtreecommitdiff
path: root/devel/liboil
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2005-10-21 09:36:37 +0000
committerKoop Mast <kwm@FreeBSD.org>2005-10-21 09:36:37 +0000
commit26c17cb9e2be005de05a7d2943b52e0a4eb99f2d (patch)
tree32bd533ec239c8ec2fdf64af7ef103cc13aa481b /devel/liboil
parent8d4b99d2a94dd19f43fb7d4f5f739dd0edcd48fe (diff)
downloadports-26c17cb9e2be005de05a7d2943b52e0a4eb99f2d.tar.gz
ports-26c17cb9e2be005de05a7d2943b52e0a4eb99f2d.zip
Notes
Diffstat (limited to 'devel/liboil')
-rw-r--r--devel/liboil/Makefile8
-rw-r--r--devel/liboil/distinfo4
-rw-r--r--devel/liboil/files/patch-configure12
-rw-r--r--devel/liboil/files/patch-liboil__simdpack__sincos_f64.c17
-rw-r--r--devel/liboil/pkg-plist3
5 files changed, 31 insertions, 13 deletions
diff --git a/devel/liboil/Makefile b/devel/liboil/Makefile
index 3f22ef1a2350..94a0a76edd22 100644
--- a/devel/liboil/Makefile
+++ b/devel/liboil/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= liboil
-PORTVERSION= 0.3.2
+PORTVERSION= 0.3.3
CATEGORIES= devel
MASTER_SITES= http://www.schleef.org/liboil/download/
@@ -16,6 +16,7 @@ COMMENT= Library of optimized inner loops
USE_GNOME= glib20
USE_REINPLACE= yes
USE_LIBTOOL_VER=15
+USE_GCC= 3.4
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --disable-gtk-doc
@@ -23,13 +24,10 @@ PLIST_SUB= VERSION=${PORTVERSION:R}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|stdint\.h|inttypes.h|g' \
${WRKSRC}/liboil/liboiltypes.h \
+ ${WRKSRC}/liboil/liboilprofile.h \
${WRKSRC}/liboil/liboil.h
.include <bsd.port.post.mk>
diff --git a/devel/liboil/distinfo b/devel/liboil/distinfo
index 0711c68c310f..65ea53438af3 100644
--- a/devel/liboil/distinfo
+++ b/devel/liboil/distinfo
@@ -1,2 +1,2 @@
-MD5 (liboil-0.3.2.tar.gz) = f127d90ee8531d03184b76f18e3997be
-SIZE (liboil-0.3.2.tar.gz) = 568293
+MD5 (liboil-0.3.3.tar.gz) = 5bcbee1d5e7f29c95d28620f1fe6b817
+SIZE (liboil-0.3.3.tar.gz) = 671516
diff --git a/devel/liboil/files/patch-configure b/devel/liboil/files/patch-configure
index ac0cdaa69ddc..63ebd636c1dd 100644
--- a/devel/liboil/files/patch-configure
+++ b/devel/liboil/files/patch-configure
@@ -1,11 +1,11 @@
---- configure.orig Thu Mar 17 10:45:20 2005
-+++ configure Sat Mar 19 11:55:47 2005
-@@ -20895,13 +20895,13 @@
+--- configure.orig Fri Sep 30 01:52:47 2005
++++ configure Fri Oct 21 11:14:15 2005
+@@ -21513,13 +21513,13 @@
- fi
--LIBOIL_CFLAGS="$LIBOIL_CFLAGS -D_GNU_SOURCE -D_POSIX_C_SOURCE=200112L -I\$(top_srcdir) -O2"
-+LIBOIL_CFLAGS="$LIBOIL_CFLAGS -D_GNU_SOURCE -I\$(top_srcdir) -O2"
+
+-LIBOIL_CFLAGS="$LIBOIL_CFLAGS -D_BSD_SOURCE -D_GNU_SOURCE -I\$(top_srcdir) -O2"
++LIBOIL_CFLAGS="$LIBOIL_CFLAGS -D_BSD_SOURCE -D_GNU_SOURCE -I\$(top_srcdir) $(CFLAGS)"
LIBOIL_LIBS="\$(top_builddir)/liboil/liboil-$LIBOIL_MAJORMINOR.la"
diff --git a/devel/liboil/files/patch-liboil__simdpack__sincos_f64.c b/devel/liboil/files/patch-liboil__simdpack__sincos_f64.c
new file mode 100644
index 000000000000..895a2cdccde2
--- /dev/null
+++ b/devel/liboil/files/patch-liboil__simdpack__sincos_f64.c
@@ -0,0 +1,17 @@
+--- liboil/simdpack/sincos_f64.c.orig Sun Oct 9 09:59:12 2005
++++ liboil/simdpack/sincos_f64.c Sun Oct 9 10:01:03 2005
+@@ -71,6 +71,7 @@
+ }
+ OIL_DEFINE_IMPL (sincos_f64_i20_fast, sincos_f64);
+
++/*
+ #ifdef _GNU_SOURCE
+ static void
+ sincos_f64_sincos (double *dest_sin, double *dest_cos, int n, double *offset,
+@@ -83,5 +84,6 @@
+ }
+ }
+ OIL_DEFINE_IMPL (sincos_f64_sincos, sincos_f64);
+ #endif
++*/
+
diff --git a/devel/liboil/pkg-plist b/devel/liboil/pkg-plist
index d7bac1ed51c9..0d8366d425ee 100644
--- a/devel/liboil/pkg-plist
+++ b/devel/liboil/pkg-plist
@@ -1,9 +1,11 @@
include/liboil-%%VERSION%%/liboil/liboil.h
+include/liboil-%%VERSION%%/liboil/liboilclasses.h
include/liboil-%%VERSION%%/liboil/liboilcpu.h
include/liboil-%%VERSION%%/liboil/liboildebug.h
include/liboil-%%VERSION%%/liboil/liboilfuncs.h
include/liboil-%%VERSION%%/liboil/liboilfunction.h
include/liboil-%%VERSION%%/liboil/liboilgcc.h
+include/liboil-%%VERSION%%/liboil/liboilinternal.h
include/liboil-%%VERSION%%/liboil/liboilparameter.h
include/liboil-%%VERSION%%/liboil/liboilprofile.h
include/liboil-%%VERSION%%/liboil/liboilprototype.h
@@ -34,6 +36,7 @@ share/gtk-doc/html/liboil/liboil-liboilfuncs-doc.html
share/gtk-doc/html/liboil/liboil-liboilfuncs-math.html
share/gtk-doc/html/liboil/liboil-liboilfuncs-math8x8.html
share/gtk-doc/html/liboil/liboil-liboilfuncs-pixel.html
+share/gtk-doc/html/liboil/liboil-liboilmacros.html
share/gtk-doc/html/liboil/liboil-liboilparameter.html
share/gtk-doc/html/liboil/liboil-liboilprofile.html
share/gtk-doc/html/liboil/liboil-liboilprototype.html