aboutsummaryrefslogtreecommitdiff
path: root/devel/liboobs/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-19 05:14:07 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-19 05:14:07 +0000
commit951c257ea3655de6e80c26a36c18c69ee8047ea8 (patch)
tree249b59a23d9c6fae8db5e5639385f6273d237705 /devel/liboobs/Makefile
parent91926e92b73e3751382216a16044c5d8b24ad126 (diff)
downloadports-951c257ea3655de6e80c26a36c18c69ee8047ea8.tar.gz
ports-951c257ea3655de6e80c26a36c18c69ee8047ea8.zip
Notes
Diffstat (limited to 'devel/liboobs/Makefile')
-rw-r--r--devel/liboobs/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/liboobs/Makefile b/devel/liboobs/Makefile
new file mode 100644
index 000000000000..d9a86e6eb241
--- /dev/null
+++ b/devel/liboobs/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: liboobs
+# Date created: 2006-06-06
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/devel/liboobs/Makefile,v 1.18 2007/03/12 12:34:37 ahze Exp $
+
+PORTNAME= liboobs
+PORTVERSION= 2.18.0
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Wrapping library to the System Tools Backends
+
+BUILD_DEPENDS= ${LOCALBASE}/etc/dbus-1/system.d/system-tools-backends.conf:${PORTSDIR}/sysutils/system-tools-backends
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+RUN_DEPENDS= ${LOCALBASE}/etc/dbus-1/system.d/system-tools-backends.conf:${PORTSDIR}/sysutils/system-tools-backends
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack glib20
+USE_LDCONFIG= yes
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
+
+.include <bsd.port.mk>