aboutsummaryrefslogtreecommitdiff
path: root/devel/libopenbsd/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-01-18 13:20:31 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-01-18 13:20:31 +0000
commit02f27a83b44d4566fd409edc60570ac0734eb63e (patch)
tree62d2805fd9c9c4285034b54a2ccb3f498f302811 /devel/libopenbsd/Makefile
parentbddf1289efd81317364118eb60cdc28cc766c3c2 (diff)
Notes
Diffstat (limited to 'devel/libopenbsd/Makefile')
-rw-r--r--devel/libopenbsd/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/devel/libopenbsd/Makefile b/devel/libopenbsd/Makefile
index 1ec138e2535f..fbb5026ff640 100644
--- a/devel/libopenbsd/Makefile
+++ b/devel/libopenbsd/Makefile
@@ -17,15 +17,14 @@ MAKE_ARGS= INCLUDEDIR="${PREFIX}/include" LIBDIR="${PREFIX}/lib" \
MANDIR="${PREFIX}/man/man"
USE_LDCONFIG= yes
+.include <bsd.port.options.mk>
+
#
# To update snapshot: make makesum BOOTSTRAP=
# Specific snapshot: make makesum SVN_FETCH= PORTVERSION=r1234
#
.if defined(BOOTSTRAP)
-# XXX SED and _MASTER_SITES_svn aren't defined yet
-SED?= /usr/bin/sed
-SVN_REV!= ${SETENV} LC_ALL=C svn info \
- ${MASTER_SITES:M*\:svn:S/:svn//} | \
+SVN_REV!= svn info ${MASTER_SITES:M*\:svn:S/:svn//} | \
${SED} -n 's/^Last Changed Rev: //p'
PORTVERSION:= r${SVN_REV}
.else