aboutsummaryrefslogtreecommitdiff
path: root/devel/libopendaap/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-05-16 18:21:37 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-05-16 18:21:37 +0000
commite1e371b7079da676f811a467deb497176e6e9eac (patch)
tree82749e0f8ce0b840ba866d647cb071f5c083f88f /devel/libopendaap/Makefile
parent757e510008475071ecf6d43038735041a3cab99a (diff)
downloadports-e1e371b7079da676f811a467deb497176e6e9eac.tar.gz
ports-e1e371b7079da676f811a467deb497176e6e9eac.zip
Notes
Diffstat (limited to 'devel/libopendaap/Makefile')
-rw-r--r--devel/libopendaap/Makefile24
1 files changed, 7 insertions, 17 deletions
diff --git a/devel/libopendaap/Makefile b/devel/libopendaap/Makefile
index 97f197d8ee25..108a5122182b 100644
--- a/devel/libopendaap/Makefile
+++ b/devel/libopendaap/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libopendaap
-PORTVERSION= 0.3.0
-PORTREVISION= 1
+PORTVERSION= 0.4.0
CATEGORIES= devel net
MASTER_SITES= http://craz.net/programs/itunes/files/
@@ -15,25 +14,16 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= C lib used to connect to iTunes(R) music shares
USE_BZIP2= yes
-USE_REINPLACE= yes
USE_GNOME= gnomehack gnometarget pkgconfig
-USE_INC_LIBTOOL_VER=15
-USE_GCC= 3.4
-MAN3= libopendaap.3
-
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}"
-
+USE_REINPLACE= yes
+USE_LIBTOOL_VER= 15
INSTALLS_SHLIB= yes
-pre-configure:
-# Broken libtool fix
- @cd ${WRKSRC} && \
- ${LIBTOOLIZE} --force
+MAN3= libopendaap.3
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
- ${WRKSRC}/Makefile.am \
- ${WRKSRC}/Makefile.in \
- ${WRKSRC}/opendaap.pc.in
+.for file in Makefile.in opendaap.pc.in
+ @${REINPLACE_CMD} -e 's|-lpthread||g' ${WRKSRC}/${file}
+.endfor
.include <bsd.port.mk>