aboutsummaryrefslogtreecommitdiff
path: root/devel/libopendaap
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-05-16 18:21:37 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-05-16 18:21:37 +0000
commite1e371b7079da676f811a467deb497176e6e9eac (patch)
tree82749e0f8ce0b840ba866d647cb071f5c083f88f /devel/libopendaap
parent757e510008475071ecf6d43038735041a3cab99a (diff)
downloadports-e1e371b7079da676f811a467deb497176e6e9eac.tar.gz
ports-e1e371b7079da676f811a467deb497176e6e9eac.zip
Notes
Diffstat (limited to 'devel/libopendaap')
-rw-r--r--devel/libopendaap/Makefile24
-rw-r--r--devel/libopendaap/distinfo4
-rw-r--r--devel/libopendaap/files/patch-client.c28
-rw-r--r--devel/libopendaap/files/patch-ioloop.c13
-rw-r--r--devel/libopendaap/files/patch-mDNS-mDNSClientAPI.h13
-rw-r--r--devel/libopendaap/files/patch-threadpool.c14
6 files changed, 64 insertions, 32 deletions
diff --git a/devel/libopendaap/Makefile b/devel/libopendaap/Makefile
index 97f197d8ee25..108a5122182b 100644
--- a/devel/libopendaap/Makefile
+++ b/devel/libopendaap/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libopendaap
-PORTVERSION= 0.3.0
-PORTREVISION= 1
+PORTVERSION= 0.4.0
CATEGORIES= devel net
MASTER_SITES= http://craz.net/programs/itunes/files/
@@ -15,25 +14,16 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= C lib used to connect to iTunes(R) music shares
USE_BZIP2= yes
-USE_REINPLACE= yes
USE_GNOME= gnomehack gnometarget pkgconfig
-USE_INC_LIBTOOL_VER=15
-USE_GCC= 3.4
-MAN3= libopendaap.3
-
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}"
-
+USE_REINPLACE= yes
+USE_LIBTOOL_VER= 15
INSTALLS_SHLIB= yes
-pre-configure:
-# Broken libtool fix
- @cd ${WRKSRC} && \
- ${LIBTOOLIZE} --force
+MAN3= libopendaap.3
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
- ${WRKSRC}/Makefile.am \
- ${WRKSRC}/Makefile.in \
- ${WRKSRC}/opendaap.pc.in
+.for file in Makefile.in opendaap.pc.in
+ @${REINPLACE_CMD} -e 's|-lpthread||g' ${WRKSRC}/${file}
+.endfor
.include <bsd.port.mk>
diff --git a/devel/libopendaap/distinfo b/devel/libopendaap/distinfo
index dd57e5fa4a19..f5a90ce3ca64 100644
--- a/devel/libopendaap/distinfo
+++ b/devel/libopendaap/distinfo
@@ -1,2 +1,2 @@
-MD5 (libopendaap-0.3.0.tar.bz2) = a722ee6171f946a1f415d7c4d88f150a
-SIZE (libopendaap-0.3.0.tar.bz2) = 365682
+MD5 (libopendaap-0.4.0.tar.bz2) = 4edf92ac18c6ab8c05be7a4eb64a8a8d
+SIZE (libopendaap-0.4.0.tar.bz2) = 241953
diff --git a/devel/libopendaap/files/patch-client.c b/devel/libopendaap/files/patch-client.c
new file mode 100644
index 000000000000..02a4f926df34
--- /dev/null
+++ b/devel/libopendaap/files/patch-client.c
@@ -0,0 +1,28 @@
+--- client.c.orig Thu May 12 15:46:29 2005
++++ client.c Mon May 16 19:20:04 2005
+@@ -1380,10 +1380,10 @@
+
+ HTTP_Connection *http_connection;
+
+- if (strlen(songformat) > 4) return -1;
+-
+ HTTP_GetResult *httpRes;
+
++ if (strlen(songformat) > 4) return -1;
++
+ if (pCHThis->version_major != 3)
+ {
+ buf = safe_sprintf(songUrl_42, databaseid, songid, songformat,
+@@ -1643,10 +1643,11 @@
+ static void AsyncWaitUpdate(void *pv_pCHThis, void *unused)
+ {
+ DAAP_SClientHost *pCHThis = (DAAP_SClientHost*)pv_pCHThis;
+- TRACE("()\n");
+ char hash[33] = {0};
+ char updateUrl[] = "/update?session-id=%i&revision-number=%i&delta=%i";
+ char *buf;
++
++ TRACE("()\n");
+
+ buf = safe_sprintf(updateUrl, pCHThis->sessionid, pCHThis->revision_number,
+ pCHThis->revision_number);
diff --git a/devel/libopendaap/files/patch-ioloop.c b/devel/libopendaap/files/patch-ioloop.c
new file mode 100644
index 000000000000..777d9a924ccd
--- /dev/null
+++ b/devel/libopendaap/files/patch-ioloop.c
@@ -0,0 +1,13 @@
+--- ioloop.c.orig Tue Dec 14 13:39:31 2004
++++ ioloop.c Mon May 16 19:24:20 2005
+@@ -113,9 +113,9 @@
+
+ void fd_event_reset(fd_event *event)
+ {
+- event->signalled = 0;
+ char buf[1] = {0};
+ int flags;
++ event->signalled = 0;
+
+ /* set non-blocking on read pipe */
+ flags = fcntl(event->pipe[0], F_GETFL, 0);
diff --git a/devel/libopendaap/files/patch-mDNS-mDNSClientAPI.h b/devel/libopendaap/files/patch-mDNS-mDNSClientAPI.h
deleted file mode 100644
index 23d4145fc48f..000000000000
--- a/devel/libopendaap/files/patch-mDNS-mDNSClientAPI.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- mDNS/mDNSClientAPI.h.orig Wed Mar 17 23:45:20 2004
-+++ mDNS/mDNSClientAPI.h Wed Mar 17 23:45:36 2004
-@@ -480,8 +480,8 @@
- typedef unsigned char mDNSu8;
- typedef signed short mDNSs16;
- typedef unsigned short mDNSu16;
--typedef signed long mDNSs32;
--typedef unsigned long mDNSu32;
-+typedef signed int mDNSs32;
-+typedef unsigned int mDNSu32;
-
- // To enforce useful type checking, we make mDNSInterfaceID be a pointer to a dummy struct
- // This way, mDNSInterfaceIDs can be assigned, and compared with each other, but not with other types
diff --git a/devel/libopendaap/files/patch-threadpool.c b/devel/libopendaap/files/patch-threadpool.c
new file mode 100644
index 000000000000..17c47a360572
--- /dev/null
+++ b/devel/libopendaap/files/patch-threadpool.c
@@ -0,0 +1,14 @@
+--- threadpool.c.orig Tue Dec 14 13:56:23 2004
++++ threadpool.c Mon May 16 19:23:22 2005
+@@ -279,9 +279,9 @@
+ void CP_ThreadPool_QueueWorkItem(CP_SThreadPool *pTPThis, CP_TPfnJob pfnCallback,
+ void *arg1, void *arg2)
+ {
+- ts_mutex_lock(pTPThis->mtJobQueueMutex);
+-
+ CP_STPJobQueue *pTPJQNewJob = malloc(sizeof(CP_STPJobQueue));
++
++ ts_mutex_lock(pTPThis->mtJobQueueMutex);
+
+ pTPJQNewJob->fnJobCallback = pfnCallback;
+ pTPJQNewJob->arg1 = arg1;