aboutsummaryrefslogtreecommitdiff
path: root/devel/libopendaap
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-12 14:22:28 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-12 14:22:28 +0000
commit4014a70ea1d9d51618d76c2e8af5d52c53e2a039 (patch)
treed7ada86832b5ce0001c4df07640d168ce5fa8884 /devel/libopendaap
parentb1f68a06477852479be787c30937bb47db4d5484 (diff)
Add libopendaap 0.1.2,
libopendaap is a library written in C which enables applications to discover, and connect to, iTunes(R) music shares. Unlike all other daap implementations, this library is able to connect to recent iTunes shares which require a special authentication algorithm. PR: ports/64035 Submitted by: Michael Johnson <ahze@ahze.net>
Notes
Notes: svn path=/head/; revision=103786
Diffstat (limited to 'devel/libopendaap')
-rw-r--r--devel/libopendaap/Makefile34
-rw-r--r--devel/libopendaap/distinfo2
-rw-r--r--devel/libopendaap/pkg-descr7
-rw-r--r--devel/libopendaap/pkg-plist6
4 files changed, 49 insertions, 0 deletions
diff --git a/devel/libopendaap/Makefile b/devel/libopendaap/Makefile
new file mode 100644
index 000000000000..d52bd0a431cc
--- /dev/null
+++ b/devel/libopendaap/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: libopendaap
+# Date created: 2004-03-10
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libopendaap
+PORTVERSION= 0.1.2
+CATEGORIES= devel net
+MASTER_SITES= http://crazney.net/programs/itunes/files/
+
+MAINTAINER= ahze@ahze.net
+COMMENT= C lib used to connect to iTunes(R) music shares
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GNOME= gnomehack pkgconfig lthack
+USE_LIBTOOL= yes
+USE_GCC= 3.3
+
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}"
+
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-DNOT_HAVE_SA_LEN||' \
+ ${WRKSRC}/mDNS/Makefile.am \
+ ${WRKSRC}/mDNS/Makefile.in
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
+ ${WRKSRC}/Makefile.am \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/devel/libopendaap/distinfo b/devel/libopendaap/distinfo
new file mode 100644
index 000000000000..e3ab08776112
--- /dev/null
+++ b/devel/libopendaap/distinfo
@@ -0,0 +1,2 @@
+MD5 (libopendaap-0.1.2.tar.bz2) = ee95737731d01e5a089a5674f75b13a1
+SIZE (libopendaap-0.1.2.tar.bz2) = 320679
diff --git a/devel/libopendaap/pkg-descr b/devel/libopendaap/pkg-descr
new file mode 100644
index 000000000000..ecfdac488074
--- /dev/null
+++ b/devel/libopendaap/pkg-descr
@@ -0,0 +1,7 @@
+libopendaap is a library written in C which enables applications to discover,
+and connect to, iTunes(R) music shares.
+
+Unlike all other daap implementations, this library is able to connect to
+recent iTunes shares which require a special authentication algorithm.
+
+WWW: http://crazney.net/programs/itunes/libopendaap.html
diff --git a/devel/libopendaap/pkg-plist b/devel/libopendaap/pkg-plist
new file mode 100644
index 000000000000..56f2d07cd212
--- /dev/null
+++ b/devel/libopendaap/pkg-plist
@@ -0,0 +1,6 @@
+include/daap/client.h
+lib/libopendaap.a
+lib/libopendaap.so
+lib/libopendaap.so.0
+libdata/pkgconfig/opendaap.pc
+@dirrm include/daap