aboutsummaryrefslogtreecommitdiff
path: root/devel/libopensync/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-06-19 05:54:13 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-06-19 05:54:13 +0000
commit4cb240652fd124bf1462b03c773dc4c3a735ad17 (patch)
tree472e532cc6369879695c8c057d030a901cc2739d /devel/libopensync/Makefile
parent7e1eb3a2ff8983cac6095ad6245e80ac8d0ead6d (diff)
Notes
Diffstat (limited to 'devel/libopensync/Makefile')
-rw-r--r--devel/libopensync/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/devel/libopensync/Makefile b/devel/libopensync/Makefile
new file mode 100644
index 000000000000..300093af7a72
--- /dev/null
+++ b/devel/libopensync/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: libopensync
+# Date created: 2005-06-19
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libopensync
+PORTVERSION= 0.17
+CATEGORIES= devel
+MASTER_SITES= http://www.opensync.org/attachment/wiki/download/
+EXTRACT_SUFX= .tar.gz\?rev=\&format=raw
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= Freedesktop synchronization framework
+
+LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3 \
+ swigguile.0:${PORTSDIR}/devel/swig13
+
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
+USE_LIBTOOL_VER=15
+USE_PYTHON= yes
+USE_GNOME= gnomehack glib20 libxml2
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN="Does not build."
+.endif
+
+pre-everything::
+ @${ECHO_MSG} "NOTE: You may want to avoid extra dependencies"
+ @${ECHO_MSG} " from devel/swig13 by building with the following"
+ @${ECHO_MSG} " SWIG_LANGUAGES=\"perl python\""
+ @${ECHO_MSG}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$${libdir}/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.post.mk>