aboutsummaryrefslogtreecommitdiff
path: root/devel/libopensync
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-03-11 01:37:46 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-03-11 01:37:46 +0000
commitf683ce144a383f49c405c38e9747ec608fc9657e (patch)
tree0c5e4af2ab3e3bc67ffd3b0979916418ab147d0c /devel/libopensync
parentd965d76bba9b35ad5e36de78f0df423109dda6f2 (diff)
downloadports-f683ce144a383f49c405c38e9747ec608fc9657e.tar.gz
ports-f683ce144a383f49c405c38e9747ec608fc9657e.zip
Notes
Diffstat (limited to 'devel/libopensync')
-rw-r--r--devel/libopensync/Makefile10
-rw-r--r--devel/libopensync/distinfo6
-rw-r--r--devel/libopensync/files/patch-build_osync_support.py12
-rw-r--r--devel/libopensync/pkg-plist16
4 files changed, 30 insertions, 14 deletions
diff --git a/devel/libopensync/Makefile b/devel/libopensync/Makefile
index 7d55076cf5fe..690c1d2359a4 100644
--- a/devel/libopensync/Makefile
+++ b/devel/libopensync/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libopensync
-PORTVERSION= 0.30
-PORTREVISION= 1
+PORTVERSION= 0.31
CATEGORIES= devel
MASTER_SITES= http://www.opensync.org/attachment/wiki/download/
DISTNAME= libopensync-${PORTVERSION}
@@ -27,8 +26,11 @@ USE_SCONS= yes
SCONS_ARGS= prefix=${PREFIX}
post-patch:
- @${REINPLACE_CMD} -e 's|$$libsuffix/pkgconfig|libdata/pkgconfig|' ${WRKSRC}/SConstruct
- @${REINPLACE_CMD} -e 's|gthread-2.0|gthread-2.0 pthread|' ${WRKSRC}/opensync/SConscript
+ @${REINPLACE_CMD} -e "s|install_lib, 'pkgconfig'|install_prefix, 'libdata', 'pkgconfig'|" ${WRKSRC}/SConstruct
+ @${REINPLACE_CMD} \
+ -e 's|gthread-2.0|gthread-2.0 pthread|' \
+ -e 's|vnum="%d.%d.%d" % ([^)]*)|vnum="%d" % (config["major"])|' \
+ ${WRKSRC}/opensync/SConscript
post-install:
@${LN} -sf ${LOCALBASE}/lib/libopensync.so ${LOCALBASE}/lib/libopensync.so.1
diff --git a/devel/libopensync/distinfo b/devel/libopensync/distinfo
index b998d85d5c6f..1cfce08207f3 100644
--- a/devel/libopensync/distinfo
+++ b/devel/libopensync/distinfo
@@ -1,3 +1,3 @@
-MD5 (libopensync-0.30.tar.bz2?rev=&format=raw) = 1b52417878ab4ede584ce18edacfa548
-SHA256 (libopensync-0.30.tar.bz2?rev=&format=raw) = 0a1cfcb736d3569f8bced7e2e6c48d3168a0e97dee40705d09c5adfadcf6a463
-SIZE (libopensync-0.30.tar.bz2?rev=&format=raw) = 862123
+MD5 (libopensync-0.31.tar.bz2?rev=&format=raw) = caf4fd1b174f4863ba79ab074a29b054
+SHA256 (libopensync-0.31.tar.bz2?rev=&format=raw) = bdbaae2a70e202ee90e6af500f22f3de81459a1cb0445c0668eeedf020d723a3
+SIZE (libopensync-0.31.tar.bz2?rev=&format=raw) = 862176
diff --git a/devel/libopensync/files/patch-build_osync_support.py b/devel/libopensync/files/patch-build_osync_support.py
new file mode 100644
index 000000000000..e52174171b6d
--- /dev/null
+++ b/devel/libopensync/files/patch-build_osync_support.py
@@ -0,0 +1,12 @@
+Significant whitespace considered harmful...
+--- build/osync_support.py.orig 2007-06-21 14:38:39.000000000 +0200
++++ build/osync_support.py 2008-03-09 19:32:41.000000000 +0100
+@@ -54,7 +54,7 @@
+ else:
+ # bad, nothing is available, tell the user
+ print "No build directories found for your platform '%s'" % platform
+- return None
++ return None
+
+ print "Found directory %s, will build there" % target_dir
+ return target_dir
diff --git a/devel/libopensync/pkg-plist b/devel/libopensync/pkg-plist
index f5a5a251b920..699374be45f5 100644
--- a/devel/libopensync/pkg-plist
+++ b/devel/libopensync/pkg-plist
@@ -31,6 +31,7 @@ include/opensync-1.0/opensync/merger/opensync_merger.h
include/opensync-1.0/opensync/merger/opensync_xmlfield.h
include/opensync-1.0/opensync/merger/opensync_xmlfieldlist.h
include/opensync-1.0/opensync/merger/opensync_xmlformat.h
+include/opensync-1.0/opensync/opensync-archive.h
include/opensync-1.0/opensync/opensync-client.h
include/opensync-1.0/opensync/opensync-context.h
include/opensync-1.0/opensync/opensync-data.h
@@ -66,15 +67,16 @@ libdata/pkgconfig/opensync-1.0.pc
libdata/pkgconfig/osengine-1.0.pc
share/opensync/capabilities/file-sync.xml
share/opensync/capabilities/syncml-nokia-7650.xml
-share/opensync/descriptions/descriptions.xsd
share/opensync/descriptions/miscellaneous.xml
share/opensync/descriptions/syncml-nokia.xml
-share/opensync/descriptions/xmlformat-calendar.xsd
-share/opensync/descriptions/xmlformat-common.xsd
-share/opensync/descriptions/xmlformat-contact.xsd
-share/opensync/descriptions/xmlformat-event.xsd
-share/opensync/descriptions/xmlformat-note.xsd
-share/opensync/descriptions/xmlformat-todo.xsd
+share/opensync/schemas/descriptions.xsd
+share/opensync/schemas/xmlformat-calendar.xsd
+share/opensync/schemas/xmlformat-common.xsd
+share/opensync/schemas/xmlformat-contact.xsd
+share/opensync/schemas/xmlformat-event.xsd
+share/opensync/schemas/xmlformat-note.xsd
+share/opensync/schemas/xmlformat-todo.xsd
+@dirrm share/opensync/schemas
@dirrm share/opensync/descriptions
@dirrm share/opensync/capabilities
@dirrm share/opensync