aboutsummaryrefslogtreecommitdiff
path: root/devel/libopkele/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-14 11:28:47 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-14 11:28:47 +0000
commita7a74e97535c21b58aaf16a6f0e3840526a8bb2a (patch)
tree9d10fadc6609076775e5fd65f38c63421ab20378 /devel/libopkele/Makefile
parent25e7a0db9d9f1e79ecd661fcccaedc2e6c162d55 (diff)
downloadports-a7a74e97535c21b58aaf16a6f0e3840526a8bb2a.tar.gz
ports-a7a74e97535c21b58aaf16a6f0e3840526a8bb2a.zip
Notes
Diffstat (limited to 'devel/libopkele/Makefile')
-rw-r--r--devel/libopkele/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/libopkele/Makefile b/devel/libopkele/Makefile
new file mode 100644
index 000000000000..ae9f1e333809
--- /dev/null
+++ b/devel/libopkele/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: libopkele
+# Date created: 28 November 2007
+# Whom: Sutra Zhou <zhoushuqun@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libopkele
+PORTVERSION= 0.3.2
+CATEGORIES= devel
+MASTER_SITES= http://kin.klever.net/dist/
+
+MAINTAINER= zhoushuqun@gmail.com
+COMMENT= A c++ implementation of an OpenID decentralized identity system
+
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl \
+ pcre.0:${PORTSDIR}/devel/pcre
+
+USE_GMAKE= yes
+USE_OPENSSL= yes
+USE_LDCONFIG= yes
+USE_GNOME= pkgconfig
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= "OPENSSL_CFLAGS=${CFLAGS} -l${OPENSSLINC}" \
+ OPENSSL_LIBS=-L${OPENSSLLIB}
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS= "-L${LOCALBASE}/lib"
+
+post-patch:
+ @ ${REINPLACE_CMD} -e "s|pkgconfigdir =.*|pkgconfigdir = ${PREFIX}/libdata/pkgconfig|g" \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>