aboutsummaryrefslogtreecommitdiff
path: root/devel/libopkele
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2013-11-02 23:13:23 +0000
committerMark Felder <feld@FreeBSD.org>2013-11-02 23:13:23 +0000
commit83444035919ada31ad7bcb591ad9d87b0d296188 (patch)
tree515e5fd6c18a390c099e2dab5428dce534ce8528 /devel/libopkele
parent3f19f8605f2ce9223b51affb12f7287b33d2e8dd (diff)
downloadports-83444035919ada31ad7bcb591ad9d87b0d296188.tar.gz
ports-83444035919ada31ad7bcb591ad9d87b0d296188.zip
Notes
Diffstat (limited to 'devel/libopkele')
-rw-r--r--devel/libopkele/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/devel/libopkele/Makefile b/devel/libopkele/Makefile
index 121728ae9e6e..f68cf34cf7d9 100644
--- a/devel/libopkele/Makefile
+++ b/devel/libopkele/Makefile
@@ -11,13 +11,14 @@ MAINTAINER= zhoushuqun@gmail.com
COMMENT= A c++ implementation of an OpenID decentralized identity system
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- pcre.3:${PORTSDIR}/devel/pcre \
- expat.6:${PORTSDIR}/textproc/expat2 \
- tidy:${PORTSDIR}/www/tidy-lib \
- xslt:${PORTSDIR}/textproc/libxslt
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libtidy.so:${PORTSDIR}/www/tidy-lib \
+ libxslt.so:${PORTSDIR}/textproc/libxslt
USE_LDCONFIG= yes
+USE_GCC= 4.6
USES= gmake pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= "OPENSSL_CFLAGS=${CFLAGS} -l${OPENSSLINC}" \
@@ -29,7 +30,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
# This port needs OpenSSL 0.9.8b which is present in 7.0 and up
USE_OPENSSL= yes
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/Mk/bsd.openssl.mk"