aboutsummaryrefslogtreecommitdiff
path: root/devel/libosmocore
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-08-11 18:08:33 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-08-11 18:08:33 +0000
commit79c3df0c9f81681782f9d616476ed1f7b88fd0a0 (patch)
tree177ae0792c4cad060ac68efd38ab5284f4c8f39f /devel/libosmocore
parent1c76210ba38eef382b25eca1edeccf183243fc87 (diff)
Notes
Diffstat (limited to 'devel/libosmocore')
-rw-r--r--devel/libosmocore/Makefile15
-rw-r--r--devel/libosmocore/files/patch-Doxyfile.codec.in2
-rw-r--r--devel/libosmocore/files/patch-Doxyfile.core.in2
-rw-r--r--devel/libosmocore/files/patch-Doxyfile.gsm.in2
-rw-r--r--devel/libosmocore/files/patch-Doxyfile.vty.in2
-rw-r--r--devel/libosmocore/files/patch-Makefile.am45
6 files changed, 61 insertions, 7 deletions
diff --git a/devel/libosmocore/Makefile b/devel/libosmocore/Makefile
index 8d8db190169a..3880eb8e0ae7 100644
--- a/devel/libosmocore/Makefile
+++ b/devel/libosmocore/Makefile
@@ -12,27 +12,36 @@ COMMENT= Common library for all Osmocom projects
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= gmake libtool pkgconfig execinfo
USE_AUTOTOOLS= aclocal autoconf automake libtoolize autoheader
AUTOMAKE_ARGS= --gnu --add-missing --copy
-
-USES= gmake libtool
-LDFLAGS+= -lexecinfo
+LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
+OPTIONS_DEFINE= DOCS
+DOCS_DESC= Build documentation
+OPTIONS_UNSET= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
dot:${PORTSDIR}/graphics/graphviz
+.endif
post-patch:
${REINPLACE_CMD} -e 's|pkgconfigdir.*|pkgconfigdir = ${PREFIX}/libdata/pkgconfig|g' \
${WRKSRC}/Makefile.am
${ECHO_CMD} ${PORTVERSION} > ${WRKSRC}/.tarball-version
+.if ${PORT_OPTIONS:MDOCS}
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in codec core gsm vty
${FIND} ${WRKSRC}/doc/${i}/html -not -type d | ${SED} \
's,^${WRKSRC}/doc/${i}/html,${DOCSDIR_REL}/${i}/html,' >> ${TMPPLIST}
.endfor
+.endif
.include <bsd.port.mk>
diff --git a/devel/libosmocore/files/patch-Doxyfile.codec.in b/devel/libosmocore/files/patch-Doxyfile.codec.in
index d290412ebbd3..862226076442 100644
--- a/devel/libosmocore/files/patch-Doxyfile.codec.in
+++ b/devel/libosmocore/files/patch-Doxyfile.codec.in
@@ -1,5 +1,5 @@
--- ./Doxyfile.codec.in.orig 2014-03-31 15:40:46.000000000 +0200
-+++ ./Doxyfile.codec.in 2014-08-10 08:28:34.000000000 +0200
++++ ./Doxyfile.codec.in 2014-08-11 15:10:30.000000000 +0200
@@ -1,109 +1,129 @@
-# Doxyfile 1.7.4
+# Doxyfile 1.8.7
diff --git a/devel/libosmocore/files/patch-Doxyfile.core.in b/devel/libosmocore/files/patch-Doxyfile.core.in
index dffc81e6330e..2e4daab84b76 100644
--- a/devel/libosmocore/files/patch-Doxyfile.core.in
+++ b/devel/libosmocore/files/patch-Doxyfile.core.in
@@ -1,5 +1,5 @@
--- ./Doxyfile.core.in.orig 2014-03-31 15:40:46.000000000 +0200
-+++ ./Doxyfile.core.in 2014-08-10 08:27:43.000000000 +0200
++++ ./Doxyfile.core.in 2014-08-11 15:10:30.000000000 +0200
@@ -1,109 +1,129 @@
-# Doxyfile 1.7.4
+# Doxyfile 1.8.7
diff --git a/devel/libosmocore/files/patch-Doxyfile.gsm.in b/devel/libosmocore/files/patch-Doxyfile.gsm.in
index 2c1c384cf8e8..05e5f6087ad5 100644
--- a/devel/libosmocore/files/patch-Doxyfile.gsm.in
+++ b/devel/libosmocore/files/patch-Doxyfile.gsm.in
@@ -1,5 +1,5 @@
--- ./Doxyfile.gsm.in.orig 2014-03-31 15:40:46.000000000 +0200
-+++ ./Doxyfile.gsm.in 2014-08-10 08:29:31.000000000 +0200
++++ ./Doxyfile.gsm.in 2014-08-11 15:10:30.000000000 +0200
@@ -1,109 +1,129 @@
-# Doxyfile 1.7.4
+# Doxyfile 1.8.7
diff --git a/devel/libosmocore/files/patch-Doxyfile.vty.in b/devel/libosmocore/files/patch-Doxyfile.vty.in
index fbfc9858366b..596a89bcf876 100644
--- a/devel/libosmocore/files/patch-Doxyfile.vty.in
+++ b/devel/libosmocore/files/patch-Doxyfile.vty.in
@@ -1,5 +1,5 @@
--- ./Doxyfile.vty.in.orig 2014-03-31 15:40:46.000000000 +0200
-+++ ./Doxyfile.vty.in 2014-08-10 08:29:38.000000000 +0200
++++ ./Doxyfile.vty.in 2014-08-11 15:10:30.000000000 +0200
@@ -1,109 +1,129 @@
-# Doxyfile 1.7.4
+# Doxyfile 1.8.7
diff --git a/devel/libosmocore/files/patch-Makefile.am b/devel/libosmocore/files/patch-Makefile.am
new file mode 100644
index 000000000000..92f7b2db52e1
--- /dev/null
+++ b/devel/libosmocore/files/patch-Makefile.am
@@ -0,0 +1,45 @@
+--- ./Makefile.am.orig 2014-08-11 15:41:34.000000000 +0200
++++ ./Makefile.am 2014-08-11 15:41:41.000000000 +0200
+@@ -15,42 +15,3 @@
+
+ EXTRA_DIST = git-version-gen
+
+-if HAVE_DOXYGEN
+-
+-html_DATA = $(top_builddir)/doc/html.tar
+-
+-$(html_DATA): $(top_builddir)/doc/core/html/index.html \
+- $(top_builddir)/doc/gsm/html/index.html \
+- $(top_builddir)/doc/vty/html/index.html \
+- $(top_builddir)/doc/codec/html/index.html
+- cd $(top_builddir)/doc && tar cf html.tar */html
+-
+-$(top_builddir)/doc/core/html/index.html: $(SOURCES) Doxyfile.core
+- @rm -rf doc/core
+- mkdir -p doc/core
+- $(DOXYGEN) Doxyfile.core
+-
+-$(top_builddir)/doc/gsm/html/index.html: $(SOURCES) Doxyfile.gsm
+- @rm -rf doc/gsm
+- mkdir -p doc/gsm
+- $(DOXYGEN) Doxyfile.gsm
+-
+-$(top_builddir)/doc/vty/html/index.html: $(SOURCES) Doxyfile.vty
+- @rm -rf doc/vty/{html,latex}
+- $(DOXYGEN) Doxyfile.vty
+-
+-$(top_builddir)/doc/codec/html/index.html: $(SOURCES) Doxyfile.codec
+- @rm -rf doc/codec
+- mkdir -p doc/codec
+- $(DOXYGEN) Doxyfile.codec
+-
+-install-data-hook:
+- cd $(DESTDIR)$(htmldir) && tar xf html.tar && rm -f html.tar
+-
+-uninstall-hook:
+- cd $(DESTDIR)$(htmldir) && rm -rf {core,gsm,vty,codec}
+-
+-DX_CLEAN = doc/{core,gsm,vty,codec}/{html,latex}/* doc/html.tar
+-endif
+-
+-MOSTLYCLEANFILES = $(DX_CLEAN)