aboutsummaryrefslogtreecommitdiff
path: root/devel/libowfat
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-30 22:15:01 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-30 22:15:01 +0000
commit5ba02d8570f32870acc0caf07d7415183411f374 (patch)
tree4dcf7a28541ecbe9d809ce0b71ba2ed7a7579416 /devel/libowfat
parent0251351f106cd4c831b6cf1b9f1ba060eed408ca (diff)
downloadports-5ba02d8570f32870acc0caf07d7415183411f374.tar.gz
ports-5ba02d8570f32870acc0caf07d7415183411f374.zip
Notes
Diffstat (limited to 'devel/libowfat')
-rw-r--r--devel/libowfat/Makefile8
-rw-r--r--devel/libowfat/distinfo4
-rw-r--r--devel/libowfat/files/manpages4
-rw-r--r--devel/libowfat/files/patch-io-iob_addfile.c19
4 files changed, 7 insertions, 28 deletions
diff --git a/devel/libowfat/Makefile b/devel/libowfat/Makefile
index 1fde5c1ecea5..fa38b8a54b93 100644
--- a/devel/libowfat/Makefile
+++ b/devel/libowfat/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libowfat
-PORTVERSION= 0.19.2
-PORTREVISION= 1
+PORTVERSION= 0.20
CATEGORIES= devel ipv6
MASTER_SITES= http://dl.fefe.de/
@@ -30,11 +29,10 @@ CFLAGS+= -O2 -fomit-frame-pointer
.include "${FILESDIR}/manpages"
-examples= test/client.c test/dllink.c test/httpd.c test/readhttp.c \
- test/server.c test/uudecode.c test/vd.c
+examples= examples/byte.c examples/str.c
examplesdir= ${EXAMPLESDIR:S,^${PREFIX}/,,}
PLIST_DIRS= ${examplesdir}
-PLIST_FILES= lib/libowfat.a ${examples:S,^test/,${examplesdir}/,}
+PLIST_FILES= lib/libowfat.a ${examples:S,^examples/,${examplesdir}/,}
.if!defined(NOPORTDOCS)
PORTDOCS= CHANGES README TODO
.endif
diff --git a/devel/libowfat/distinfo b/devel/libowfat/distinfo
index 4a56eb38d960..63a60ff2b0cb 100644
--- a/devel/libowfat/distinfo
+++ b/devel/libowfat/distinfo
@@ -1,2 +1,2 @@
-MD5 (libowfat-0.19.2.tar.bz2) = 7aea51f394d55223eec5820cc84d32f5
-SIZE (libowfat-0.19.2.tar.bz2) = 104852
+MD5 (libowfat-0.20.tar.bz2) = 60e112c24b0f3d6e2757baa96f1ed07e
+SIZE (libowfat-0.20.tar.bz2) = 109541
diff --git a/devel/libowfat/files/manpages b/devel/libowfat/files/manpages
index cc1bb72789d6..fa08c1530bca 100644
--- a/devel/libowfat/files/manpages
+++ b/devel/libowfat/files/manpages
@@ -22,10 +22,10 @@ fmt_ip6_flat.3 fmt_ip6c.3 fmt_ip6if.3 fmt_ip6ifc.3 fmt_long.3 \
fmt_longlong.3 fmt_minus.3 fmt_pad.3 fmt_plusminus.3 fmt_str.3 \
fmt_strn.3 fmt_uint.3 fmt_uint0.3 fmt_ulong.3 fmt_ulong0.3 \
fmt_ulonglong.3 fmt_xlong.3 fmt_xlonglong.3 imult16.3 imult32.3 \
-imult64.3 io_canread.3 io_canwrite.3 io_check.3 io_close.3 \
+imult64.3 io_appendfile.3 io_canread.3 io_canwrite.3 io_check.3 io_close.3 \
io_closeonexec.3 io_createfile.3 io_dontwantread.3 io_dontwantwrite.3 \
io_eagain.3 io_fd.3 io_finishandshutdown.3 io_getcookie.3 io_nonblock.3 \
-io_passfd.3 io_pipe.3 io_readfile.3 io_receivefd.3 io_sendfile.3 \
+io_passfd.3 io_pipe.3 io_readfile.3 io_readwritefile.3 io_receivefd.3 io_sendfile.3 \
io_setcookie.3 io_socketpair.3 io_timeout.3 io_timeouted.3 io_tryread.3 \
io_tryreadtimeout.3 io_trywrite.3 io_trywritetimeout.3 io_wait.3 \
io_waitread.3 io_waituntil.3 io_wantread.3 io_wantwrite.3 iob_addbuf.3 \
diff --git a/devel/libowfat/files/patch-io-iob_addfile.c b/devel/libowfat/files/patch-io-iob_addfile.c
deleted file mode 100644
index 88d016c0e928..000000000000
--- a/devel/libowfat/files/patch-io-iob_addfile.c
+++ /dev/null
@@ -1,19 +0,0 @@
-Index: io/iob_addfile.c
-===================================================================
-RCS file: /cvs/libowfat/io/iob_addfile.c,v
-retrieving revision 1.2
-retrieving revision 1.3
-diff -u -r1.2 -r1.3
---- io/iob_addfile.c 26 Sep 2003 15:55:44 -0000 1.2
-+++ io/iob_addfile.c 7 Apr 2004 08:38:41 -0000 1.3
-@@ -1,7 +1,9 @@
- #include "iob_internal.h"
-
- int iob_addfile(io_batch* b,int64 fd,uint64 off,uint64 n) {
-- iob_entry* e=array_allocate(&b->b,sizeof(iob_entry),
-+ iob_entry* e;
-+ if (n==0) return 1;
-+ e=array_allocate(&b->b,sizeof(iob_entry),
- array_length(&b->b,sizeof(iob_entry)));
- if (!e) return 0;
- e->type=FROMFILE;