aboutsummaryrefslogtreecommitdiff
path: root/devel/libowfat
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2005-03-13 15:28:50 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2005-03-13 15:28:50 +0000
commit7852d9e096570bcca597fa01d5c485c6b46de8a8 (patch)
tree7a59cc541e748bb8854149c36322e9d98bd20971 /devel/libowfat
parentced21e51a1cd0fd42c7ed77c1cf420c69be50c1d (diff)
downloadports-7852d9e096570bcca597fa01d5c485c6b46de8a8.tar.gz
ports-7852d9e096570bcca597fa01d5c485c6b46de8a8.zip
Notes
Diffstat (limited to 'devel/libowfat')
-rw-r--r--devel/libowfat/Makefile19
-rw-r--r--devel/libowfat/distinfo4
-rw-r--r--devel/libowfat/files/manpages2
3 files changed, 12 insertions, 13 deletions
diff --git a/devel/libowfat/Makefile b/devel/libowfat/Makefile
index df11e4928992..bfd003244f8b 100644
--- a/devel/libowfat/Makefile
+++ b/devel/libowfat/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libowfat
-PORTVERSION= 0.21
+PORTVERSION= 0.22
CATEGORIES= devel ipv6
MASTER_SITES= http://dl.fefe.de/
@@ -29,10 +29,13 @@ CFLAGS+= -O2 -fomit-frame-pointer
.include "${FILESDIR}/manpages"
-examples= examples/byte.c examples/str.c
-examplesdir= ${EXAMPLESDIR:S,^${PREFIX}/,,}
-PLIST_DIRS= ${examplesdir}
-PLIST_FILES= lib/libowfat.a ${examples:S,^examples/,${examplesdir}/,}
+include= array.h buffer.h byte.h case.h dns.h errmsg.h fmt.h \
+ havealloca.h io.h iob.h iopause.h ip4.h ip6.h mmap.h \
+ ndelay.h open.h openreadclose.h readclose.h safemult.h \
+ scan.h socket.h str.h stralloc.h tai.h taia.h textcode.h \
+ uint16.h uint32.h uint64.h
+PLIST_DIRS= include/libowfat
+PLIST_FILES= ${include:S,^,include/libowfat/,} lib/libowfat.a
.if!defined(NOPORTDOCS)
PORTDOCS= CHANGES README TODO
.endif
@@ -42,11 +45,5 @@ post-install:
${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
- ${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${examples} ${EXAMPLESDIR}
-# add installed header files to packaging list:
- @cd ${PREFIX} && \
- ${FIND} include/libowfat -type f -o -type l | ${SORT} >>${TMPPLIST}
- @${ECHO_CMD} "@dirrm include/libowfat" >>${TMPPLIST}
.include <bsd.port.post.mk>
diff --git a/devel/libowfat/distinfo b/devel/libowfat/distinfo
index 147bec382e76..95e515ebfab3 100644
--- a/devel/libowfat/distinfo
+++ b/devel/libowfat/distinfo
@@ -1,2 +1,2 @@
-MD5 (libowfat-0.21.tar.bz2) = 4023b5ecadbfb5c8ef81f956a42b7529
-SIZE (libowfat-0.21.tar.bz2) = 118300
+MD5 (libowfat-0.22.tar.bz2) = 19468178a3b14083f30f6de694652d18
+SIZE (libowfat-0.22.tar.bz2) = 111045
diff --git a/devel/libowfat/files/manpages b/devel/libowfat/files/manpages
index f86fdb087ff8..1a922a395fef 100644
--- a/devel/libowfat/files/manpages
+++ b/devel/libowfat/files/manpages
@@ -152,8 +152,10 @@ iob_addfile.3 \
iob_addfile_close.3 \
iob_adds.3 \
iob_adds_free.3 \
+iob_free.3 \
iob_new.3 \
iob_prefetch.3 \
+iob_reset.3 \
iob_send.3 \
iob_write.3 \
iopause.3 \