aboutsummaryrefslogtreecommitdiff
path: root/devel/libowfat
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-28 12:17:09 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-28 12:17:09 +0000
commitdec3023b9965ee1116a90d38d28aff180e964fde (patch)
tree68fef28eb9a8cddc370e04a838d07166719cfe8b /devel/libowfat
parenta27a0d1e06089a46f282438553b9425c85141495 (diff)
downloadports-dec3023b9965ee1116a90d38d28aff180e964fde.tar.gz
ports-dec3023b9965ee1116a90d38d28aff180e964fde.zip
Notes
Diffstat (limited to 'devel/libowfat')
-rw-r--r--devel/libowfat/Makefile7
-rw-r--r--devel/libowfat/distinfo4
-rw-r--r--devel/libowfat/files/manpages14
-rw-r--r--devel/libowfat/files/patch-GNUmakefile18
-rw-r--r--devel/libowfat/files/patch-io-io_tryread.c13
-rw-r--r--devel/libowfat/files/patch-io-io_trywrite.c13
6 files changed, 27 insertions, 42 deletions
diff --git a/devel/libowfat/Makefile b/devel/libowfat/Makefile
index df68ca2dd40f..6d9580b4cc34 100644
--- a/devel/libowfat/Makefile
+++ b/devel/libowfat/Makefile
@@ -6,9 +6,8 @@
#
PORTNAME= libowfat
-PORTVERSION= 0.18
-PORTREVISION= 1
-CATEGORIES= devel
+PORTVERSION= 0.19.2
+CATEGORIES= devel ipv6
MASTER_SITES= http://dl.fefe.de/
MAINTAINER= tmseck@netcologne.de
@@ -18,7 +17,7 @@ USE_BZIP2= YES
USE_GMAKE= YES
MAKEFILE= GNUmakefile
-MAKE_ENV+= MAN3PREFIX=${MAN3PREFIX}
+MAKE_ENV+= INSTALL="${INSTALL}"
OPTIONS= LIBOWFAT_OPTIMIZED_CFLAGS "Use optimized CFLAGS" on
diff --git a/devel/libowfat/distinfo b/devel/libowfat/distinfo
index a06c847ffc7d..4a56eb38d960 100644
--- a/devel/libowfat/distinfo
+++ b/devel/libowfat/distinfo
@@ -1,2 +1,2 @@
-MD5 (libowfat-0.18.tar.bz2) = 112dcc80db665f6c43e7961343cd84e1
-SIZE (libowfat-0.18.tar.bz2) = 96786
+MD5 (libowfat-0.19.2.tar.bz2) = 7aea51f394d55223eec5820cc84d32f5
+SIZE (libowfat-0.19.2.tar.bz2) = 104852
diff --git a/devel/libowfat/files/manpages b/devel/libowfat/files/manpages
index 00f89d1a995a..cc1bb72789d6 100644
--- a/devel/libowfat/files/manpages
+++ b/devel/libowfat/files/manpages
@@ -21,7 +21,16 @@ fmt_httpdate.3 fmt_human.3 fmt_humank.3 fmt_ip4.3 fmt_ip6.3 \
fmt_ip6_flat.3 fmt_ip6c.3 fmt_ip6if.3 fmt_ip6ifc.3 fmt_long.3 \
fmt_longlong.3 fmt_minus.3 fmt_pad.3 fmt_plusminus.3 fmt_str.3 \
fmt_strn.3 fmt_uint.3 fmt_uint0.3 fmt_ulong.3 fmt_ulong0.3 \
-fmt_ulonglong.3 fmt_xlong.3 fmt_xlonglong.3 iopause.3 mmap_private.3 \
+fmt_ulonglong.3 fmt_xlong.3 fmt_xlonglong.3 imult16.3 imult32.3 \
+imult64.3 io_canread.3 io_canwrite.3 io_check.3 io_close.3 \
+io_closeonexec.3 io_createfile.3 io_dontwantread.3 io_dontwantwrite.3 \
+io_eagain.3 io_fd.3 io_finishandshutdown.3 io_getcookie.3 io_nonblock.3 \
+io_passfd.3 io_pipe.3 io_readfile.3 io_receivefd.3 io_sendfile.3 \
+io_setcookie.3 io_socketpair.3 io_timeout.3 io_timeouted.3 io_tryread.3 \
+io_tryreadtimeout.3 io_trywrite.3 io_trywritetimeout.3 io_wait.3 \
+io_waitread.3 io_waituntil.3 io_wantread.3 io_wantwrite.3 iob_addbuf.3 \
+iob_addbuf_free.3 iob_addfile.3 iob_addfile_close.3 iob_adds.3 \
+iob_adds_free.3 iob_new.3 iob_prefetch.3 iob_send.3 iopause.3 mmap_private.3 \
mmap_read.3 mmap_shared.3 ndelay_off.3 ndelay_on.3 open_append.3 \
open_excl.3 open_read.3 open_rw.3 open_trunc.3 open_write.3 \
openreadclose.3 readclose.3 readclose_append.3 scan_8int.3 scan_8long.3 \
@@ -50,4 +59,5 @@ taia_add.3 taia_addsec.3 taia_approx.3 taia_frac.3 taia_less.3 \
taia_now.3 taia_pack.3 taia_sub.3 taia_tai.3 taia_uint.3 taia_unpack.3 \
uint16_pack.3 uint16_pack_big.3 uint16_read.3 uint16_read_big.3 \
uint16_unpack.3 uint16_unpack_big.3 uint32_pack.3 uint32_pack_big.3 \
-uint32_read.3 uint32_read_big.3 uint32_unpack.3 uint32_unpack_big.3
+uint32_read.3 uint32_read_big.3 uint32_unpack.3 uint32_unpack_big.3 \
+umult16.3 umult32.3 umult64.3
diff --git a/devel/libowfat/files/patch-GNUmakefile b/devel/libowfat/files/patch-GNUmakefile
index cc9d63077071..6c021e9f53ef 100644
--- a/devel/libowfat/files/patch-GNUmakefile
+++ b/devel/libowfat/files/patch-GNUmakefile
@@ -1,5 +1,5 @@
---- GNUmakefile.orig Sat Feb 21 23:01:27 2004
-+++ GNUmakefile Sat Feb 21 23:06:27 2004
+--- GNUmakefile.orig Sat Mar 27 18:25:44 2004
++++ GNUmakefile Sat Mar 27 20:31:04 2004
@@ -4,20 +4,16 @@
# in /opt/diet, where they are in the default search path for my diet libc
# work but don't conflict with anything there. YMMV.
@@ -10,7 +10,7 @@
-INCLUDEDIR=${prefix}/include
-MAN3DIR=${prefix}/man/man3
+INCLUDEDIR=${prefix}/include/libowfat
-+MAN3DIR=${MAN3PREFIX}/man/man3
++MAN3DIR=${MANPREFIX}/man/man3
LIBS=byte.a fmt.a scan.a str.a uint.a open.a stralloc.a unix.a socket.a \
buffer.a mmap.a taia.a tai.a dns.a case.a mult.a array.a io.a textcode.a
@@ -24,16 +24,18 @@
# startrip
ifneq ($(DEBUG),)
CFLAGS=-pipe -Wall -g
-@@ -147,9 +143,9 @@
+@@ -146,10 +142,10 @@
+ openreadclose.h readclose.h ndelay.h array.h io.h safemult.h iob.h havealloca.h
install: libowfat.a
- install -d $(INCLUDEDIR) $(MAN3DIR) $(LIBDIR)
+- install -d $(INCLUDEDIR) $(MAN3DIR) $(LIBDIR)
- install -m 644 $(INCLUDES) $(INCLUDEDIR)
- install -m 644 $(wildcard */*.3) $(MAN3DIR)
- install -m 644 libowfat.a $(LIBDIR)
-+ install -m 444 $(INCLUDES) $(INCLUDEDIR)
-+ install -m 444 $(wildcard */*.3) $(MAN3DIR)
-+ install -m 444 libowfat.a $(LIBDIR)
++ ${INSTALL} -d $(INCLUDEDIR) $(MAN3DIR) $(LIBDIR)
++ ${BSD_INSTALL_DATA} $(INCLUDES) $(INCLUDEDIR)
++ ${BSD_INSTALL_MAN} $(wildcard */*.3) $(MAN3DIR)
++ ${BSD_INSTALL_DATA} libowfat.a $(LIBDIR)
uninstall:
rm -f $(patsubst %.h,$(INCLUDEDIR)/%.h,$(INCLUDES))
diff --git a/devel/libowfat/files/patch-io-io_tryread.c b/devel/libowfat/files/patch-io-io_tryread.c
deleted file mode 100644
index 5c4983c1e7ab..000000000000
--- a/devel/libowfat/files/patch-io-io_tryread.c
+++ /dev/null
@@ -1,13 +0,0 @@
-! fix a possible signal handling race condition
-! obtained from libowfat cvs
---- io/io_tryread.c 7 Nov 2003 22:11:30 -0000 1.4
-+++ io/io_tryread.c 7 Mar 2004 21:48:56 -0000 1.5
-@@ -21,7 +21,7 @@
- e->next_read=-1;
- return -1;
- }
-- new.it_interval.tv_usec=0;
-+ new.it_interval.tv_usec=10000;
- new.it_interval.tv_sec=0;
- new.it_value.tv_usec=10000;
- new.it_value.tv_sec=0;
diff --git a/devel/libowfat/files/patch-io-io_trywrite.c b/devel/libowfat/files/patch-io-io_trywrite.c
deleted file mode 100644
index d65ffaa46cc0..000000000000
--- a/devel/libowfat/files/patch-io-io_trywrite.c
+++ /dev/null
@@ -1,13 +0,0 @@
-! fix a possible signal handling race condition
-! obtained from libowfat cvs
---- io/io_trywrite.c 27 Feb 2004 17:04:03 -0000 1.5
-+++ io/io_trywrite.c 7 Mar 2004 21:48:56 -0000 1.6
-@@ -22,7 +22,7 @@
- e->next_write=-1;
- return -1;
- }
-- new.it_interval.tv_usec=0;
-+ new.it_interval.tv_usec=10000;
- new.it_interval.tv_sec=0;
- new.it_value.tv_usec=10000;
- new.it_value.tv_sec=0;