aboutsummaryrefslogtreecommitdiff
path: root/devel/libphish/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-05 21:30:34 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-05 21:30:34 +0000
commitb50c4a004fcfcbcd06e3a4cadd315b15fa469127 (patch)
tree09ba962029988558164753b32cebdb7448295f07 /devel/libphish/Makefile
parentf0dcdd522f5810814e07bb02b63e106dee735aeb (diff)
downloadports-b50c4a004fcfcbcd06e3a4cadd315b15fa469127.tar.gz
ports-b50c4a004fcfcbcd06e3a4cadd315b15fa469127.zip
Notes
Diffstat (limited to 'devel/libphish/Makefile')
-rw-r--r--devel/libphish/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/libphish/Makefile b/devel/libphish/Makefile
new file mode 100644
index 000000000000..565861d0c90a
--- /dev/null
+++ b/devel/libphish/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: libphish
+# Date created: 17 Apr 2006
+# Whom: Rashid N. Achilov <shelton@granch.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libphish
+PORTVERSION= 0.1.0
+CATEGORIES= devel
+MASTER_SITES= http://download.berlios.de/opdb/ \
+ http://download2.berlios.de/opdb/ \
+
+MAINTAINER= shelton@granch.ru
+COMMENT= A cross-platform library to interact with the Open Phishing Database
+
+BUILD_DEPENDS= xmlwf:${PORTSDIR}/textproc/expat2
+
+USE_BZIP2= yes
+INSTALLS_SHLIB= yes
+USE_GCC= 3.2+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CPPFLAGS= -I${LOCALBASE}/include -DFreeBSD
+LDFLAGS= -L${LOCALBASE}/lib
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} `${LS}` ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>