aboutsummaryrefslogtreecommitdiff
path: root/devel/libphk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2008-09-08 09:20:56 +0000
committerMathieu Arnold <mat@FreeBSD.org>2008-09-08 09:20:56 +0000
commit68a531ccd7d9c6e105df758221c34b2470c5b1a2 (patch)
treea3db75a1e1f39e2517920e366a9c3f1a272ceb16 /devel/libphk
parent2322ba05b2451ef07169a55c7430057fe1d49b88 (diff)
downloadports-68a531ccd7d9c6e105df758221c34b2470c5b1a2.tar.gz
ports-68a531ccd7d9c6e105df758221c34b2470c5b1a2.zip
Notes
Diffstat (limited to 'devel/libphk')
-rw-r--r--devel/libphk/Makefile1
-rw-r--r--devel/libphk/files/patch-phk__expr.c22
2 files changed, 23 insertions, 0 deletions
diff --git a/devel/libphk/Makefile b/devel/libphk/Makefile
index cc54e61eff91..e0a5808159aa 100644
--- a/devel/libphk/Makefile
+++ b/devel/libphk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libphk
PORTVERSION= 0.3.20080902
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://phk.freebsd.dk/phkrel/ \
${MASTER_SITE_LOCAL}
diff --git a/devel/libphk/files/patch-phk__expr.c b/devel/libphk/files/patch-phk__expr.c
new file mode 100644
index 000000000000..1552f4182969
--- /dev/null
+++ b/devel/libphk/files/patch-phk__expr.c
@@ -0,0 +1,22 @@
+--- phk_expr.c~ 2008-04-29 18:50:56.000000000 +0000
++++ phk_expr.c 2008-09-08 09:17:19.205920000 +0000
+@@ -52,8 +52,8 @@
+ {
+ if (1)
+ return;
+- fprintf(stderr, "<%*.*s|", e->p - e->b, e->p - e->b, e->b);
+- fprintf(stderr, "%*.*s> %s\n", e->e - e->p, e->e - e->p, e->p, w);
++ fprintf(stderr, "<%*.*s|", (int)(e->p - e->b), (int)(e->p - e->b), e->b);
++ fprintf(stderr, "%*.*s> %s\n", (int)(e->e - e->p), (int)(e->e - e->p), e->p, w);
+ }
+
+ /*
+@@ -289,7 +289,7 @@
+ if (e->err != NULL) {
+ if (errs != NULL)
+ asprintf(errs, "Expression error:\n%s\n%*.*s^ %s\n",
+- e->b, e->p - e->b, e->p - e->b, "", e->err);
++ e->b, (int)(e->p - e->b), (int)(e->p - e->b), "", e->err);
+ return (NAN);
+ }
+ return (v);