aboutsummaryrefslogtreecommitdiff
path: root/devel/libphk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2008-09-02 15:13:18 +0000
committerMathieu Arnold <mat@FreeBSD.org>2008-09-02 15:13:18 +0000
commit694a4d9f5e44174814c7065fa3db215b61ee7a3c (patch)
tree6fab49bcbb5273a606bebfe9efbcc582aec1f94b /devel/libphk
parentff9a3917dca5fab5e5b99d9a1d7e89bd6096cb20 (diff)
downloadports-694a4d9f5e44174814c7065fa3db215b61ee7a3c.tar.gz
ports-694a4d9f5e44174814c7065fa3db215b61ee7a3c.zip
Notes
Diffstat (limited to 'devel/libphk')
-rw-r--r--devel/libphk/Makefile28
-rw-r--r--devel/libphk/distinfo3
-rw-r--r--devel/libphk/pkg-descr3
-rw-r--r--devel/libphk/pkg-plist12
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/libphk/Makefile b/devel/libphk/Makefile
new file mode 100644
index 000000000000..06967d51c086
--- /dev/null
+++ b/devel/libphk/Makefile
@@ -0,0 +1,28 @@
+# New ports collection Makefile for: Libphk
+# Date created: 2 September 2008
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= libphk
+PORTVERSION= 0.3.20080902
+CATEGORIES= devel
+MASTER_SITES= http://phk.freebsd.dk/phkrel/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR=mat
+DISTNAME= Libphk.${PORTVERSION:C/0.3.//}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Function used by a few other ports
+
+WRKSRC= ${WRKDIR}/Libphk
+
+MAN3= libphk.3 phk_argv.3 phk_binheap.3
+MANCOMPRESSED= yes
+
+post-patch:
+ @${SED} -i -e 's!/usr/local!$${PREFIX}!g' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/devel/libphk/distinfo b/devel/libphk/distinfo
new file mode 100644
index 000000000000..8f49e5a25f58
--- /dev/null
+++ b/devel/libphk/distinfo
@@ -0,0 +1,3 @@
+MD5 (Libphk.20080902.tgz) = c42088a89bebcd1186c3d3d091677709
+SHA256 (Libphk.20080902.tgz) = 1d27c8da0371ebedf90a1a7e07f765c42b3947b79eaa140d4412fbd7b8b038fb
+SIZE (Libphk.20080902.tgz) = 20480
diff --git a/devel/libphk/pkg-descr b/devel/libphk/pkg-descr
new file mode 100644
index 000000000000..3926460aba07
--- /dev/null
+++ b/devel/libphk/pkg-descr
@@ -0,0 +1,3 @@
+A somewhat prototypical facility for generating CLI interfaces.
+
+WWW: http://phk.freebsd.dk/phkrel/
diff --git a/devel/libphk/pkg-plist b/devel/libphk/pkg-plist
new file mode 100644
index 000000000000..cbead339036c
--- /dev/null
+++ b/devel/libphk/pkg-plist
@@ -0,0 +1,12 @@
+@comment $FreeBSD$
+include/phk_argv.h
+include/phk_binheap.h
+include/phk_expr.h
+include/phk_ihex.h
+include/phk_tcp.h
+include/phk_obj.h
+include/phk_event.h
+include/phk_modbus.h
+include/phk_lineup.h
+lib/libphk.a
+lib/libphk_p.a