aboutsummaryrefslogtreecommitdiff
path: root/devel/libplist
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-02-28 05:06:26 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-02-28 05:06:26 +0000
commit822ac0a5ff8f3b0a53e117944b25bca73eceb9cf (patch)
tree9925f1f470cd5466210c0b117a9a528e1242d8fd /devel/libplist
parentf0d74dc4264f187c11319626069945ba240416d5 (diff)
downloadports-822ac0a5ff8f3b0a53e117944b25bca73eceb9cf.tar.gz
ports-822ac0a5ff8f3b0a53e117944b25bca73eceb9cf.zip
Notes
Diffstat (limited to 'devel/libplist')
-rw-r--r--devel/libplist/Makefile54
-rw-r--r--devel/libplist/distinfo2
-rw-r--r--devel/libplist/pkg-descr11
-rw-r--r--devel/libplist/pkg-plist29
4 files changed, 96 insertions, 0 deletions
diff --git a/devel/libplist/Makefile b/devel/libplist/Makefile
new file mode 100644
index 000000000000..34e73d7114b5
--- /dev/null
+++ b/devel/libplist/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: libplist
+# Date created: 28 May 2010
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= libplist
+PORTVERSION= 1.3
+CATEGORIES= devel
+MASTER_SITES= http://www.libimobiledevice.org/downloads/
+
+MAINTAINER= avilla@FreeBSD.org
+COMMENT= A library to handle Apple Property List format
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
+
+USE_BZIP2= yes
+USE_GNOME= glib20 libxml2
+USE_ICONV= yes
+MAKE_JOBS_SAFE= yes
+USE_CMAKE= yes
+CFLAGS+= -I${LOCALBASE}/include
+USE_LDCONFIG= yes
+
+PORTDOCS= AUTHORS README
+
+OPTIONS= PYTHON "Enable Python bindings (needs Swig)" off
+
+.include <bsd.port.options.mk>
+
+.ifdef(WITH_PYTHON)
+BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
+USE_PYTHON= yes
+CMAKE_ARGS+= -DENABLE_PYTHON:BOOL=On
+PLIST_SUB+= PYTHON=""
+.else
+CMAKE_ARGS+= -DENABLE_PYTHON:BOOL=Off
+PLIST_SUB+= PYTHON="@comment "
+.endif
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's:$${CMAKE_INSTALL_LIBDIR}/pkgconfig:libdata/pkgconfig:' \
+ ${WRKSRC}/CMakeLists.txt
+
+post-install:
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/libplist/distinfo b/devel/libplist/distinfo
new file mode 100644
index 000000000000..40899fdcb332
--- /dev/null
+++ b/devel/libplist/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libplist-1.3.tar.bz2) = 982c8aac59cdc3fafc925a407a29b6cf367c5ec9bad6ad509fe5ea25d3e5b6b0
+SIZE (libplist-1.3.tar.bz2) = 67642
diff --git a/devel/libplist/pkg-descr b/devel/libplist/pkg-descr
new file mode 100644
index 000000000000..0a4cd845ab1d
--- /dev/null
+++ b/devel/libplist/pkg-descr
@@ -0,0 +1,11 @@
+libimobiledevice is a software library that talks the protocols to
+support iPhone, iPod Touch and iPad devices on Linux. Unlike other
+projects, it does not depend on using any existing proprietary
+libraries and does not require jailbreaking. It allows other software
+to easily access the device's filesystem, retrieve information about
+the device and its internals, backup/restore the device, manage
+SpringBoard icons, manage installed applications, retrieve
+addressbook/calendars/notes and bookmarks and synchronize music and
+video to the device.
+
+WWW: http://www.libimobiledevice.org
diff --git a/devel/libplist/pkg-plist b/devel/libplist/pkg-plist
new file mode 100644
index 000000000000..8a2d28471a61
--- /dev/null
+++ b/devel/libplist/pkg-plist
@@ -0,0 +1,29 @@
+bin/plutil
+bin/plutil-1.3
+include/plist/Array.h
+include/plist/Boolean.h
+include/plist/Data.h
+include/plist/Date.h
+include/plist/Dictionary.h
+include/plist/Integer.h
+include/plist/Node.h
+include/plist/Real.h
+include/plist/String.h
+include/plist/Structure.h
+include/plist/plist++.h
+include/plist/plist.h
+%%PYTHON%%include/plist/swig/plist.i
+lib/libplist++.so
+lib/libplist++.so.1
+lib/libplist++.so.1.1.3
+lib/libplist.so
+lib/libplist.so.1
+lib/libplist.so.1.1.3
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/plist/__init__.py
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/plist/_plist.so
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/plist/plist.py
+libdata/pkgconfig/libplist++.pc
+libdata/pkgconfig/libplist.pc
+%%PYTHON%%@dirrm %%PYTHON_SITELIBDIR%%/plist
+%%PYTHON%%@dirrm include/plist/swig
+@dirrm include/plist