aboutsummaryrefslogtreecommitdiff
path: root/devel/libpo6
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-09-23 01:24:30 +0000
committerSteve Wills <swills@FreeBSD.org>2018-09-23 01:24:30 +0000
commit268ae88ebeaa20184188bb3240410b17be16a4ad (patch)
treeaa162e84617011e95c9235933f372efa274e1673 /devel/libpo6
parent7a439a9bafb74e3422cf1ef30f247e80caa87ceb (diff)
Notes
Diffstat (limited to 'devel/libpo6')
-rw-r--r--devel/libpo6/Makefile10
-rw-r--r--devel/libpo6/distinfo5
-rw-r--r--devel/libpo6/files/patch-errno.cc43
-rw-r--r--devel/libpo6/files/patch-po6-net-ipaddr.h13
-rw-r--r--devel/libpo6/pkg-plist7
5 files changed, 58 insertions, 20 deletions
diff --git a/devel/libpo6/Makefile b/devel/libpo6/Makefile
index 67a031fb87a3..17fb611f0d84 100644
--- a/devel/libpo6/Makefile
+++ b/devel/libpo6/Makefile
@@ -2,16 +2,18 @@
# $FreeBSD$
PORTNAME= libpo6
-PORTVERSION= 0.5.2
+PORTVERSION= 0.8.0
CATEGORIES= devel
MASTER_SITES= http://hyperdex.org/src/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ndowens@yahoo.com
COMMENT= POSIX wrappers for C++
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+TEST_TARGET= check
GNU_CONFIGURE= yes
-USES= gmake pathfix
-
+USES= gmake libtool pathfix
+USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/devel/libpo6/distinfo b/devel/libpo6/distinfo
index f5d032c2aaf3..7a5ed29413e6 100644
--- a/devel/libpo6/distinfo
+++ b/devel/libpo6/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libpo6-0.5.2.tar.gz) = fd59e2b3597261e10f91da17f07de6b8ee71ffe2d0cdb7affd8ec33fdb763ec9
-SIZE (libpo6-0.5.2.tar.gz) = 106956
+TIMESTAMP = 1534474698
+SHA256 (libpo6-0.8.0.tar.gz) = 5aedaf96326fe76f6b71bcc7713a741fcdeb694a8c818ca240c74b61de4e4b0d
+SIZE (libpo6-0.8.0.tar.gz) = 364709
diff --git a/devel/libpo6/files/patch-errno.cc b/devel/libpo6/files/patch-errno.cc
new file mode 100644
index 000000000000..3a3d109e81cf
--- /dev/null
+++ b/devel/libpo6/files/patch-errno.cc
@@ -0,0 +1,43 @@
+--- errno.cc.orig 2018-08-17 03:05:05 UTC
++++ errno.cc
+@@ -27,7 +27,6 @@
+
+ // C
+ #include <string.h>
+-#include <string.h>
+
+ // POSIX
+ #include <errno.h>
+@@ -43,12 +42,17 @@ po6 :: strerror(int err)
+ memset(buf, 0, sizeof(buf));
+
+ errno = 0;
+-#if (_POSIX_C_SOURCE >= 200112L || _XOPEN_SOURCE >= 600) && ! _GNU_SOURCE
++#if _GNU_SOURCE
++ // GNU
++ char* ret = strerror_r(err, buf, sizeof(buf));
++
++ if (ret != buf)
++ {
++ strncpy(buf, ret, sizeof(buf));
++ }
++#else
+ // XSI-compliant
+ errno = strerror_r(err, buf, sizeof(buf));
+-#else
+- // GNU
+- strncpy(buf, strerror_r(err, buf, sizeof(buf)), sizeof(buf));
+ #endif
+ int obs = errno;
+ errno = saved;
+@@ -62,9 +66,7 @@ po6 :: strerror(int err)
+ return std::string(buf);
+ }
+
+-#define XSTR(x) #x
+-#define STR(x) XSTR(x)
+-#define CSTRINGIFY(x) if ((x) == err) { return STR(x); }
++#define CSTRINGIFY(x) if ((x) == err) { return #x; }
+
+ const char*
+ po6 :: strerrno(int err)
diff --git a/devel/libpo6/files/patch-po6-net-ipaddr.h b/devel/libpo6/files/patch-po6-net-ipaddr.h
deleted file mode 100644
index 78ad5ba87ec9..000000000000
--- a/devel/libpo6/files/patch-po6-net-ipaddr.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- po6/net/ipaddr.h.orig 2015-01-05 09:06:24.000000000 +0100
-+++ po6/net/ipaddr.h 2015-01-05 09:12:13.000000000 +0100
-@@ -42,6 +42,10 @@
- #include <sys/socket.h>
- #endif
-
-+#if defined(__FreeBSD__)
-+#include <sys/types.h>
-+#endif
-+
- // STL
- #include <string>
-
diff --git a/devel/libpo6/pkg-plist b/devel/libpo6/pkg-plist
index 10fe65f6dda4..ef87b1245f13 100644
--- a/devel/libpo6/pkg-plist
+++ b/devel/libpo6/pkg-plist
@@ -1,5 +1,7 @@
+include/po6/errno.h
include/po6/error.h
include/po6/io/fd.h
+include/po6/io/mmap.h
include/po6/net/hostname.h
include/po6/net/ipaddr.h
include/po6/net/location.h
@@ -10,6 +12,9 @@ include/po6/threads/barrier.h
include/po6/threads/cond.h
include/po6/threads/mutex.h
include/po6/threads/rwlock.h
-include/po6/threads/spinlock.h
include/po6/threads/thread.h
+lib/libpo6.a
+lib/libpo6.so
+lib/libpo6.so.0
+lib/libpo6.so.0.0.0
libdata/pkgconfig/libpo6.pc