aboutsummaryrefslogtreecommitdiff
path: root/devel/libpperl
diff options
context:
space:
mode:
authorKelly Yancey <kbyanc@FreeBSD.org>2005-12-15 01:58:58 +0000
committerKelly Yancey <kbyanc@FreeBSD.org>2005-12-15 01:58:58 +0000
commitdc81a0dac81a4f5d2911fe5905872c534a1ec160 (patch)
tree020264613a8f31a1ce637e91e4aa5019b3e7f222 /devel/libpperl
parent9643bc0f551e51e49b1c53007ec42634642df681 (diff)
Notes
Diffstat (limited to 'devel/libpperl')
-rw-r--r--devel/libpperl/Makefile31
-rw-r--r--devel/libpperl/distinfo2
-rw-r--r--devel/libpperl/pkg-descr2
-rw-r--r--devel/libpperl/pkg-plist4
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/libpperl/Makefile b/devel/libpperl/Makefile
new file mode 100644
index 000000000000..980b33bddf02
--- /dev/null
+++ b/devel/libpperl/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: libpperl
+# Date created: December 14, 2005
+# Whom: Kelly Yancey <kbyanc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libpperl
+PORTVERSION= 20051214
+CATEGORIES= devel
+MASTER_SITES= http://people.freebsd.org/~kbyanc/ \
+ http://www.posi.net/software/libpperl/
+
+MAINTAINER= kbyanc@FreeBSD.org
+COMMENT= A library easing embedding perl interpreters into C programs
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= pkgconfig
+USE_PERL5= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= this library only supports perl 5.8.0 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libpperl/distinfo b/devel/libpperl/distinfo
new file mode 100644
index 000000000000..66173726c4a7
--- /dev/null
+++ b/devel/libpperl/distinfo
@@ -0,0 +1,2 @@
+MD5 (libpperl-20051214.tar.gz) = 7a2dab5f0c57aa60b3e6486e328356df
+SIZE (libpperl-20051214.tar.gz) = 749418
diff --git a/devel/libpperl/pkg-descr b/devel/libpperl/pkg-descr
new file mode 100644
index 000000000000..6ae64d750af7
--- /dev/null
+++ b/devel/libpperl/pkg-descr
@@ -0,0 +1,2 @@
+libpperl is a library abstracting the embedded perl interface so as to
+transparently handle as many of the hairy edge cases as possible.
diff --git a/devel/libpperl/pkg-plist b/devel/libpperl/pkg-plist
new file mode 100644
index 000000000000..26a13eff6087
--- /dev/null
+++ b/devel/libpperl/pkg-plist
@@ -0,0 +1,4 @@
+include/pperl.h
+lib/libpperl.so.0
+lib/libpperl.a
+libdata/pkgconfig/libpperl.pc