aboutsummaryrefslogtreecommitdiff
path: root/devel/libqxt
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-04 14:52:26 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-04 14:52:26 +0000
commitd9afd799b96abcb2b3d89b7dfff69c294870864b (patch)
tree5257c7f747c57118c35ab7350550bb637692d2d2 /devel/libqxt
parentbefd393463c281c9ec1339fae06b8d3f288d93c5 (diff)
Notes
Diffstat (limited to 'devel/libqxt')
-rw-r--r--devel/libqxt/Makefile14
-rw-r--r--devel/libqxt/files/patch-src-designer_designer.pro2
-rw-r--r--devel/libqxt/pkg-plist6
3 files changed, 14 insertions, 8 deletions
diff --git a/devel/libqxt/Makefile b/devel/libqxt/Makefile
index df196dd3ec8c..2a1bbecba585 100644
--- a/devel/libqxt/Makefile
+++ b/devel/libqxt/Makefile
@@ -10,7 +10,7 @@ DISTNAME= v${PORTVERSION}
MAINTAINER= gahr@FreeBSD.org
COMMENT= Extension library for Qt
-LIB_DEPENDS= dns_sd:${PORTSDIR}/net/avahi-libdns
+LIB_DEPENDS= libdns_sd.so:${PORTSDIR}/net/avahi-libdns
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
USE_BDB= 44+
@@ -21,10 +21,10 @@ USE_LDCONFIG= ${PREFIX}/lib/qxt
QT_NONSTANDARD= yes
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= -prefix ${PREFIX} \
- -libdir ${PREFIX}/lib/qxt \
+CONFIGURE_ARGS= -prefix ${STAGEDIR}${PREFIX} \
+ -libdir ${STAGEDIR}${PREFIX}/lib/qxt \
-qmake-bin ${QMAKE} \
- -featuredir ${PREFIX}/share/qt4/mkspecs/features \
+ -featuredir ${STAGEDIR}${PREFIX}/share/qt4/mkspecs/features \
-I ${BDB_INCLUDE_DIR} \
-I ${LOCALBASE}/include/avahi-compat-libdns_sd \
-L ${BDB_LIB_DIR} \
@@ -37,10 +37,10 @@ PLIST_SUB+= SHVER_1=${PORTVERSION} \
SHVER_2=${PORTVERSION:R} \
SHVER_3=${PORTVERSION:R:R}
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e '\
s|%%PREFIX%%|${PREFIX}|g; \
+ s|%%STAGEDIR%%|${STAGEDIR}|g; \
s|/bin/bash|${LOCALBASE}/bin/bash|g; \
/^QXT_MODULES/s|docs||g' \
${WRKSRC}/configure \
@@ -50,6 +50,10 @@ post-patch:
/INCLUDEPATH/s|\.|${BDB_INCLUDE_DIR}|g' \
${WRKSRC}/config.tests/db/db.pro
+post-configure:
+ ${REINPLACE_CMD} -e 's|${STAGEDIR}||g' \
+ ${WRKSRC}/features/qxtvars.prf
+
regression-test:
cd ${WRKSRC}/tests && \
${QMAKE} tests.pro && ${MAKE} && \
diff --git a/devel/libqxt/files/patch-src-designer_designer.pro b/devel/libqxt/files/patch-src-designer_designer.pro
index 69818e750354..e42707e3520f 100644
--- a/devel/libqxt/files/patch-src-designer_designer.pro
+++ b/devel/libqxt/files/patch-src-designer_designer.pro
@@ -5,5 +5,5 @@
CONFIG += designer plugin
-target.path = $$[QT_INSTALL_PLUGINS]/designer
-+target.path = %%PREFIX%%/lib/qt4/plugins/designer
++target.path = %%STAGEDIR%%%%PREFIX%%/lib/qt4/plugins/designer
INSTALLS = target
diff --git a/devel/libqxt/pkg-plist b/devel/libqxt/pkg-plist
index 43c9959d4e58..571ce992ada8 100644
--- a/devel/libqxt/pkg-plist
+++ b/devel/libqxt/pkg-plist
@@ -319,7 +319,7 @@ include/QxtZeroconf/qxtmdns_avahi.h
include/QxtZeroconf/qxtmdns_avahi_p.h
include/QxtZeroconf/qxtservicebrowser.h
include/QxtZeroconf/qxtservicebrowser_p.h
-lib/qt4/plugins/designer/libQxtDesignerPlugins.so
+%%QT_PLUGINDIR%%/designer/libQxtDesignerPlugins.so
lib/qxt/libQxtBerkeley.so
lib/qxt/libQxtBerkeley.so.%%SHVER_1%%
lib/qxt/libQxtBerkeley.so.%%SHVER_2%%
@@ -358,7 +358,9 @@ share/qt4/mkspecs/features/qxtvars.prf
@dirrm include/QxtZeroconf
@dirrm include/QxtWeb
@dirrm lib/qxt
-@dirrmtry lib/qt4/plugins/designer
+@dirrmtry %%QT_PLUGINDIR%%/designer
@dirrmtry share/qt4/mkspecs/features
@dirrmtry share/qt4/mkspecs
@dirrmtry share/qt4
+@dirrmtry %%QT_PLUGINDIR%%
+@dirrmtry %%QT_LIBDIR%%