aboutsummaryrefslogtreecommitdiff
path: root/devel/libs11n/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-08-01 04:22:07 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-08-01 04:22:07 +0000
commitd85aec9833187dcba46527ebc232765911bcd856 (patch)
tree0d7ef0815215486cc796866c46a61efc046e8c5f /devel/libs11n/Makefile
parent14b6d8f5798825a8c119c403692e3cbe18ad4f55 (diff)
downloadports-d85aec9833187dcba46527ebc232765911bcd856.tar.gz
ports-d85aec9833187dcba46527ebc232765911bcd856.zip
Notes
Diffstat (limited to 'devel/libs11n/Makefile')
-rw-r--r--devel/libs11n/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/libs11n/Makefile b/devel/libs11n/Makefile
new file mode 100644
index 000000000000..2b55027cafac
--- /dev/null
+++ b/devel/libs11n/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: libs11n
+# Date created: 23 Nov 2005
+# Whom: aaron@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= libs11n
+PORTVERSION= 1.2.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= s11n
+DISTNAME= ${PORTNAME}-${PORTVERSION}-nobuildfiles
+EXTRACT_SUFX= .zip
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= A C++ library for easily serializing a wide variety of objects
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+USE_ZIP= yes
+USE_GCC= 3.2+
+INSTALLS_SHLIB= yes
+
+post-extract:
+ @${CP} ${PATCHDIR}/Makefile.bsd ${WRKSRC}/Makefile
+
+pre-install:
+ ${MKDIR} ${PREFIX}/include/s11n.net
+ ${MKDIR} ${PREFIX}/include/s11n.net/s11n
+ ${MKDIR} ${PREFIX}/include/s11n.net/s11n/io
+ ${MKDIR} ${PREFIX}/include/s11n.net/s11n/nodeutil
+ ${MKDIR} ${PREFIX}/include/s11n.net/s11n/plugin
+ ${MKDIR} ${PREFIX}/include/s11n.net/s11n/proxy
+ ${MKDIR} ${PREFIX}/include/s11n.net/s11n/proxy/pod
+ ${MKDIR} ${PREFIX}/include/s11n.net/s11n/proxy/std
+
+.include <bsd.port.mk>