aboutsummaryrefslogtreecommitdiff
path: root/devel/libsearpc/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-11-02 15:06:44 +0000
committerJohn Marino <marino@FreeBSD.org>2014-11-02 15:06:44 +0000
commit5619450fbc320a2d8b2a9cebdb7feea497dc0818 (patch)
treed60a25094326dece25303f9179c20ab69ab375bb /devel/libsearpc/Makefile
parent8c04387bda4f29d54ca83b3c4ed67f9ee743ee60 (diff)
downloadports-5619450fbc320a2d8b2a9cebdb7feea497dc0818.tar.gz
ports-5619450fbc320a2d8b2a9cebdb7feea497dc0818.zip
Notes
Diffstat (limited to 'devel/libsearpc/Makefile')
-rw-r--r--devel/libsearpc/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/libsearpc/Makefile b/devel/libsearpc/Makefile
new file mode 100644
index 000000000000..04b270d2a586
--- /dev/null
+++ b/devel/libsearpc/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= libsearpc
+PORTVERSION= 3.0.0
+CATEGORIES= devel
+
+MAINTAINER= yan_jingfeng@yahoo.com
+COMMENT= Simple RPC framework based on GObject System in C
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libjansson.so:${PORTSDIR}/devel/jansson \
+ libgobject-2.0.so:${PORTSDIR}/devel/glib20
+
+USE_GITHUB= yes
+GH_ACCOUNT= haiwen
+GH_TAGNAME= v3.0-latest
+GH_COMMIT= 8998e7b
+
+USES= autoreconf libtool pathfix pkgconfig python:2
+USE_LDCONFIG= yes
+PATHFIX_MAKEFILEIN= Makefile.am
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>