aboutsummaryrefslogtreecommitdiff
path: root/devel/libshhmsg
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-21 03:17:40 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-21 03:17:40 +0000
commitf7c67e5143759e1b8fac102f8403ad2ea54c385c (patch)
treed78c6d39e7bf0dfb6dcbac1d1f44de6a1c487e7c /devel/libshhmsg
parentf30769c2c6d1fb7c1978a6ba822e1ce624165501 (diff)
downloadports-f7c67e5143759e1b8fac102f8403ad2ea54c385c.tar.gz
ports-f7c67e5143759e1b8fac102f8403ad2ea54c385c.zip
Notes
Diffstat (limited to 'devel/libshhmsg')
-rw-r--r--devel/libshhmsg/Makefile8
-rw-r--r--devel/libshhmsg/distinfo2
-rw-r--r--devel/libshhmsg/files/Makefile.lib18
-rw-r--r--devel/libshhmsg/files/patch-aa61
-rw-r--r--devel/libshhmsg/pkg-plist9
5 files changed, 28 insertions, 70 deletions
diff --git a/devel/libshhmsg/Makefile b/devel/libshhmsg/Makefile
index 28747597bbe0..b5685ffa25f3 100644
--- a/devel/libshhmsg/Makefile
+++ b/devel/libshhmsg/Makefile
@@ -7,21 +7,21 @@
#
PORTNAME= libshhmsg
-PORTVERSION= 1.4.0
+PORTVERSION= 1.4.1
CATEGORIES= devel
MASTER_SITES= http://shh.thathost.com/pub-unix/files/
DISTNAME= shhmsg-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-USE_GMAKE= yes
+MAKEFILE= ${FILESDIR}/Makefile.lib
INSTALLS_SHLIB= yes
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/libshhmsg
+ @${MKDIR} ${DOCSDIR}
.for file in CREDITS README shhmsg.txt
- @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/libshhmsg
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
diff --git a/devel/libshhmsg/distinfo b/devel/libshhmsg/distinfo
index 9b804a7440b6..50be429e56bc 100644
--- a/devel/libshhmsg/distinfo
+++ b/devel/libshhmsg/distinfo
@@ -1 +1 @@
-MD5 (shhmsg-1.4.0.tar.gz) = e4bfbcef3f067af49df865d2d40d0a5d
+MD5 (shhmsg-1.4.1.tar.gz) = de300150851786eb19cb9b9ad234d7a2
diff --git a/devel/libshhmsg/files/Makefile.lib b/devel/libshhmsg/files/Makefile.lib
new file mode 100644
index 000000000000..29258a653b72
--- /dev/null
+++ b/devel/libshhmsg/files/Makefile.lib
@@ -0,0 +1,18 @@
+PREFIX?= /usr/local
+SHLIB_VER?= 1
+
+LIB= shhmsg
+LIBDIR= ${PREFIX}/lib
+SHLIB_MAJOR= ${SHLIB_VER}
+SHLIB_MINOR= 4
+NOPROFILE= yes
+NOOBJ= yes
+
+INCS= shhmsg.h
+INCDIR= ${PREFIX}/include
+
+CFLAGS+= -DHAVE_STRERROR
+
+SRCS= errno.c error.c fatal.c message.c progname.c streams.c vars.c verbose.c
+
+.include <bsd.lib.mk>
diff --git a/devel/libshhmsg/files/patch-aa b/devel/libshhmsg/files/patch-aa
deleted file mode 100644
index c66b17b240a3..000000000000
--- a/devel/libshhmsg/files/patch-aa
+++ /dev/null
@@ -1,61 +0,0 @@
---- Makefile.orig Tue Oct 13 18:11:42 1998
-+++ Makefile Sun Apr 29 23:24:10 2001
-@@ -6,7 +6,7 @@
- VERSION = $(VERMAJ).$(VERMIN).$(VERPAT)
-
- # Define SHARED as 1 for Linux shared ELF library
--#SHARED = 1
-+SHARED = 1
-
- ifeq ($(SHARED),1)
- LIBTARGET = lib$(DIST).so.$(VERSION)
-@@ -20,19 +20,19 @@
- LIBHEAD = $(DIST).h
- TARGETS = $(LIBTARGET)
-
--INSTBASEDIR = /usr/local
-+INSTBASEDIR = ${PREFIX}
- INSTLIBDIR = $(INSTBASEDIR)/lib
- INSTINCDIR = $(INSTBASEDIR)/include
--INSTALL = install -m 644
--INSTALLPROG = install -m 755
--MKDIRP = install -d -m 755
-+INSTALL = ${BSD_INSTALL_DATA}
-+INSTALLPROG = ${BSD_INSTALL_PROGRAM}
-+MKDIRP = mkdir -p
-
--CC = gcc
--OPTIM = -O2
-+#CC = gcc
-+OPTIM = $(CFLAGS)
-
- INCDIR = -I.
-
--CCOPT = -s -Wall $(OPTIM) $(INCDIR)
-+CCOPT = $(INCDIR) $(CFLAGS)
-
- # Object files to store in the library
- LIBOBJS = vars.o streams.o progname.o \
-@@ -43,7 +43,7 @@
-
- $(LIBTARGET): $(LIBOBJS)
- ifeq ($(SHARED),1)
-- $(CC) -shared -Wl,-soname,$(LIBTARGETSOMAJ) -o $(LIBTARGET) $(LIBOBJS)
-+ $(CC) -shared -Wl,-soname,$(LIBTARGETSOMAJ) -o $(LIBTARGETSOMAJ) $(LIBOBJS)
- else
- ar rcs $(LIBTARGET) $(LIBOBJS)
- endif
-@@ -56,12 +56,10 @@
-
- install: $(LIBTARGET)
- $(MKDIRP) $(INSTLIBDIR) $(INSTINCDIR)
-- $(INSTALL) $(LIBTARGET) $(INSTLIBDIR)
-+ $(INSTALL) $(LIBTARGETSOMAJ) $(INSTLIBDIR)
- $(INSTALL) $(LIBHEAD) $(INSTINCDIR)
- ifeq ($(SHARED),1)
-- ln -sf $(LIBTARGET) $(INSTLIBDIR)/$(LIBTARGETSOMAJ)
- ln -sf $(LIBTARGETSOMAJ) $(INSTLIBDIR)/$(LIBTARGETSO)
-- echo "If you use GNU/Linux, remember to run ldconfig"
- endif
-
- clean:
diff --git a/devel/libshhmsg/pkg-plist b/devel/libshhmsg/pkg-plist
index 2501b55a4930..7e419a1d0d68 100644
--- a/devel/libshhmsg/pkg-plist
+++ b/devel/libshhmsg/pkg-plist
@@ -1,8 +1,9 @@
@comment $FreeBSD$
include/shhmsg.h
+lib/libshhmsg.a
lib/libshhmsg.so
lib/libshhmsg.so.1
-share/doc/libshhmsg/CREDITS
-share/doc/libshhmsg/README
-share/doc/libshhmsg/shhmsg.txt
-@dirrm share/doc/libshhmsg
+%%PORTDOCS%%share/doc/libshhmsg/CREDITS
+%%PORTDOCS%%share/doc/libshhmsg/README
+%%PORTDOCS%%share/doc/libshhmsg/shhmsg.txt
+%%PORTDOCS%%@dirrm share/doc/libshhmsg