aboutsummaryrefslogtreecommitdiff
path: root/devel/libshhopt/files
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-04-03 01:15:54 +0000
committerSteve Price <steve@FreeBSD.org>1999-04-03 01:15:54 +0000
commit26bb1d17298aead28b8519e7495ebb31ae81d60d (patch)
tree89886204fb7bcda6f7674a3fdb0a4141e5c466b3 /devel/libshhopt/files
parentc2b29e69629822b5b30fdde297f5d067090a8efe (diff)
downloadports-26bb1d17298aead28b8519e7495ebb31ae81d60d.tar.gz
ports-26bb1d17298aead28b8519e7495ebb31ae81d60d.zip
Notes
Diffstat (limited to 'devel/libshhopt/files')
-rw-r--r--devel/libshhopt/files/Makefile8
-rw-r--r--devel/libshhopt/files/patch-aa37
2 files changed, 45 insertions, 0 deletions
diff --git a/devel/libshhopt/files/Makefile b/devel/libshhopt/files/Makefile
new file mode 100644
index 000000000000..320b6692179e
--- /dev/null
+++ b/devel/libshhopt/files/Makefile
@@ -0,0 +1,8 @@
+PREFIX = /usr/local
+LIBDIR = $(PREFIX)/lib
+INCDIR = $(PREFIX)/include
+
+CC = gcc
+
+example:
+ $(CC) -o example example.c -I$(INCDIR) -L$(LIBDIR) -lshhopt
diff --git a/devel/libshhopt/files/patch-aa b/devel/libshhopt/files/patch-aa
new file mode 100644
index 000000000000..963686074ff3
--- /dev/null
+++ b/devel/libshhopt/files/patch-aa
@@ -0,0 +1,37 @@
+--- Makefile.orig Sun Jul 5 12:08:59 1998
++++ Makefile Fri Apr 2 15:15:59 1999
+@@ -6,10 +6,10 @@
+ VERSION = $(VERMAJ).$(VERMIN).$(VERPAT)
+
+ # Define SHARED as 1 for Linux shared ELF library
+-#SHARED = 1
++SHARED = 1
+
+ ifeq ($(SHARED),1)
+-LIBTARGET = lib$(DIST).so.$(VERSION)
++LIBTARGET = lib$(DIST).so.$(VERMAJ)
+ LIBTARGETSO = lib$(DIST).so
+ LIBTARGETSOMAJ = $(LIBTARGETSO).$(VERMAJ)
+ CCSHRD = -fPIC
+@@ -23,8 +23,8 @@
+ INSTBASEDIR = /usr/local
+ INSTLIBDIR = $(INSTBASEDIR)/lib
+ INSTINCDIR = $(INSTBASEDIR)/include
+-INSTALL = install -m 644
+-INSTALLPROG = install -m 755
++INSTALL = install -c -m 644
++INSTALLPROG = install -c -m 755
+ MKDIRP = install -d -m 755
+
+ CC = gcc
+@@ -67,9 +67,7 @@
+ $(INSTALL) $(LIBTARGET) $(INSTLIBDIR)
+ $(INSTALL) $(LIBHEAD) $(INSTINCDIR)
+ ifeq ($(SHARED),1)
+- ln -sf $(LIBTARGET) $(INSTLIBDIR)/$(LIBTARGETSOMAJ)
+- ln -sf $(LIBTARGETSOMAJ) $(INSTLIBDIR)/$(LIBTARGETSO)
+- echo "If you use GNU/Linux, remember to run ldconfig"
++ ln -sf $(LIBTARGET) $(INSTLIBDIR)/$(LIBTARGETSO)
+ endif
+
+ clean: