aboutsummaryrefslogtreecommitdiff
path: root/devel/libsigc++20/Makefile
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2004-06-25 08:23:30 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2004-06-25 08:23:30 +0000
commit623f5174fbdd89556f1b988a163ac00867655f9a (patch)
treecd44f2500227b6e6c587544793afc566fc0b53dc /devel/libsigc++20/Makefile
parentd7321ca7a32ae8a7cf408a226f3476443aa37342 (diff)
downloadports-623f5174fbdd89556f1b988a163ac00867655f9a.tar.gz
ports-623f5174fbdd89556f1b988a163ac00867655f9a.zip
Notes
Diffstat (limited to 'devel/libsigc++20/Makefile')
-rw-r--r--devel/libsigc++20/Makefile30
1 files changed, 16 insertions, 14 deletions
diff --git a/devel/libsigc++20/Makefile b/devel/libsigc++20/Makefile
index 1c7134bf14d1..698a724f6b88 100644
--- a/devel/libsigc++20/Makefile
+++ b/devel/libsigc++20/Makefile
@@ -1,29 +1,31 @@
-# New ports collection makefile for: libsigc++
-# Date created: 30 September 2002
-# Whom: Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
+# New ports collection makefile for: libsigc++2
+# Date created: 14 Feb 2004
+# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= libsigc++
-PORTVERSION= 1.2.5
-PORTREVISION= 1
-CATEGORIES= devel gnome
-MASTER_SITES= ${MASTER_SITE_GNOME} \
- ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.2 \
- libsigc
-DIST_SUBDIR= gnome2
+PORTVERSION= 2.0.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= libsigc \
+ sources/libsigc++/${PORTVERSION:R}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Callback Framework for C++
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+USE_BZIP2= yes
+USE_GCC= 3.3
USE_GMAKE= yes
-LATEST_LINK= libsigc++12
+LATEST_LINK= libsigc++20
INSTALLS_SHLIB= yes
-USE_GNOME= gnomehack gnometarget pkgconfig
-USE_LIBTOOL_VER= 13
+USE_GNOME= gnomehack lthack gnometarget pkgconfig
+USE_LIBTOOL_VER=13
+
+PLIST_SUB= VERSION="2.0" API_VERSION="2.0"
.include <bsd.port.mk>