aboutsummaryrefslogtreecommitdiff
path: root/devel/libsoup-gnome
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
commit3680f27ebff58ece429c4e032f9ad84fb1372114 (patch)
tree6c5ff4664c1a779ddad350ac887e5706dbfdd4eb /devel/libsoup-gnome
parent02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (diff)
Notes
Diffstat (limited to 'devel/libsoup-gnome')
-rw-r--r--devel/libsoup-gnome/Makefile29
-rw-r--r--devel/libsoup-gnome/pkg-descr16
-rw-r--r--devel/libsoup-gnome/pkg-plist10
3 files changed, 55 insertions, 0 deletions
diff --git a/devel/libsoup-gnome/Makefile b/devel/libsoup-gnome/Makefile
new file mode 100644
index 000000000000..fafcadceb911
--- /dev/null
+++ b/devel/libsoup-gnome/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libgsf
+# Date created: 11 September 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/devel/libsoup-gnome/Makefile,v 1.1 2010/06/05 21:11:10 kwm Exp $
+#
+
+PORTREVISION= 0
+CATEGORIES= devel gnome
+PKGNAMESUFFIX= -gnome
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A GNOME wrapper for libsoup
+
+MASTERDIR= ${.CURDIR}/../libsoup
+#BUILD_WRKSRC= ${WRKSRC}/gsf-gnome
+#INSTALL_WRKSRC= ${WRKSRC}/gsf-gnome
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+SOUP_SLAVE= yes
+
+#post-install:
+# @${MKDIR} ${PREFIX}/libdata/pkgconfig
+# @${INSTALL_DATA} ${WRKSRC}/libsoup-gnome-2.4.pc \
+# ${PREFIX}/libdata/pkgconfig/
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/libsoup-gnome/pkg-descr b/devel/libsoup-gnome/pkg-descr
new file mode 100644
index 000000000000..1ec2bfea440f
--- /dev/null
+++ b/devel/libsoup-gnome/pkg-descr
@@ -0,0 +1,16 @@
+Soup is a SOAP (Simple Object Access Protocol) implementation in C.
+
+It provides a queued asynchronous callback-based mechanism for sending and
+servicing SOAP requests, and a WSDL (Web Service Definition Language) for C
+compilers which generates client stubs and server skeletons for easily
+calling and implementing SOAP methods. It uses GLib and is designed to work
+well with GTK applications.
+
+Features:
+ * Completely Asynchronous
+ * Connection cache
+ * HTTP chunked transfer and persistent connections
+ * Authenticated HTTP, SOCKS4, and SOCKS5 proxy support
+ * SSL Support using OpenSSL
+ * Apache module server support
+ * Client digest authentication
diff --git a/devel/libsoup-gnome/pkg-plist b/devel/libsoup-gnome/pkg-plist
new file mode 100644
index 000000000000..500adeb165e8
--- /dev/null
+++ b/devel/libsoup-gnome/pkg-plist
@@ -0,0 +1,10 @@
+include/libsoup-gnome-%%VERSION%%/libsoup/soup-cookie-jar-sqlite.h
+include/libsoup-gnome-%%VERSION%%/libsoup/soup-gnome-features.h
+include/libsoup-gnome-%%VERSION%%/libsoup/soup-gnome.h
+lib/libsoup-gnome-%%VERSION%%.a
+lib/libsoup-gnome-%%VERSION%%.la
+lib/libsoup-gnome-%%VERSION%%.so
+lib/libsoup-gnome-%%VERSION%%.so.1
+libdata/pkgconfig/libsoup-gnome-%%VERSION%%.pc
+@dirrm include/libsoup-gnome-%%VERSION%%/libsoup
+@dirrm include/libsoup-gnome-%%VERSION%%