aboutsummaryrefslogtreecommitdiff
path: root/devel/libsoup
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
commit58406bee8938178fc317574c4236434b0dd11a25 (patch)
treeb4fa34eca69e23769c548b4436cbf65d765e5fe2 /devel/libsoup
parent98eb5c95a29c8dd1a76435744e5316092835f696 (diff)
Presenting GNOME 2.8 for FreeBSD (2.8.1 to be exact).
This release notes detailing all of the new goodies in GNOME 2.8 can be found at http://www.gnome.org/start/2.8/notes/, and the list of what was fixed in GNOME 2.8.1 can be found at http://lists.gnome.org/archives/gnome-announce-list/2004-October/msg00056.html. This release, as well as all of our others, would not have been possible without the great efforts of our FreeBSD GNOME Team. The list of current members can be found at http://www.freebsd.org/gnome/contact.html (including our newest member, Michael Johnson <ahze@FreeBSD.org>). Special thanks also goes out to all of the loyal FreeBSD GNOME users that put up with crashes and hangs to test and debug GNOME on FreeBSD. We would especially like to thank those users that provided patches for GNOME 2.7 and 2.8: Franz Klammer <klammer@webonaut.com> Piotr Smyrak <piotr.smyrak@heron.pl> Radek Kozlowski <radek@raadradd.com> Khairil Yusof <kaeru@pd.jaring.my> Yasuda Keisuke <kysd@po.harenet.ne.jp> Tom McLaughlin <tmclaugh@sdf.lonestar.org> Vladimir Grebenschikov <vova@fbsd.ru> GNOME 2.8 also features a new, FreeBSD-specific splashscreen that was designed by jimmac for GNOME 2.8, then daemonized by Franz Klammer <klammer@webonaut.com> and Radek Kozlowski <radek@raadradd.com>. As with GNOME 2.6, you cannot just "portupgrade" to GNOME 2.8. There is a script provided at http://www.marcuscom.com/downloads/gnome_upgrade28.sh that will aid in the upgrade process. Full documentation on the GNOME 2.8 upgrade is coming following this commit. From all of us at FreeBSD GNOME, ENJOY!
Notes
Notes: svn path=/head/; revision=121068
Diffstat (limited to 'devel/libsoup')
-rw-r--r--devel/libsoup/Makefile28
-rw-r--r--devel/libsoup/distinfo4
-rw-r--r--devel/libsoup/files/patch-configure11
-rw-r--r--devel/libsoup/pkg-descr13
-rw-r--r--devel/libsoup/pkg-plist80
5 files changed, 88 insertions, 48 deletions
diff --git a/devel/libsoup/Makefile b/devel/libsoup/Makefile
index bd7a1bacb36d..c4709713daad 100644
--- a/devel/libsoup/Makefile
+++ b/devel/libsoup/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= libsoup
-PORTVERSION= 1.99.28
-PORTREVISION= 1
+PORTVERSION= 2.2.1
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.99
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.2
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -19,14 +18,27 @@ COMMENT= A SOAP (Simple Object Access Protocol) implementation in C
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_BZIP2= yes
-USE_GNOME= gnomehack lthack glib20
+USE_GNOME= gnomehack glib20 libxml2
INSTALLS_SHLIB= yes
-USE_INC_LIBTOOL_VER= 13
-USE_OPENSSL= yes
+USE_LIBTOOL_VER=15
+USE_GMAKE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
- --with-gnutls-includes=${FALSE} \
- --with-gnutls-libs=${FALSE}
+ --disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
LDFLAGS+= -L${LOCALBASE}/lib
+PLIST_SUB= VERSION="2.2"
+
+.if !defined(WITHOUT_SSL)
+LIB_DEPENDS+= gnutls.12:${PORTSDIR}/security/gnutls
+.else
+CONFIGURE_ARGS+=--disable-ssl
+.endif
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "libsoup has the following configurable option(s):"
+ @${ECHO_MSG} " WITHOUT_SSL Disable GnuTLS SSL support"
+ @${ECHO_MSG} ""
+
.include <bsd.port.mk>
diff --git a/devel/libsoup/distinfo b/devel/libsoup/distinfo
index 87c1098922f8..902a0436e7cf 100644
--- a/devel/libsoup/distinfo
+++ b/devel/libsoup/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/libsoup-1.99.28.tar.bz2) = c33f1cb5697ef9b9ad6cd8482c4c2abb
-SIZE (gnome2/libsoup-1.99.28.tar.bz2) = 233412
+MD5 (gnome2/libsoup-2.2.1.tar.bz2) = 8132b0bce469affed688c4863702aa41
+SIZE (gnome2/libsoup-2.2.1.tar.bz2) = 403907
diff --git a/devel/libsoup/files/patch-configure b/devel/libsoup/files/patch-configure
deleted file mode 100644
index 85f964458b26..000000000000
--- a/devel/libsoup/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Tue Apr 6 17:08:05 2004
-+++ configure Tue Apr 6 17:10:47 2004
-@@ -9520,7 +9521,7 @@
- save_CPPFLAGS=$CPPFLAGS
- CPPFLAGS="$CPPFLAGS $gnutls_inc_prefix"
-
--for ac_header in gnutls/gnutls.h
-+for ac_header in gnutls/xxxgnutls.h
- do
- as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
- if eval "test \"\${$as_ac_Header+set}\" = set"; then
diff --git a/devel/libsoup/pkg-descr b/devel/libsoup/pkg-descr
index 423bf5cfc4f6..1ec2bfea440f 100644
--- a/devel/libsoup/pkg-descr
+++ b/devel/libsoup/pkg-descr
@@ -1,17 +1,16 @@
Soup is a SOAP (Simple Object Access Protocol) implementation in C.
-It provides an queued asynchronous callback-based mechanism for sending and
-servicing SOAP requests, and a WSDL (Web Service Definition Language) to C
-compiler which generates client stubs and server skeletons for easily calling
-and implementing SOAP methods.
-
-It uses the GLib main loop and is designed to work well with GTK applications.
+It provides a queued asynchronous callback-based mechanism for sending and
+servicing SOAP requests, and a WSDL (Web Service Definition Language) for C
+compilers which generates client stubs and server skeletons for easily
+calling and implementing SOAP methods. It uses GLib and is designed to work
+well with GTK applications.
Features:
* Completely Asynchronous
* Connection cache
* HTTP chunked transfer and persistent connections
- * authenticated HTTP, SOCKS4, and SOCKS5 proxy support
+ * Authenticated HTTP, SOCKS4, and SOCKS5 proxy support
* SSL Support using OpenSSL
* Apache module server support
* Client digest authentication
diff --git a/devel/libsoup/pkg-plist b/devel/libsoup/pkg-plist
index 1ef3a47265a0..debbbf1a8694 100644
--- a/devel/libsoup/pkg-plist
+++ b/devel/libsoup/pkg-plist
@@ -1,20 +1,60 @@
-include/soup-2.0/libsoup/soup-address.h
-include/soup-2.0/libsoup/soup-context.h
-include/soup-2.0/libsoup/soup-error.h
-include/soup-2.0/libsoup/soup-headers.h
-include/soup-2.0/libsoup/soup-message.h
-include/soup-2.0/libsoup/soup-method.h
-include/soup-2.0/libsoup/soup-misc.h
-include/soup-2.0/libsoup/soup-ntlm.h
-include/soup-2.0/libsoup/soup-server-auth.h
-include/soup-2.0/libsoup/soup-server.h
-include/soup-2.0/libsoup/soup-socket.h
-include/soup-2.0/libsoup/soup-uri.h
-include/soup-2.0/libsoup/soup.h
-lib/libsoup-2.0.a
-lib/libsoup-2.0.so
-lib/libsoup-2.0.so.0
-libdata/pkgconfig/soup-2.0.pc
-libexec/libsoup-ssl-proxy
-@dirrm include/soup-2.0/libsoup
-@dirrm include/soup-2.0
+include/libsoup-%%VERSION%%/libsoup/soup-address.h
+include/libsoup-%%VERSION%%/libsoup/soup-connection.h
+include/libsoup-%%VERSION%%/libsoup/soup-headers.h
+include/libsoup-%%VERSION%%/libsoup/soup-message-filter.h
+include/libsoup-%%VERSION%%/libsoup/soup-message-queue.h
+include/libsoup-%%VERSION%%/libsoup/soup-message.h
+include/libsoup-%%VERSION%%/libsoup/soup-method.h
+include/libsoup-%%VERSION%%/libsoup/soup-misc.h
+include/libsoup-%%VERSION%%/libsoup/soup-server-auth.h
+include/libsoup-%%VERSION%%/libsoup/soup-server-message.h
+include/libsoup-%%VERSION%%/libsoup/soup-server.h
+include/libsoup-%%VERSION%%/libsoup/soup-session-async.h
+include/libsoup-%%VERSION%%/libsoup/soup-session-sync.h
+include/libsoup-%%VERSION%%/libsoup/soup-session.h
+include/libsoup-%%VERSION%%/libsoup/soup-soap-message.h
+include/libsoup-%%VERSION%%/libsoup/soup-soap-response.h
+include/libsoup-%%VERSION%%/libsoup/soup-socket.h
+include/libsoup-%%VERSION%%/libsoup/soup-status.h
+include/libsoup-%%VERSION%%/libsoup/soup-types.h
+include/libsoup-%%VERSION%%/libsoup/soup-uri.h
+include/libsoup-%%VERSION%%/libsoup/soup.h
+lib/libsoup-%%VERSION%%.a
+lib/libsoup-%%VERSION%%.so
+lib/libsoup-%%VERSION%%.so.7
+libdata/pkgconfig/libsoup-%%VERSION%%.pc
+%%DOCSDIR%%/SoupAuth.html
+%%DOCSDIR%%/SoupAuthBasic.html
+%%DOCSDIR%%/SoupAuthDigest.html
+%%DOCSDIR%%/SoupConnection.html
+%%DOCSDIR%%/SoupConnectionNTLM.html
+%%DOCSDIR%%/SoupMessage.html
+%%DOCSDIR%%/SoupSoapMessage.html
+%%DOCSDIR%%/ch01.html
+%%DOCSDIR%%/home.png
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/index.sgml
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/libsoup-SoupAddress.html
+%%DOCSDIR%%/libsoup-SoupServer.html
+%%DOCSDIR%%/libsoup-SoupServerMessage.html
+%%DOCSDIR%%/libsoup-SoupSession.html
+%%DOCSDIR%%/libsoup-SoupSocket.html
+%%DOCSDIR%%/libsoup-soup-dns.html
+%%DOCSDIR%%/libsoup-soup-headers.html
+%%DOCSDIR%%/libsoup-soup-md5-utils.html
+%%DOCSDIR%%/libsoup-soup-message-private.html
+%%DOCSDIR%%/libsoup-soup-message-queue.html
+%%DOCSDIR%%/libsoup-soup-method.html
+%%DOCSDIR%%/libsoup-soup-misc.html
+%%DOCSDIR%%/libsoup-soup-server-auth.html
+%%DOCSDIR%%/libsoup-soup-ssl.html
+%%DOCSDIR%%/libsoup-soup-status.html
+%%DOCSDIR%%/libsoup-soup-uri.html
+%%DOCSDIR%%/libsoup.devhelp
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/style.css
+%%DOCSDIR%%/up.png
+@dirrm %%DOCSDIR%%
+@dirrm include/libsoup-%%VERSION%%/libsoup
+@dirrm include/libsoup-%%VERSION%%