aboutsummaryrefslogtreecommitdiff
path: root/devel/libstatgrab/Makefile
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2014-05-12 20:01:59 +0000
committerTim Bishop <tdb@FreeBSD.org>2014-05-12 20:01:59 +0000
commitc483447c1d985815bc5b07d10fed7c9f29bf736b (patch)
tree668e7a047851c622918e90038d050cc6020eb0f5 /devel/libstatgrab/Makefile
parent5af57f192720c6ab78a65905e04a0672c953e7fc (diff)
Notes
Diffstat (limited to 'devel/libstatgrab/Makefile')
-rw-r--r--devel/libstatgrab/Makefile39
1 files changed, 19 insertions, 20 deletions
diff --git a/devel/libstatgrab/Makefile b/devel/libstatgrab/Makefile
index fddfc99bd2a0..0e42e473dab8 100644
--- a/devel/libstatgrab/Makefile
+++ b/devel/libstatgrab/Makefile
@@ -2,37 +2,36 @@
# $FreeBSD$
PORTNAME= libstatgrab
-PORTVERSION= 0.17
+PORTVERSION= 0.90
CATEGORIES= devel
-MASTER_SITES= ftp://ftp.uk.i-scream.org/pub/i-scream/%SUBDIR%/ \
- http://ftp.uk.i-scream.org/pub/i-scream/%SUBDIR%/ \
- http://dl.ambiweb.de/mirrors/ftp.i-scream.org/%SUBDIR%/ \
- ftp://ftp.i-scream.org/pub/i-scream/%SUBDIR%/ \
- http://ftp.i-scream.org/pub/i-scream/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= http://ftp.uk.i-scream.org/pub/i-scream/libstatgrab/ \
+ http://dl.ambiweb.de/mirrors/ftp.i-scream.org/libstatgrab/ \
+ http://ftp.i-scream.org/pub/i-scream/libstatgrab/
MAINTAINER= tdb@FreeBSD.org
COMMENT= Provides a useful interface to system statistics
-DIST_SUBDIR= i-scream
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig libtool
-CONFIGURE_ARGS+= --disable-examples
+CONFIGURE_ARGS= --disable-examples
-.ifdef(WITHOUT_STATGRAB)
-CONFIGURE_ARGS+= --disable-statgrab
-PLIST_SUB+= STATGRAB="@comment "
-.else
-PLIST_SUB+= STATGRAB=""
-.endif
+OPTIONS_DEFINE= TOOLS
+OPTIONS_DEFAULT= TOOLS
+
+TOOLS_DESC= Build and install statgrab and saidar
+
+OPTIONS_SUB= yes
+
+.include <bsd.port.options.mk>
-.ifdef(WITHOUT_SAIDAR)
-CONFIGURE_ARGS+= --disable-saidar
-PLIST_SUB+= SAIDAR="@comment "
+.if ${PORT_OPTIONS:MTOOLS}
+USES+= shebangfix perl5
+SHEBANG_FILES= src/statgrab/statgrab-make-mrtg-config.in \
+ src/statgrab/statgrab-make-mrtg-index.in
.else
-PLIST_SUB+= SAIDAR=""
+CONFIGURE_ARGS+= --disable-statgrab --disable-saidar
.endif
.include <bsd.port.mk>