aboutsummaryrefslogtreecommitdiff
path: root/devel/libstatgrab/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-10 13:50:05 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-10 13:50:05 +0000
commit249c67167e29491396cb7b05b9527cc1c70be0b4 (patch)
tree3b9d92bce043556c9aaf47389190fec393f2be96 /devel/libstatgrab/Makefile
parente1ba3c4cab3fbedc5d61ac2a1aefeac584550211 (diff)
downloadports-249c67167e29491396cb7b05b9527cc1c70be0b4.tar.gz
ports-249c67167e29491396cb7b05b9527cc1c70be0b4.zip
Notes
Diffstat (limited to 'devel/libstatgrab/Makefile')
-rw-r--r--devel/libstatgrab/Makefile34
1 files changed, 27 insertions, 7 deletions
diff --git a/devel/libstatgrab/Makefile b/devel/libstatgrab/Makefile
index c20a845f83ff..f5395875bb53 100644
--- a/devel/libstatgrab/Makefile
+++ b/devel/libstatgrab/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libstatgrab
-PORTVERSION= 0.5.1
+PORTVERSION= 0.6
CATEGORIES= devel
MASTER_SITES= ftp://ftp.mirror.ac.uk/sites/ftp.i-scream.org/pub/i-scream/%SUBDIR%/ \
http://www.mirror.ac.uk/sites/ftp.i-scream.org/pub/i-scream/%SUBDIR%/ \
@@ -17,17 +17,37 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= tim@bishnet.net
COMMENT= Provides a useful interface to system statistics
-DIST_SUBDIR= iscream
+DIST_SUBDIR= i-scream
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
-ONLY_FOR_ARCHS= i386
+MAN3= cpu_percent_usage.3 get_cpu_diff.3 get_cpu_totals.3 \
+ get_diskio_stats.3 get_diskio_stats_diff.3 get_general_stats.3 \
+ get_load_stats.3 get_memory_stats.3 get_network_stats.3 \
+ get_network_stats_diff.3 get_page_stats.3 \
+ get_page_stats_diff.3 get_process_stats.3 get_swap_stats.3 \
+ get_user_stats.3 statgrab.3
-.include <bsd.port.pre.mk>
+CONFIGURE_ARGS+= --disable-examples \
+ --with-pkgconfig-dir=${PREFIX}/libdata/pkgconfig
-.if ${OSVERSION} >= 500000
-IGNORE= "does not currently support FreeBSD 5.x"
+.if defined(WITHOUT_STATGRAB)
+CONFIGURE_ARGS+= --disable-statgrab
+PLIST_SUB+= STATGRAB="@comment "
+.else
+PLIST_SUB+= STATGRAB=""
.endif
-.include <bsd.port.post.mk>
+.if defined(WITHOUT_SAIDAR)
+CONFIGURE_ARGS+= --disable-saidar
+PLIST_SUB+= SAIDAR="@comment "
+.else
+PLIST_SUB+= SAIDAR=""
+.endif
+
+.if defined(WITHOUT_SETGID_BINARIES)
+CONFIGURE_ARGS+= --disable-setgid-binaries
+.endif
+
+.include <bsd.port.mk>