aboutsummaryrefslogtreecommitdiff
path: root/devel/libtecla/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-13 07:25:32 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-13 07:25:32 +0000
commitccc0ead913625dd0af6158679d7dffde4804aac3 (patch)
tree86f9110e481026520a0612904713424548217601 /devel/libtecla/Makefile
parent71cb91ea2bd87b9cd054418582e0357cd221642a (diff)
downloadports-ccc0ead913625dd0af6158679d7dffde4804aac3.tar.gz
ports-ccc0ead913625dd0af6158679d7dffde4804aac3.zip
Notes
Diffstat (limited to 'devel/libtecla/Makefile')
-rw-r--r--devel/libtecla/Makefile29
1 files changed, 14 insertions, 15 deletions
diff --git a/devel/libtecla/Makefile b/devel/libtecla/Makefile
index 5baa3ea65aaa..da67c000cc23 100644
--- a/devel/libtecla/Makefile
+++ b/devel/libtecla/Makefile
@@ -7,28 +7,27 @@
#
PORTNAME= libtecla
-PORTVERSION= 1.3.3
+PORTVERSION= 1.4.0
CATEGORIES= devel
MASTER_SITES= http://www.astro.caltech.edu/~mcs/tecla/
MAINTAINER= ports@FreeBSD.org
GNU_CONFIGURE= yes
-
WRKSRC= ${WRKDIR}/${PORTNAME}
-ALL_TARGET=
+ALL_TARGET= default
+SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
+ REALCURDIR="${.CURDIR}" \
+ PORTNAME="${PORTNAME}"
+
+post-extract:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/genman3list.sh
+
+post-clean:
+ @${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
-MAN3= cfc_file_start.3 cfc_literal_escapes.3 cfc_set_check_fn.3 \
- cpl_add_completion.3 cpl_complete_word.3 cpl_file_completions.3 \
- cpl_last_error.3 cpl_list_completions.3 cpl_record_error.3 \
- del_CplFileConf.3 del_ExpandFile.3 del_GetLine.3 del_PathCache.3 \
- del_PcaPathConf.3 del_WordCompletion.3 ef_expand_file.3 \
- ef_last_error.3 ef_list_expansions.3 gl_change_terminal.3 \
- gl_customize_completion.3 \
- gl_get_line.3 libtecla.3 new_CplFileConf.3 new_ExpandFile.3 \
- new_GetLine.3 new_PathCache.3 new_PcaPathConf.3 new_WordCompletion.3 \
- pca_last_error.3 pca_lookup_file.3 pca_path_completions.3 \
- pca_scan_path.3 pca_set_check_fn.3 ppc_file_start.3 \
- ppc_literal_escapes.3
+.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
+.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
+.endif
.include <bsd.port.mk>