aboutsummaryrefslogtreecommitdiff
path: root/devel/libtecla
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-02-11 19:15:03 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-02-11 19:15:03 +0000
commitd6902361d36fed6fc44446ac045c8fbeb5e26427 (patch)
treede075d83fa9aa1827fe1994b805604efe23c219d /devel/libtecla
parent4d71468734500e8bfc491fb7a26b24119e2bcce6 (diff)
downloadports-d6902361d36fed6fc44446ac045c8fbeb5e26427.tar.gz
ports-d6902361d36fed6fc44446ac045c8fbeb5e26427.zip
Notes
Diffstat (limited to 'devel/libtecla')
-rw-r--r--devel/libtecla/Makefile37
-rw-r--r--devel/libtecla/distinfo1
-rw-r--r--devel/libtecla/pkg-comment1
-rw-r--r--devel/libtecla/pkg-descr16
-rw-r--r--devel/libtecla/pkg-plist3
5 files changed, 58 insertions, 0 deletions
diff --git a/devel/libtecla/Makefile b/devel/libtecla/Makefile
new file mode 100644
index 000000000000..09596158bf39
--- /dev/null
+++ b/devel/libtecla/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# New ports collection makefile for: libtecla
+# Date created: Feb 12, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtecla
+PORTVERSION= 1.2
+CATEGORIES= devel
+MASTER_SITES= http://www.astro.caltech.edu/~mcs/tecla/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_GMAKE= yes
+ALL_TARGET= libtecla.a libtecla_r.a
+
+MAN3= cfc_file_start.3 cfc_literal_escapes.3 cfc_set_check_fn.3 \
+ cpl_add_completion.3 cpl_complete_word.3 cpl_file_completions.3 \
+ cpl_last_error.3 cpl_list_completions.3 cpl_record_error.3 \
+ del_CplFileConf.3 del_ExpandFile.3 del_GetLine.3 del_PathCache.3 \
+ del_PcaPathConf.3 del_WordCompletion.3 ef_expand_file.3 \
+ ef_last_error.3 gl_change_terminal.3 gl_customize_completion.3 \
+ gl_get_line.3 libtecla.3 new_CplFileConf.3 new_ExpandFile.3 \
+ new_GetLine.3 new_PathCache.3 new_PcaPathConf.3 new_WordCompletion.3 \
+ pca_last_error.3 pca_lookup_file.3 pca_path_completions.3 \
+ pca_scan_path.3 pca_set_check_fn.3 ppc_file_start.3 \
+ ppc_literal_escapes.3
+
+post-patch:
+ @${PERL} -pi -e "s|/usr/local|${PREFIX}|g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/devel/libtecla/distinfo b/devel/libtecla/distinfo
new file mode 100644
index 000000000000..117dc332b813
--- /dev/null
+++ b/devel/libtecla/distinfo
@@ -0,0 +1 @@
+MD5 (libtecla1.2.tar.gz) = ec9ef789dc6745de71f6c6f7d51a00d3
diff --git a/devel/libtecla/pkg-comment b/devel/libtecla/pkg-comment
new file mode 100644
index 000000000000..4630b2c96782
--- /dev/null
+++ b/devel/libtecla/pkg-comment
@@ -0,0 +1 @@
+Interactive command line editing facilities
diff --git a/devel/libtecla/pkg-descr b/devel/libtecla/pkg-descr
new file mode 100644
index 000000000000..fb42757a6e9a
--- /dev/null
+++ b/devel/libtecla/pkg-descr
@@ -0,0 +1,16 @@
+The tecla library provides UNIX and LINUX programs with interactive
+command line editing facilities, similar to those of the unix tcsh
+shell. In addition to simple command-line editing, it supports recall
+of previously entered command lines, TAB completion of file names or
+other tokens, and in-line wild-card expansion of filenames. The
+internal functions which perform file-name completion and wild-card
+expansion are also available externally for optional use by programs,
+along with a module for tab-completion and lookup of filenames in a
+list of directories.
+
+Note that special care has been taken to allow the use of this library
+in threaded programs. The option to enable this is discussed in the
+Makefile, and specific discussions of thread safety are presented in
+the included man pages.
+
+WWW: http://www.astro.caltech.edu/~mcs/tecla/
diff --git a/devel/libtecla/pkg-plist b/devel/libtecla/pkg-plist
new file mode 100644
index 000000000000..6f62f81439f3
--- /dev/null
+++ b/devel/libtecla/pkg-plist
@@ -0,0 +1,3 @@
+lib/libtecla.a
+lib/libtecla_r.a
+include/libtecla.h