aboutsummaryrefslogtreecommitdiff
path: root/devel/libtifiles/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 10:55:05 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 10:55:05 +0000
commit0a8169aade48999993d8aff95df7d80729779c6a (patch)
tree45e5c5ad888fae6fc24d2211cb1dba86f495df6a /devel/libtifiles/Makefile
parent84844a75580499aafec4baab0f7cb7bd5f5255c9 (diff)
downloadports-0a8169aade48999993d8aff95df7d80729779c6a.tar.gz
ports-0a8169aade48999993d8aff95df7d80729779c6a.zip
Notes
Diffstat (limited to 'devel/libtifiles/Makefile')
-rw-r--r--devel/libtifiles/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/libtifiles/Makefile b/devel/libtifiles/Makefile
new file mode 100644
index 000000000000..be36ea20fc52
--- /dev/null
+++ b/devel/libtifiles/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: libtifiles
+# Date created: 27 August 2003
+# Whom: Tijl Coosemans <tijl@ulyssis.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtifiles
+PORTVERSION= 0.5.7
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= tilp
+
+MAINTAINER= tijl@ulyssis.org
+COMMENT= TI calculator file types library
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
+
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"\
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= tifiles-config.1
+
+.include <bsd.port.mk>