aboutsummaryrefslogtreecommitdiff
path: root/devel/libtool
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2011-02-25 06:15:44 +0000
committerAde Lovett <ade@FreeBSD.org>2011-02-25 06:15:44 +0000
commite0d39220da70d4549cd2c80f3e1aa7f10013ffeb (patch)
treee1bec5b72ac74951b3de76134222d19cbadc67fc /devel/libtool
parentfa865a042d7d1a702d59bb5913e79897ea83de46 (diff)
Notes
Diffstat (limited to 'devel/libtool')
-rw-r--r--devel/libtool/Makefile2
-rw-r--r--devel/libtool/distinfo5
-rw-r--r--devel/libtool/files/patch-libltdl_config_ltmain.sh38
3 files changed, 12 insertions, 33 deletions
diff --git a/devel/libtool/Makefile b/devel/libtool/Makefile
index 949e0de17534..720bb7ce6f93 100644
--- a/devel/libtool/Makefile
+++ b/devel/libtool/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= libtool
-PORTVERSION= 2.2.10
+PORTVERSION= 2.4
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= libtool
diff --git a/devel/libtool/distinfo b/devel/libtool/distinfo
index ee1757dd9c29..187e5840b97a 100644
--- a/devel/libtool/distinfo
+++ b/devel/libtool/distinfo
@@ -1,3 +1,2 @@
-MD5 (libtool-2.2.10.tar.gz) = b745d220e88163fcd9eea0a90ccf21b0
-SHA256 (libtool-2.2.10.tar.gz) = de7d1d028fa3be15a05b3e00fe64f80ece62636923cc9ef82dc8b9a2f3c5d77d
-SIZE (libtool-2.2.10.tar.gz) = 2439628
+SHA256 (libtool-2.4.tar.gz) = 13df57ab63a94e196c5d6e95d64e53262834fe780d5e82c28f177f9f71ddf62e
+SIZE (libtool-2.4.tar.gz) = 2580417
diff --git a/devel/libtool/files/patch-libltdl_config_ltmain.sh b/devel/libtool/files/patch-libltdl_config_ltmain.sh
index ad0599710598..4bc3bf1c120a 100644
--- a/devel/libtool/files/patch-libltdl_config_ltmain.sh
+++ b/devel/libtool/files/patch-libltdl_config_ltmain.sh
@@ -1,8 +1,6 @@
---- libltdl/config/ltmain.sh.orig 2009-06-29 12:36:19.000000000 -0500
-+++ libltdl/config/ltmain.sh 2009-06-29 12:57:44.000000000 -0500
-@@ -1010,6 +1010,21 @@
- func_infer_tag ()
- {
+--- libltdl/config/ltmain.sh.orig 2010-09-22 09:45:43.000000000 -0500
++++ libltdl/config/ltmain.sh 2011-01-18 12:59:46.000000000 -0600
+@@ -1376,2 +1376,17 @@
$opt_debug
+
+ # FreeBSD-specific: where we install compilers with non-standard names
@@ -20,11 +18,7 @@
+ fi
+
if test -n "$available_tags" && test -z "$tagname"; then
- CC_quoted=
- for arg in $CC; do
-@@ -1042,7 +1057,22 @@
- break
- ;;
+@@ -1412,3 +1427,18 @@
esac
- fi
+
@@ -44,34 +38,22 @@
+ fi
+ fi
done
- # If $tagname still isn't set, then no tagged configuration
- # was found and let the user know that the "--tag" command
-@@ -2528,6 +2558,9 @@
- ;;
- esac
+@@ -3516,2 +3546,5 @@
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
- func_fatal_error "unknown suffix for \`$my_dlsyms'"
- ;;
-@@ -4584,6 +4617,7 @@
- *" $arg "*) ;;
- * ) new_inherited_linker_flags="$new_inherited_linker_flags $arg" ;;
+@@ -5585,2 +5618,3 @@
esac
+ deplibs="$deplibs $arg"
continue
- ;;
-
-@@ -5073,13 +5107,30 @@
- finalize_deplibs="$deplib $finalize_deplibs"
- else
- compiler_flags="$compiler_flags $deplib"
+@@ -6155,9 +6189,26 @@
+ func_append compiler_flags " $deplib"
- if test "$linkmode" = lib ; then
- case "$new_inherited_linker_flags " in
- *" $deplib "*) ;;
-- * ) new_inherited_linker_flags="$new_inherited_linker_flags $deplib" ;;
+- * ) func_append new_inherited_linker_flags " $deplib" ;;
- esac
- fi
fi
@@ -99,5 +81,3 @@
+ esac # linkmode
+
continue
- ;;
- -l*)