aboutsummaryrefslogtreecommitdiff
path: root/devel/libtool
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2010-12-08 19:58:49 +0000
committerAde Lovett <ade@FreeBSD.org>2010-12-08 19:58:49 +0000
commitf584da22ee03bf55f4db7ffa79c61aa8ad827ad6 (patch)
treef7da82208d8de3376467178192bb0f8181f73280 /devel/libtool
parentdeb6a6b36bfd8259bc9c372e4698cb7c7a8233ce (diff)
Notes
Diffstat (limited to 'devel/libtool')
-rw-r--r--devel/libtool/Makefile37
-rw-r--r--devel/libtool/distinfo3
-rw-r--r--devel/libtool/files/patch-libltdl-Makefile.in23
-rw-r--r--devel/libtool/files/patch-libltdl_config_ltmain.sh103
-rw-r--r--devel/libtool/pkg-descr8
-rw-r--r--devel/libtool/pkg-plist56
6 files changed, 230 insertions, 0 deletions
diff --git a/devel/libtool/Makefile b/devel/libtool/Makefile
new file mode 100644
index 000000000000..949e0de17534
--- /dev/null
+++ b/devel/libtool/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: libtool
+# Date created: 6 May 1998
+# Whom: Motoyuki Kasahara <m-kasahr@sra.co.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME?= libtool
+PORTVERSION= 2.2.10
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= libtool
+DISTNAME= libtool-${PORTVERSION}
+
+MAINTAINER= autotools@FreeBSD.org
+COMMENT?= Generic shared library support script
+
+LICENSE?= GPLv2
+LICENSE_FILE?= ${WRKSRC}/COPYING
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS?= --disable-ltdl-install
+CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
+INFO?= libtool
+.if ${PORTNAME} != "libltdl"
+MAN1= libtool.1 libtoolize.1
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|sed gsed|sed|g' \
+ -e 's|CC=cc|CC=${CC}|g' \
+ ${WRKSRC}/configure ${WRKSRC}/libltdl/configure
+
+post-configure:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${TOUCH} -f
+
+.include <bsd.port.mk>
diff --git a/devel/libtool/distinfo b/devel/libtool/distinfo
new file mode 100644
index 000000000000..ee1757dd9c29
--- /dev/null
+++ b/devel/libtool/distinfo
@@ -0,0 +1,3 @@
+MD5 (libtool-2.2.10.tar.gz) = b745d220e88163fcd9eea0a90ccf21b0
+SHA256 (libtool-2.2.10.tar.gz) = de7d1d028fa3be15a05b3e00fe64f80ece62636923cc9ef82dc8b9a2f3c5d77d
+SIZE (libtool-2.2.10.tar.gz) = 2439628
diff --git a/devel/libtool/files/patch-libltdl-Makefile.in b/devel/libtool/files/patch-libltdl-Makefile.in
new file mode 100644
index 000000000000..02f03e7099d6
--- /dev/null
+++ b/devel/libtool/files/patch-libltdl-Makefile.in
@@ -0,0 +1,23 @@
+--- libltdl/Makefile.in.orig 2009-11-19 14:55:46.000000000 +0100
++++ libltdl/Makefile.in 2009-11-19 14:56:35.000000000 +0100
+@@ -402,12 +402,6 @@
+ $(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
+ $(SHELL) ./config.status --recheck
+
+-$(top_srcdir)/configure: $(am__configure_deps)
+- $(am__cd) $(srcdir) && $(AUTOCONF)
+-$(ACLOCAL_M4): $(am__aclocal_m4_deps)
+- $(am__cd) $(srcdir) && $(ACLOCAL) $(ACLOCAL_AMFLAGS)
+-$(am__aclocal_m4_deps):
+-
+ config.h: stamp-h1
+ @if test ! -f $@; then \
+ rm -f stamp-h1; \
+@@ -418,7 +412,6 @@
+ @rm -f stamp-h1
+ cd $(top_builddir) && $(SHELL) ./config.status config.h
+ $(srcdir)/config-h.in: $(am__configure_deps)
+- ($(am__cd) $(top_srcdir) && $(AUTOHEADER))
+ rm -f stamp-h1
+ touch $@
+
diff --git a/devel/libtool/files/patch-libltdl_config_ltmain.sh b/devel/libtool/files/patch-libltdl_config_ltmain.sh
new file mode 100644
index 000000000000..ad0599710598
--- /dev/null
+++ b/devel/libtool/files/patch-libltdl_config_ltmain.sh
@@ -0,0 +1,103 @@
+--- libltdl/config/ltmain.sh.orig 2009-06-29 12:36:19.000000000 -0500
++++ libltdl/config/ltmain.sh 2009-06-29 12:57:44.000000000 -0500
+@@ -1010,6 +1010,21 @@
+ func_infer_tag ()
+ {
+ $opt_debug
++
++ # FreeBSD-specific: where we install compilers with non-standard names
++ tag_compilers_CC="*cc cc* *gcc gcc* clang"
++ tag_compilers_CXX="*c++ c++* *g++ g++* clang++"
++ base_compiler=`set -- "$@"; echo $1`
++
++ # If $tagname isn't set, then try to infer if the default "CC" tag applies
++ if test -z "$tagname"; then
++ for zp in $tag_compilers_CC; do
++ case $base_compiler in
++ $zp) tagname="CC"; break;;
++ esac
++ done
++ fi
++
+ if test -n "$available_tags" && test -z "$tagname"; then
+ CC_quoted=
+ for arg in $CC; do
+@@ -1042,7 +1057,22 @@
+ break
+ ;;
+ esac
+- fi
++
++ # FreeBSD-specific: try compilers based on inferred tag
++ if test -z "$tagname"; then
++ eval "tag_compilers=\$tag_compilers_${z}"
++ if test -n "$tag_compilers"; then
++ for zp in $tag_compilers; do
++ case $base_compiler in
++ $zp) tagname=$z; break;;
++ esac
++ done
++ if test -n "$tagname"; then
++ break
++ fi
++ fi
++ fi
++ fi
+ done
+ # If $tagname still isn't set, then no tagged configuration
+ # was found and let the user know that the "--tag" command
+@@ -2528,6 +2558,9 @@
+ ;;
+ esac
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ func_fatal_error "unknown suffix for \`$my_dlsyms'"
+ ;;
+@@ -4584,6 +4617,7 @@
+ *" $arg "*) ;;
+ * ) new_inherited_linker_flags="$new_inherited_linker_flags $arg" ;;
+ esac
++ deplibs="$deplibs $arg"
+ continue
+ ;;
+
+@@ -5073,13 +5107,30 @@
+ finalize_deplibs="$deplib $finalize_deplibs"
+ else
+ compiler_flags="$compiler_flags $deplib"
+- if test "$linkmode" = lib ; then
+- case "$new_inherited_linker_flags " in
+- *" $deplib "*) ;;
+- * ) new_inherited_linker_flags="$new_inherited_linker_flags $deplib" ;;
+- esac
+- fi
+ fi
++
++ case $linkmode in
++ lib)
++ deplibs="$deplib $deplibs"
++ test "$pass" = conv && continue
++ newdependency_libs="$deplib $newdependency_libs"
++ ;;
++ prog)
++ if test "$pass" = conv; then
++ deplibs="$deplib $deplibs"
++ continue
++ fi
++ if test "$pass" = scan; then
++ deplibs="$deplib $deplibs"
++ else
++ compile_deplibs="$deplib $compile_deplibs"
++ finalize_deplibs="$deplib $finalize_deplibs"
++ fi
++ ;;
++ *)
++ ;;
++ esac # linkmode
++
+ continue
+ ;;
+ -l*)
diff --git a/devel/libtool/pkg-descr b/devel/libtool/pkg-descr
new file mode 100644
index 000000000000..1dea88bf6d51
--- /dev/null
+++ b/devel/libtool/pkg-descr
@@ -0,0 +1,8 @@
+This is GNU Libtool, a generic library support script. Libtool hides
+the complexity of using shared libraries behind a consistent, portable
+interface.
+
+To use libtool, add the new generic library building commands to your
+Makefile, Makefile.in, or Makefile.am.
+
+WWW: http://www.gnu.org/software/libtool/
diff --git a/devel/libtool/pkg-plist b/devel/libtool/pkg-plist
new file mode 100644
index 000000000000..d4bbdd78ca36
--- /dev/null
+++ b/devel/libtool/pkg-plist
@@ -0,0 +1,56 @@
+bin/libtool
+bin/libtoolize
+share/aclocal/argz.m4
+share/aclocal/libtool.m4
+share/aclocal/ltdl.m4
+share/aclocal/ltoptions.m4
+share/aclocal/ltsugar.m4
+share/aclocal/ltversion.m4
+share/aclocal/lt~obsolete.m4
+share/libtool/config/compile
+share/libtool/config/config.guess
+share/libtool/config/config.sub
+share/libtool/config/depcomp
+share/libtool/config/install-sh
+share/libtool/config/ltmain.sh
+share/libtool/config/missing
+share/libtool/libltdl/COPYING.LIB
+share/libtool/libltdl/Makefile.am
+share/libtool/libltdl/Makefile.in
+share/libtool/libltdl/Makefile.inc
+share/libtool/libltdl/README
+share/libtool/libltdl/aclocal.m4
+share/libtool/libltdl/argz.c
+share/libtool/libltdl/argz_.h
+share/libtool/libltdl/config-h.in
+share/libtool/libltdl/configure
+share/libtool/libltdl/configure.ac
+share/libtool/libltdl/libltdl/lt__alloc.h
+share/libtool/libltdl/libltdl/lt__dirent.h
+share/libtool/libltdl/libltdl/lt__glibc.h
+share/libtool/libltdl/libltdl/lt__private.h
+share/libtool/libltdl/libltdl/lt__strl.h
+share/libtool/libltdl/libltdl/lt_dlloader.h
+share/libtool/libltdl/libltdl/lt_error.h
+share/libtool/libltdl/libltdl/lt_system.h
+share/libtool/libltdl/libltdl/slist.h
+share/libtool/libltdl/loaders/dld_link.c
+share/libtool/libltdl/loaders/dlopen.c
+share/libtool/libltdl/loaders/dyld.c
+share/libtool/libltdl/loaders/load_add_on.c
+share/libtool/libltdl/loaders/loadlibrary.c
+share/libtool/libltdl/loaders/preopen.c
+share/libtool/libltdl/loaders/shl_load.c
+share/libtool/libltdl/lt__alloc.c
+share/libtool/libltdl/lt__dirent.c
+share/libtool/libltdl/lt__strl.c
+share/libtool/libltdl/lt_dlloader.c
+share/libtool/libltdl/lt_error.c
+share/libtool/libltdl/ltdl.c
+share/libtool/libltdl/ltdl.h
+share/libtool/libltdl/slist.c
+@dirrm share/libtool/libltdl/loaders
+@dirrm share/libtool/libltdl/libltdl
+@dirrm share/libtool/libltdl
+@dirrm share/libtool/config
+@dirrm share/libtool