aboutsummaryrefslogtreecommitdiff
path: root/devel/libunicode
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-06-05 06:49:40 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-06-05 06:49:40 +0000
commit67e59b4617483e92d92e47bff7cbe409c7231f0f (patch)
treea9f5fbc95a79959218d09328fd085461ec251675 /devel/libunicode
parent6db426f2fb878ebe98ecbf64a1d7e92f821e532d (diff)
downloadports-67e59b4617483e92d92e47bff7cbe409c7231f0f.tar.gz
ports-67e59b4617483e92d92e47bff7cbe409c7231f0f.zip
Notes
Diffstat (limited to 'devel/libunicode')
-rw-r--r--devel/libunicode/Makefile2
-rw-r--r--devel/libunicode/files/patch-iso8859.c11
-rw-r--r--devel/libunicode/files/patch-latin1.c11
3 files changed, 23 insertions, 1 deletions
diff --git a/devel/libunicode/Makefile b/devel/libunicode/Makefile
index b95c0e7fa40a..6b35f1cdad10 100644
--- a/devel/libunicode/Makefile
+++ b/devel/libunicode/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libunicode
PORTVERSION= 0.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/libunicode
diff --git a/devel/libunicode/files/patch-iso8859.c b/devel/libunicode/files/patch-iso8859.c
new file mode 100644
index 000000000000..afe3101c55be
--- /dev/null
+++ b/devel/libunicode/files/patch-iso8859.c
@@ -0,0 +1,11 @@
+--- iso8859.c.orig Fri Oct 29 15:15:19 1999
++++ iso8859.c Wed Jun 5 02:43:26 2002
+@@ -271,6 +271,8 @@
+ #define ISO_DEFINE(Num) \
+ static char * n ## Num [] = { "8859-" # Num, \
+ "ISO-8859-" # Num, \
++ "ISO_8859-1" # Num, \
++ "ISO8859-" # Num, \
+ NULL }; \
+ unicode_encoding_t P3 (unicode_iso8859_, Num, _encoding) = \
+ { \
diff --git a/devel/libunicode/files/patch-latin1.c b/devel/libunicode/files/patch-latin1.c
new file mode 100644
index 000000000000..5196870a1c85
--- /dev/null
+++ b/devel/libunicode/files/patch-latin1.c
@@ -0,0 +1,11 @@
+--- latin1.c.orig Wed Jun 5 02:41:15 2002
++++ latin1.c Wed Jun 5 02:41:34 2002
+@@ -89,7 +89,7 @@
+ }
+
+ /* The encoding descriptor for Latin1. */
+-static char *l1n[] = { "8859-1", "ISO-8859-1", NULL };
++static char *l1n[] = { "8859-1", "ISO8859-1", "ISO_8859-1", "ISO-8859-1", NULL };
+ unicode_encoding_t unicode_latin1_encoding =
+ {
+ l1n,