aboutsummaryrefslogtreecommitdiff
path: root/devel/libunistring
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-08-08 13:29:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-08-08 13:29:34 +0000
commit6a0617331902b6b2b0d45d0977a3d34a67458c5c (patch)
treec8c10bdcc04f26c46548cb4868c60abfb570be97 /devel/libunistring
parente5e0c4b33235b0691f9927278e7ee1c822154e47 (diff)
Notes
Diffstat (limited to 'devel/libunistring')
-rw-r--r--devel/libunistring/Makefile33
-rw-r--r--devel/libunistring/distinfo2
-rw-r--r--devel/libunistring/pkg-descr6
-rw-r--r--devel/libunistring/pkg-plist47
4 files changed, 88 insertions, 0 deletions
diff --git a/devel/libunistring/Makefile b/devel/libunistring/Makefile
new file mode 100644
index 000000000000..173188c5ffb4
--- /dev/null
+++ b/devel/libunistring/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libunistring
+# Date created: 2011-05-17
+# Whom: Takefu
+#
+# $FreeBSD$
+#
+
+PORTNAME= libunistring
+PORTVERSION= 0.9.3
+CATEGORIES= devel
+MASTER_SITES= GNU
+
+MAINTAINER= takefu@airport.fm
+COMMENT= Unicode string library
+
+LICENSE= GPLv3 LGPL3
+LICENSE_COMB= dual
+LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING
+LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.LIB
+
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+INFO= ${PORTNAME}
+
+pre-patch:
+.if defined(NOPORTDOCS)
+ cd ${WRKSRC}/doc && ${REINPLACE_CMD}\
+ -e 's!install-data-local:!#install-data-local:!' Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/libunistring/distinfo b/devel/libunistring/distinfo
new file mode 100644
index 000000000000..550c21932550
--- /dev/null
+++ b/devel/libunistring/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libunistring-0.9.3.tar.gz) = 610d3ec724fbdaa654afe3cff20b9f4d504be3fd296fded2e0f7f764041006a3
+SIZE (libunistring-0.9.3.tar.gz) = 2555215
diff --git a/devel/libunistring/pkg-descr b/devel/libunistring/pkg-descr
new file mode 100644
index 000000000000..1eb2af39c808
--- /dev/null
+++ b/devel/libunistring/pkg-descr
@@ -0,0 +1,6 @@
+ GNU LIBUNISTRING - Unicode string library
+
+This library provides functions for manipulating Unicode strings and
+for manipulating C strings according to the Unicode standard.
+
+WWW: http://www.gnu.org/software/libunistring/
diff --git a/devel/libunistring/pkg-plist b/devel/libunistring/pkg-plist
new file mode 100644
index 000000000000..96f86921ce50
--- /dev/null
+++ b/devel/libunistring/pkg-plist
@@ -0,0 +1,47 @@
+@comment $FreeBSD$
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_1.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_10.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_11.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_12.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_13.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_14.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_15.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_16.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_17.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_18.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_19.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_2.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_3.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_4.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_5.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_6.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_7.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_8.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_9.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_abt.html
+%%PORTDOCS%%%%DOCSDIR%%/libunistring_toc.html
+include/unistring/inline.h
+include/unistring/stdbool.h
+include/unistring/stdint.h
+include/unistring/localcharset.h
+include/unistring/iconveh.h
+include/unistring/version.h
+include/unistring/cdefs.h
+include/unistring/woe32dll.h
+include/unitypes.h
+include/unistr.h
+include/uniconv.h
+include/unistdio.h
+include/uniname.h
+include/unictype.h
+include/uniwidth.h
+include/uniwbrk.h
+include/unilbrk.h
+include/uninorm.h
+include/unicase.h
+lib/libunistring.so.1
+lib/libunistring.so
+lib/libunistring.la
+lib/libunistring.a
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/unistring