aboutsummaryrefslogtreecommitdiff
path: root/devel/libunwind
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-09-27 02:06:07 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-09-27 02:06:07 +0000
commit0f5c3e1ebfba07b7867d01693bc7877151624288 (patch)
tree41575a5f78d26c9292417062b59caad8f456dd14 /devel/libunwind
parentfcbf0d3b3698bc6789726c241bd009467e161860 (diff)
Notes
Diffstat (limited to 'devel/libunwind')
-rw-r--r--devel/libunwind/Makefile37
-rw-r--r--devel/libunwind/pkg-plist29
2 files changed, 32 insertions, 34 deletions
diff --git a/devel/libunwind/Makefile b/devel/libunwind/Makefile
index 95e1eb621f32..cd957ad4360b 100644
--- a/devel/libunwind/Makefile
+++ b/devel/libunwind/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= devel
MASTER_SITES= SAVANNAH
DISTNAME= ${PORTNAME}-1.1
-MAINTAINER= danilogondolfo@gmail.com
+MAINTAINER= danilo@FreeBSD.org
COMMENT= Generic stack unwinding library
ONLY_FOR_ARCHS= i386 amd64
@@ -21,38 +21,7 @@ ACLOCAL_ARGS= -I . -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= -c -a
LIBTOOLFILES= #empty
-MAN3= _U_dyn_cancel.3 \
- _U_dyn_register.3 \
- libunwind.3 \
- libunwind-dynamic.3 \
- libunwind-ia64.3 \
- libunwind-ptrace.3 \
- libunwind-setjmp.3 \
- unw_backtrace.3 \
- unw_create_addr_space.3 \
- unw_destroy_addr_space.3 \
- unw_flush_cache.3 \
- unw_get_accessors.3 \
- unw_get_fpreg.3 \
- unw_get_proc_info.3 \
- unw_get_proc_info_by_ip.3 \
- unw_get_proc_name.3 \
- unw_get_reg.3 \
- unw_getcontext.3 \
- unw_init_local.3 \
- unw_init_remote.3 \
- unw_is_fpreg.3 \
- unw_is_signal_frame.3 \
- unw_regname.3 \
- unw_resume.3 \
- unw_set_caching_policy.3 \
- unw_set_fpreg.3 \
- unw_set_reg.3 \
- unw_step.3 \
- unw_strerror.3
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
.if ${ARCH} == i386
PLIST_SUB= ARCH=x86
@@ -60,4 +29,4 @@ PLIST_SUB= ARCH=x86
PLIST_SUB= ARCH=x86_64
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/libunwind/pkg-plist b/devel/libunwind/pkg-plist
index a35a23243857..2b1b1fc391e9 100644
--- a/devel/libunwind/pkg-plist
+++ b/devel/libunwind/pkg-plist
@@ -27,6 +27,35 @@ lib/libunwind.a
lib/libunwind.la
lib/libunwind.so
lib/libunwind.so.8
+man/man3/_U_dyn_cancel.3.gz
+man/man3/_U_dyn_register.3.gz
+man/man3/libunwind-dynamic.3.gz
+man/man3/libunwind-ia64.3.gz
+man/man3/libunwind-ptrace.3.gz
+man/man3/libunwind-setjmp.3.gz
+man/man3/libunwind.3.gz
+man/man3/unw_backtrace.3.gz
+man/man3/unw_create_addr_space.3.gz
+man/man3/unw_destroy_addr_space.3.gz
+man/man3/unw_flush_cache.3.gz
+man/man3/unw_get_accessors.3.gz
+man/man3/unw_get_fpreg.3.gz
+man/man3/unw_get_proc_info.3.gz
+man/man3/unw_get_proc_info_by_ip.3.gz
+man/man3/unw_get_proc_name.3.gz
+man/man3/unw_get_reg.3.gz
+man/man3/unw_getcontext.3.gz
+man/man3/unw_init_local.3.gz
+man/man3/unw_init_remote.3.gz
+man/man3/unw_is_fpreg.3.gz
+man/man3/unw_is_signal_frame.3.gz
+man/man3/unw_regname.3.gz
+man/man3/unw_resume.3.gz
+man/man3/unw_set_caching_policy.3.gz
+man/man3/unw_set_fpreg.3.gz
+man/man3/unw_set_reg.3.gz
+man/man3/unw_step.3.gz
+man/man3/unw_strerror.3.gz
libdata/pkgconfig/libunwind-generic.pc
libdata/pkgconfig/libunwind.pc
libdata/pkgconfig/libunwind-ptrace.pc