aboutsummaryrefslogtreecommitdiff
path: root/devel/libusb
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2008-10-13 17:52:01 +0000
committerStefan Walter <stefan@FreeBSD.org>2008-10-13 17:52:01 +0000
commitac6ee06f68120579264f4eca43bb9ebd64d937fa (patch)
treeb56e9f77d57d2574867697e9b124cac1ebb45403 /devel/libusb
parent13a94294db53207d01552e473eb4ae9a19f62326 (diff)
downloadports-ac6ee06f68120579264f4eca43bb9ebd64d937fa.tar.gz
ports-ac6ee06f68120579264f4eca43bb9ebd64d937fa.zip
Notes
Diffstat (limited to 'devel/libusb')
-rw-r--r--devel/libusb/Makefile2
-rw-r--r--devel/libusb/files/patch-bsd.c9
2 files changed, 10 insertions, 1 deletions
diff --git a/devel/libusb/Makefile b/devel/libusb/Makefile
index 80300eaa5af5..d0c743f281a8 100644
--- a/devel/libusb/Makefile
+++ b/devel/libusb/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libusb
PORTVERSION= 0.1.12
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/devel/libusb/files/patch-bsd.c b/devel/libusb/files/patch-bsd.c
index 6e8afde3fdf7..7acf9679e81c 100644
--- a/devel/libusb/files/patch-bsd.c
+++ b/devel/libusb/files/patch-bsd.c
@@ -1,5 +1,14 @@
--- bsd.c.orig Sun Jul 30 11:18:07 2006
+++ bsd.c Sun Jul 30 11:20:30 2006
+@@ -408,7 +408,7 @@
+ /* Ensure the endpoint address is correct */
+ ep |= USB_ENDPOINT_IN;
+
+- fd = ensure_ep_open(dev, ep, O_RDONLY);
++ fd = ensure_ep_open(dev, ep, O_RDONLY | O_NONBLOCK);
+ if (fd < 0) {
+ if (usb_debug >= 2) {
+ #ifdef __FreeBSD_kernel__
@@ -623,9 +623,21 @@
int usb_clear_halt(usb_dev_handle *dev, unsigned int ep)