aboutsummaryrefslogtreecommitdiff
path: root/devel/libuta/files
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2001-04-05 19:01:48 +0000
committerAlexander Langer <alex@FreeBSD.org>2001-04-05 19:01:48 +0000
commit22d8d01d044ec4edf35e0158913e5d61cbecffcd (patch)
treec92101fac8d3fc25fc71b4fdfe8cf47001c33e23 /devel/libuta/files
parentdd3a1118073237bf69aa04b2f96c5d9320414a8a (diff)
downloadports-22d8d01d044ec4edf35e0158913e5d61cbecffcd.tar.gz
ports-22d8d01d044ec4edf35e0158913e5d61cbecffcd.zip
Notes
Diffstat (limited to 'devel/libuta/files')
-rw-r--r--devel/libuta/files/patch-aa21
-rw-r--r--devel/libuta/files/patch-ab11
-rw-r--r--devel/libuta/files/patch-ac11
-rw-r--r--devel/libuta/files/patch-ad11
-rw-r--r--devel/libuta/files/patch-ae11
-rw-r--r--devel/libuta/files/patch-af11
-rw-r--r--devel/libuta/files/patch-ag14
-rw-r--r--devel/libuta/files/patch-ah11
-rw-r--r--devel/libuta/files/patch-ai11
-rw-r--r--devel/libuta/files/patch-aj11
-rw-r--r--devel/libuta/files/patch-ak11
-rw-r--r--devel/libuta/files/patch-al11
-rw-r--r--devel/libuta/files/patch-am11
-rw-r--r--devel/libuta/files/patch-an11
-rw-r--r--devel/libuta/files/patch-ao11
-rw-r--r--devel/libuta/files/patch-ap62
-rw-r--r--devel/libuta/files/patch-aq11
-rw-r--r--devel/libuta/files/patch-ar56
18 files changed, 307 insertions, 0 deletions
diff --git a/devel/libuta/files/patch-aa b/devel/libuta/files/patch-aa
new file mode 100644
index 000000000000..91ce1147b866
--- /dev/null
+++ b/devel/libuta/files/patch-aa
@@ -0,0 +1,21 @@
+--- configure.orig Thu Apr 5 17:21:15 2001
++++ configure Thu Apr 5 17:23:51 2001
+@@ -7,6 +7,9 @@
+ # This configure script is free software; the Free Software Foundation
+ # gives unlimited permission to copy, distribute and modify it.
+
++LIBS="$LIBS -L/usr/local/lib"
++
++
+ # Defaults:
+ ac_help=
+ ac_default_prefix=/usr/local
+@@ -4603,7 +4606,7 @@
+ no_sdl=yes
+ else
+ SDL_CFLAGS=`$SDL_CONFIG $sdlconf_args --cflags`
+- SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs`
++ SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs | sed 's/-lXxf86vm -lXxf86dga -lXv //g'`
+
+ sdl_major_version=`$SDL_CONFIG $sdl_args --version | \
+ sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
diff --git a/devel/libuta/files/patch-ab b/devel/libuta/files/patch-ab
new file mode 100644
index 000000000000..d9bd2f27161b
--- /dev/null
+++ b/devel/libuta/files/patch-ab
@@ -0,0 +1,11 @@
+--- uta/color.h.orig Sat Mar 31 05:24:37 2001
++++ uta/color.h Sat Mar 31 05:26:10 2001
+@@ -22,7 +22,7 @@
+ #define _COLOR_H
+
+ #include <iostream>
+-#include <SDL/SDL_version.h>
++#include <SDL11/SDL_version.h>
+
+ namespace uta {
+ ///
diff --git a/devel/libuta/files/patch-ac b/devel/libuta/files/patch-ac
new file mode 100644
index 000000000000..5bde56c9bf9f
--- /dev/null
+++ b/devel/libuta/files/patch-ac
@@ -0,0 +1,11 @@
+--- uta/event.h.orig Sat Mar 31 05:24:44 2001
++++ uta/event.h Sat Mar 31 05:26:20 2001
+@@ -21,7 +21,7 @@
+ #ifndef _EVENT_H
+ #define _EVENT_H
+
+-#include <SDL/SDL.h>
++#include <SDL11/SDL.h>
+ #include "keysym.h"
+ #include "point.h"
+
diff --git a/devel/libuta/files/patch-ad b/devel/libuta/files/patch-ad
new file mode 100644
index 000000000000..f4a8342115de
--- /dev/null
+++ b/devel/libuta/files/patch-ad
@@ -0,0 +1,11 @@
+--- uta/keysym.h.orig Sat Mar 31 05:24:56 2001
++++ uta/keysym.h Sat Mar 31 05:26:32 2001
+@@ -20,7 +20,7 @@
+ #ifndef KEYSYM_H
+ #define KEYSYM_H
+
+-#include <SDL/SDL_keysym.h>
++#include <SDL11/SDL_keysym.h>
+
+ namespace uta {
+
diff --git a/devel/libuta/files/patch-ae b/devel/libuta/files/patch-ae
new file mode 100644
index 000000000000..c41014f200ee
--- /dev/null
+++ b/devel/libuta/files/patch-ae
@@ -0,0 +1,11 @@
+--- uta/mutex.h.orig Sat Mar 31 05:25:05 2001
++++ uta/mutex.h Sat Mar 31 05:26:54 2001
+@@ -22,7 +22,7 @@
+ #ifndef _MUTEX_H_
+ #define _MUTEX_H_
+
+-#include <SDL/SDL_mutex.h>
++#include <SDL11/SDL_mutex.h>
+
+ namespace uta {
+
diff --git a/devel/libuta/files/patch-af b/devel/libuta/files/patch-af
new file mode 100644
index 000000000000..f96ea5049ee6
--- /dev/null
+++ b/devel/libuta/files/patch-af
@@ -0,0 +1,11 @@
+--- uta/rect.h.orig Sat Mar 31 05:25:30 2001
++++ uta/rect.h Sat Mar 31 05:27:27 2001
+@@ -21,7 +21,7 @@
+ #ifndef _RECT_H
+ #define _RECT_H
+
+-#include <SDL/SDL.h>
++#include <SDL11/SDL.h>
+
+ #include "point.h"
+
diff --git a/devel/libuta/files/patch-ag b/devel/libuta/files/patch-ag
new file mode 100644
index 000000000000..01a860651720
--- /dev/null
+++ b/devel/libuta/files/patch-ag
@@ -0,0 +1,14 @@
+--- uta/sound.h.orig Sat Mar 31 05:25:38 2001
++++ uta/sound.h Sat Mar 31 05:27:39 2001
+@@ -36,9 +36,9 @@
+ #endif
+
+ #ifdef HAVE_MIXER
+-#include <SDL/SDL_mixer.h>
++#include <SDL11/SDL_mixer.h>
+ #else
+-#include <SDL/SDL_types.h>
++#include <SDL11/SDL_types.h>
+ #endif
+
+ namespace uta {
diff --git a/devel/libuta/files/patch-ah b/devel/libuta/files/patch-ah
new file mode 100644
index 000000000000..0c8413e05f6b
--- /dev/null
+++ b/devel/libuta/files/patch-ah
@@ -0,0 +1,11 @@
+--- uta/surface.h.orig Sat Mar 31 05:25:49 2001
++++ uta/surface.h Sat Mar 31 05:27:49 2001
+@@ -22,7 +22,7 @@
+ #ifndef _SURFACE_H_
+ #define _SURFACE_H_
+
+-#include <SDL/SDL.h>
++#include <SDL11/SDL.h>
+
+ #include "color.h"
+ #include "point.h"
diff --git a/devel/libuta/files/patch-ai b/devel/libuta/files/patch-ai
new file mode 100644
index 000000000000..6a8aa18704d6
--- /dev/null
+++ b/devel/libuta/files/patch-ai
@@ -0,0 +1,11 @@
+--- uta/sge_blib.h.orig Sat Mar 31 05:44:18 2001
++++ uta/sge_blib.h Sat Mar 31 05:38:40 2001
+@@ -18,7 +18,7 @@
+ #ifndef sge_blib_H
+ #define sge_blib_H
+
+-#include <SDL/SDL.h>
++#include <SDL11/SDL.h>
+ #include "sge_internal.h"
+
+
diff --git a/devel/libuta/files/patch-aj b/devel/libuta/files/patch-aj
new file mode 100644
index 000000000000..cced0c73a97f
--- /dev/null
+++ b/devel/libuta/files/patch-aj
@@ -0,0 +1,11 @@
+--- uta/sge_blib.cc.orig Sat Mar 31 05:40:36 2001
++++ uta/sge_blib.cc Sat Mar 31 05:40:51 2001
+@@ -19,7 +19,7 @@
+ * This is written by Johan E. Thélin and is slightly modified by me.
+ */
+
+-#include <SDL/SDL.h>
++#include <SDL11/SDL.h>
+ #include "sge_draw.h"
+ #include "sge_blib.h"
+
diff --git a/devel/libuta/files/patch-ak b/devel/libuta/files/patch-ak
new file mode 100644
index 000000000000..a94ac45c9566
--- /dev/null
+++ b/devel/libuta/files/patch-ak
@@ -0,0 +1,11 @@
+--- uta/sge_draw.cc.orig Sat Mar 31 05:41:03 2001
++++ uta/sge_draw.cc Sat Mar 31 05:41:56 2001
+@@ -20,7 +20,7 @@
+ * John Garrison's PowerPak
+ */
+
+-#include <SDL/SDL.h>
++#include <SDL11/SDL.h>
+ #include <math.h>
+ #include <string.h>
+ #include <stdarg.h>
diff --git a/devel/libuta/files/patch-al b/devel/libuta/files/patch-al
new file mode 100644
index 000000000000..898f8f2407cf
--- /dev/null
+++ b/devel/libuta/files/patch-al
@@ -0,0 +1,11 @@
+--- uta/surface_io.cc.orig Sat Mar 31 05:41:28 2001
++++ uta/surface_io.cc Sat Mar 31 05:42:29 2001
+@@ -79,7 +79,7 @@
+ #include <assert.h>
+
+ #include <png.h>
+-#include <SDL/SDL_endian.h>
++#include <SDL11/SDL_endian.h>
+
+ namespace uta {
+
diff --git a/devel/libuta/files/patch-am b/devel/libuta/files/patch-am
new file mode 100644
index 000000000000..fe90bd1267f8
--- /dev/null
+++ b/devel/libuta/files/patch-am
@@ -0,0 +1,11 @@
+--- uta/timer.cc.orig Sat Mar 31 05:41:43 2001
++++ uta/timer.cc Sat Mar 31 05:42:38 2001
+@@ -18,7 +18,7 @@
+ Boston, MA 02111-1307, SA.
+ */
+
+-#include <SDL/SDL.h>
++#include <SDL11/SDL.h>
+ #include "timer.h"
+
+ #include <stl.h>
diff --git a/devel/libuta/files/patch-an b/devel/libuta/files/patch-an
new file mode 100644
index 000000000000..58c087291bcf
--- /dev/null
+++ b/devel/libuta/files/patch-an
@@ -0,0 +1,11 @@
+--- uta/pixelformat.h.orig Sat Mar 31 05:51:51 2001
++++ uta/pixelformat.h Sat Mar 31 05:52:22 2001
+@@ -27,7 +27,7 @@
+
+
+ //just for typedefs ...
+-#include <SDL/SDL.h>
++#include <SDL11/SDL.h>
+
+ #include <string>
+ #include <stl.h>
diff --git a/devel/libuta/files/patch-ao b/devel/libuta/files/patch-ao
new file mode 100644
index 000000000000..4c45fe4118d3
--- /dev/null
+++ b/devel/libuta/files/patch-ao
@@ -0,0 +1,11 @@
+--- uta/sge_draw.h.orig Sat Mar 31 05:52:07 2001
++++ uta/sge_draw.h Sat Mar 31 05:52:34 2001
+@@ -18,7 +18,7 @@
+ #ifndef sge_draw_H
+ #define sge_draw_H
+
+-#include <SDL/SDL.h>
++#include <SDL11/SDL.h>
+ #include "sge_internal.h"
+
+
diff --git a/devel/libuta/files/patch-ap b/devel/libuta/files/patch-ap
new file mode 100644
index 000000000000..586c7f79bf3e
--- /dev/null
+++ b/devel/libuta/files/patch-ap
@@ -0,0 +1,62 @@
+--- acinclude.m4.orig Tue Nov 21 11:10:07 2000
++++ acinclude.m4 Sat Mar 31 06:08:52 2001
+@@ -606,8 +606,8 @@
+ CHECK_LIB_HEADER_VERSION(
+ SDL,
+ SDL_Init,
+- SDL/SDL.h,
+- SDL/SDL_version.h,
++ SDL11/SDL.h,
++ SDL11/SDL_version.h,
+ SDL_MAJOR_VERSION.SDL_MINOR_VERSION.SDL_PATCHLEVEL,
+ $1,
+ http://www.devolution.com/~slouken/SDL/SDL-0.10/src/SDL-$1.tar.gz)
+@@ -618,7 +618,7 @@
+ [
+ TEST_SKIP(
+ [
+- AC_CHECK_HEADER(SDL/SDL_mixer.h,
++ AC_CHECK_HEADER(SDL11/SDL_mixer.h,
+ [
+ AC_DEFINE(HAVE_MIXER))
+ AC_CHECK_LIB([
+@@ -1027,13 +1027,13 @@
+ if test x$sdl_exec_prefix != x ; then
+ sdl_args="$sdl_args --exec-prefix=$sdl_exec_prefix"
+ if test x${SDL_CONFIG+set} != xset ; then
+- SDL_CONFIG=$sdl_exec_prefix/bin/sdl-config
++ SDL_CONFIG=$sdl_exec_prefix/bin/sdl11-config
+ fi
+ fi
+ if test x$sdl_prefix != x ; then
+ sdl_args="$sdl_args --prefix=$sdl_prefix"
+ if test x${SDL_CONFIG+set} != xset ; then
+- SDL_CONFIG=$sdl_prefix/bin/sdl-config
++ SDL_CONFIG=$sdl_prefix/bin/sdl11-config
+ fi
+ fi
+
+@@ -1067,7 +1067,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <SDL/SDL.h>
++#include <SDL11/SDL.h>
+
+ char*
+ my_strdup (char *str)
+@@ -1141,7 +1141,7 @@
+ LIBS="$LIBS $SDL_LIBS"
+ AC_TRY_LINK([
+ #include <stdio.h>
+-#include <SDL/SDL.h>
++#include <SDL11/SDL.h>
+ ], [ return 0; ],
+ [ echo "*** The test program compiled, but did not run. This usually means"
+ echo "*** that the run-time linker is not finding SDL or finding the wrong"
+@@ -1292,4 +1292,4 @@
+ AC_SUBST(SIGC_CFLAGS)
+ AC_SUBST(SIGC_LIBS)
+
+-])
++])
diff --git a/devel/libuta/files/patch-aq b/devel/libuta/files/patch-aq
new file mode 100644
index 000000000000..cdae7ba7b1aa
--- /dev/null
+++ b/devel/libuta/files/patch-aq
@@ -0,0 +1,11 @@
+--- configure.in.orig Sat Mar 31 06:01:00 2001
++++ configure.in Sat Mar 31 06:01:12 2001
+@@ -186,7 +186,7 @@
+ ])
+ AM_CONDITIONAL(SMPEG_AVAILABLE, test x$have_smpeg = xyes)
+
+-AC_CHECK_HEADER(SDL/SDL_mixer.h,AC_CHECK_LIB(SDL_mixer, Mix_SetPostMix, [
++AC_CHECK_HEADER(SDL11/SDL_mixer.h,AC_CHECK_LIB(SDL_mixer, Mix_SetPostMix, [
+ MIXLIBS=-lSDL_mixer
+ AC_DEFINE(HAVE_MIXER)
+ ]))
diff --git a/devel/libuta/files/patch-ar b/devel/libuta/files/patch-ar
new file mode 100644
index 000000000000..62d81deb50a6
--- /dev/null
+++ b/devel/libuta/files/patch-ar
@@ -0,0 +1,56 @@
+--- aclocal.m4.orig Wed Mar 21 13:44:06 2001
++++ aclocal.m4 Sat Mar 31 06:09:47 2001
+@@ -618,8 +618,8 @@
+ CHECK_LIB_HEADER_VERSION(
+ SDL,
+ SDL_Init,
+- SDL/SDL.h,
+- SDL/SDL_version.h,
++ SDL11/SDL.h,
++ SDL11/SDL_version.h,
+ SDL_MAJOR_VERSION.SDL_MINOR_VERSION.SDL_PATCHLEVEL,
+ $1,
+ http://www.devolution.com/~slouken/SDL/SDL-0.10/src/SDL-$1.tar.gz)
+@@ -630,7 +630,7 @@
+ [
+ TEST_SKIP(
+ [
+- AC_CHECK_HEADER(SDL/SDL_mixer.h,
++ AC_CHECK_HEADER(SDL11/SDL_mixer.h,
+ [
+ AC_DEFINE(HAVE_MIXER))
+ AC_CHECK_LIB([
+@@ -1039,13 +1039,13 @@
+ if test x$sdl_exec_prefix != x ; then
+ sdl_args="$sdl_args --exec-prefix=$sdl_exec_prefix"
+ if test x${SDL_CONFIG+set} != xset ; then
+- SDL_CONFIG=$sdl_exec_prefix/bin/sdl-config
++ SDL_CONFIG=$sdl_exec_prefix/bin/sdl11-config
+ fi
+ fi
+ if test x$sdl_prefix != x ; then
+ sdl_args="$sdl_args --prefix=$sdl_prefix"
+ if test x${SDL_CONFIG+set} != xset ; then
+- SDL_CONFIG=$sdl_prefix/bin/sdl-config
++ SDL_CONFIG=$sdl_prefix/bin/sdl11-config
+ fi
+ fi
+
+@@ -1079,7 +1079,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <SDL/SDL.h>
++#include <SDL11/SDL.h>
+
+ char*
+ my_strdup (char *str)
+@@ -1153,7 +1153,7 @@
+ LIBS="$LIBS $SDL_LIBS"
+ AC_TRY_LINK([
+ #include <stdio.h>
+-#include <SDL/SDL.h>
++#include <SDL11/SDL.h>
+ ], [ return 0; ],
+ [ echo "*** The test program compiled, but did not run. This usually means"
+ echo "*** that the run-time linker is not finding SDL or finding the wrong"