aboutsummaryrefslogtreecommitdiff
path: root/devel/libuta
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-03-08 01:01:31 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-03-08 01:01:31 +0000
commit672c044e2eee3598f19a0f5e618e0c2fe8aea68d (patch)
tree771bbdda8fc0a17d5351cfa925732955ccc44706 /devel/libuta
parent86240c80e62c10278c8b2c49d61a2198db15e6ed (diff)
Properly use SDL everywhere:
USE_SDL=yes -> USE_SDL=sdl (good examles everywhere) WANT_SDL/HAVE_SDL instead of exists(localbase/lib/lib...) See http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/using-sdl.html for more information on how to use USE_SDL, WANT_SDL and HAVE_SDL. PR: follow-ups of ports/55494, ports/61877 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Notes
Notes: svn path=/head/; revision=103247
Diffstat (limited to 'devel/libuta')
-rw-r--r--devel/libuta/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/devel/libuta/Makefile b/devel/libuta/Makefile
index afe03413983c..696339577ef5 100644
--- a/devel/libuta/Makefile
+++ b/devel/libuta/Makefile
@@ -29,6 +29,8 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+WANT_SDL= yes
+
SDL11_FILES= configure uta/color.h uta/event.h uta/keysym.h uta/mutex.h \
uta/pixelformat.h uta/rect.h uta/sge_blib.cc uta/sge_blib.h \
uta/sge_draw.cc uta/sge_draw.h uta/sound.h uta/surface_io.cc \
@@ -36,12 +38,12 @@ SDL11_FILES= configure uta/color.h uta/event.h uta/keysym.h uta/mutex.h \
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libSDL_mixer.so.2)
+.if ${HAVE_SDL:Mmixer}!=""
WITH_SDL_MIXER= yes
.endif
.if defined(WITH_SDL_MIXER)
-USE_SDL= mixer sdl
+USE_SDL+= mixer
.endif
post-patch: