aboutsummaryrefslogtreecommitdiff
path: root/devel/libvanessa_logger
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-05-20 03:41:13 +0000
committerWill Andrews <will@FreeBSD.org>2001-05-20 03:41:13 +0000
commit7dd1c369e45ce88f29f3b91dd3dc88516f5f25f5 (patch)
tree42dab9cd5eeb03712e5ebf6d7fa70d6fef91edb1 /devel/libvanessa_logger
parentabb769786a53f889045b694c2e1f65ab5dbe5fb1 (diff)
downloadports-7dd1c369e45ce88f29f3b91dd3dc88516f5f25f5.tar.gz
ports-7dd1c369e45ce88f29f3b91dd3dc88516f5f25f5.zip
Notes
Diffstat (limited to 'devel/libvanessa_logger')
-rw-r--r--devel/libvanessa_logger/Makefile31
-rw-r--r--devel/libvanessa_logger/distinfo1
-rw-r--r--devel/libvanessa_logger/pkg-comment1
-rw-r--r--devel/libvanessa_logger/pkg-descr9
-rw-r--r--devel/libvanessa_logger/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/libvanessa_logger/Makefile b/devel/libvanessa_logger/Makefile
new file mode 100644
index 000000000000..9817a60a3133
--- /dev/null
+++ b/devel/libvanessa_logger/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: libvanessa_logger
+# Date created: 28 April 2001
+# Whom: Konstantinos Konstantinidis <kkonstan@daemon.gr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libvanessa_logger
+PORTVERSION= 0.0.1
+CATEGORIES= devel
+MASTER_SITES= ftp://vanessa.sourceforge.net/pub/vanessa/%SUBDIR%/ \
+ ftp://ftp.au.vergenet.net/pub/vanessa/%SUBDIR%/ \
+ ftp://ftp.nl.vergenet.net/pub/vanessa/%SUBDIR%/ \
+ ftp://ftp.jp.vergenet.net/pub/vanessa/%SUBDIR%/ \
+ ftp://ftp.us.vergenet.net/pub/vanessa/%SUBDIR%/
+MASTER_SITE_SUBDIR= vanessa_logger/${PORTVERSION}
+DISTNAME= vanessa_logger-${PORTVERSION}
+
+MAINTAINER= kkonstan@daemon.gr
+
+MAN1= vanessa_logger_sample.1
+
+INSTALLS_SHLIB= YES
+
+USE_LIBTOOL= YES
+GNU_CONFIGURE= YES
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+WRKSRC= ${WRKDIR}/vanessa_logger-${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/libvanessa_logger/distinfo b/devel/libvanessa_logger/distinfo
new file mode 100644
index 000000000000..a0d0a5be5fc4
--- /dev/null
+++ b/devel/libvanessa_logger/distinfo
@@ -0,0 +1 @@
+MD5 (vanessa_logger-0.0.1.tar.gz) = 3c83ec2cc894951ceb0fa3d9a4d3e41e
diff --git a/devel/libvanessa_logger/pkg-comment b/devel/libvanessa_logger/pkg-comment
new file mode 100644
index 000000000000..1d0033c43093
--- /dev/null
+++ b/devel/libvanessa_logger/pkg-comment
@@ -0,0 +1 @@
+Library that provides a generic logging layer
diff --git a/devel/libvanessa_logger/pkg-descr b/devel/libvanessa_logger/pkg-descr
new file mode 100644
index 000000000000..41ca65779e8e
--- /dev/null
+++ b/devel/libvanessa_logger/pkg-descr
@@ -0,0 +1,9 @@
+libvanessa_logger provides a generic logging layer that may be used to log
+to one or more of syslog, an open file handle or a file name. Though due to
+limitations in the implementation of syslog opening multiple syslog loggers
+doesn't makes sense. Includes the ability to limit which messages will be
+logged based on priorities.
+
+WWW: http://vanessa.sourceforge.net/
+
+-- K. Konstantinidis <kkonstan@daemon.gr>
diff --git a/devel/libvanessa_logger/pkg-plist b/devel/libvanessa_logger/pkg-plist
new file mode 100644
index 000000000000..18f9f5797b1b
--- /dev/null
+++ b/devel/libvanessa_logger/pkg-plist
@@ -0,0 +1,5 @@
+bin/vanessa_logger_sample
+include/vanessa_logger.h
+lib/libvanessa_logger.so.0
+lib/libvanessa_logger.so
+lib/libvanessa_logger.a