aboutsummaryrefslogtreecommitdiff
path: root/devel/libvirt
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-09-03 01:16:30 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-09-03 01:16:30 +0000
commit1d7243c71e08beb6ea5965337ba0ee5887324559 (patch)
treec9c62988ba329bc635cf5c323eee537783292eb0 /devel/libvirt
parent858fc84d234563960cc436a0913ca1d2289cf3b3 (diff)
downloadports-1d7243c71e08beb6ea5965337ba0ee5887324559.tar.gz
ports-1d7243c71e08beb6ea5965337ba0ee5887324559.zip
Notes
Diffstat (limited to 'devel/libvirt')
-rw-r--r--devel/libvirt/Makefile18
-rw-r--r--devel/libvirt/distinfo4
-rw-r--r--devel/libvirt/pkg-descr2
-rw-r--r--devel/libvirt/pkg-plist12
4 files changed, 17 insertions, 19 deletions
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index a5e6fd1135dc..2cbb7c49c1ba 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libvirt
-PORTVERSION= 1.1.1
+PORTVERSION= 1.1.2
CATEGORIES= devel
MASTER_SITES= http://libvirt.org/sources/ \
ftp://libvirt.org/libvirt/
@@ -12,11 +12,11 @@ COMMENT= Toolkit to interact with virtualization capabilities
LICENSE= LGPL3
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- gcrypt:${PORTSDIR}/security/libgcrypt \
- xml2:${PORTSDIR}/textproc/libxml2 \
- gnutls:${PORTSDIR}/security/gnutls \
- ssh2:${PORTSDIR}/security/libssh2
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libxml2.so:${PORTSDIR}/textproc/libxml2 \
+ libgnutls.so:${PORTSDIR}/security/gnutls \
+ libssh2.so:${PORTSDIR}/security/libssh2
OPTIONS_DEFINE= QEMU DOCS NLS
QEMU_DESC= QEMU bindings
@@ -30,7 +30,6 @@ NLS_CONFIGURE_ENABLE= nls
NLS_CONFIGURE_ON= --with-libintl-prefix=${LOCALBASE}
GNU_CONFIGURE= yes
-USE_PERL5_BUILD= yes
CONFIGURE_ARGS= --without-sasl \
--without-yajl \
--without-avahi \
@@ -51,7 +50,8 @@ PORTSCOUT= limit:\d+\.\d+\.\d+$$
LDFLAGS+= -L${LOCALBASE}/lib -fstack-protector
-USES= charsetfix pathfix gmake pkgconfig
+USES= charsetfix pathfix gmake pkgconfig perl5
+USE_PERL5= build
USE_LDCONFIG= yes
USE_PYTHON_BUILD= yes
SHLIB_VER= 1001
@@ -62,7 +62,7 @@ PORTDOCS= *
.include <bsd.port.options.mk>
MAN1= virsh.1 virt-pki-validate.1 virt-xml-validate.1 virt-host-validate.1
-MAN8= libvirtd.8
+MAN8= libvirtd.8 virtlockd.8
post-patch:
@${MV} ${WRKSRC}/daemon/libvirtd.conf ${WRKSRC}/daemon/libvirtd.conf.sample
diff --git a/devel/libvirt/distinfo b/devel/libvirt/distinfo
index 799288d7ca1c..36890064f899 100644
--- a/devel/libvirt/distinfo
+++ b/devel/libvirt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libvirt-1.1.1.tar.gz) = dc6f1e1e15b9b190eaa706e76edabcfc94b239c012f5afc22b22357a4b3b22c2
-SIZE (libvirt-1.1.1.tar.gz) = 25420278
+SHA256 (libvirt-1.1.2.tar.gz) = 16648af54d3e162f5cc5445d970ec29a0bd55b1dbcb568a05533c4c2f25965e3
+SIZE (libvirt-1.1.2.tar.gz) = 26069691
diff --git a/devel/libvirt/pkg-descr b/devel/libvirt/pkg-descr
index 302d323b2cda..956d9f74b142 100644
--- a/devel/libvirt/pkg-descr
+++ b/devel/libvirt/pkg-descr
@@ -9,4 +9,4 @@ libvirt provides:
* Management of virtual machines, virtual networks and storage
* Portable client API for Linux, Solaris and Windows
-WWW: http://libvirt.org/
+WWW: http://libvirt.org/
diff --git a/devel/libvirt/pkg-plist b/devel/libvirt/pkg-plist
index 292edbc6bebc..1bcfec71bad7 100644
--- a/devel/libvirt/pkg-plist
+++ b/devel/libvirt/pkg-plist
@@ -8,6 +8,7 @@ bin/virt-xml-validate
@unexec if cmp -s %D/%%ETCDIR%%/libvirt.conf.sample %D/%%ETCDIR%%/libvirt.conf; then rm -f %D/%%ETCDIR%%/libvirt.conf; fi
%%ETCDIR%%/libvirt.conf.sample
@exec if [ ! -f %D/%%ETCDIR%%/libvirt.conf ] ; then cp -p %D/%%ETCDIR%%/libvirt.conf.sample %D/%%ETCDIR%%/libvirt.conf; fi
+%%ETCDIR%%/virtlockd.conf
%%QEMU%%@unexec if cmp -s %D/%%ETCDIR%%/qemu.conf.sample %D/%%ETCDIR%%/qemu.conf; then rm -f %D/%%ETCDIR%%/qemu.conf; fi
%%QEMU%%%%ETCDIR%%/qemu.conf.sample
%%QEMU%%@exec if [ ! -f %D/%%ETCDIR%%/qemu.conf ] ; then cp -p %D/%%ETCDIR%%/qemu.conf.sample %D/%%ETCDIR%%/qemu.conf; fi
@@ -64,12 +65,16 @@ sbin/libvirtd
sbin/virtlockd
share/augeas/lenses/libvirt_lockd.aug
share/augeas/lenses/libvirtd.aug
+share/augeas/lenses/virtlockd.aug
%%QEMU%%share/augeas/lenses/libvirtd_qemu.aug
share/augeas/lenses/tests/test_libvirt_lockd.aug
share/augeas/lenses/tests/test_libvirtd.aug
+share/augeas/lenses/tests/test_virtlockd.aug
%%QEMU%%share/augeas/lenses/tests/test_libvirtd_qemu.aug
%%DOCSDIR%%%%PORTVERSION%%/html/32favicon.png
%%DOCSDIR%%%%PORTVERSION%%/html/404.html
+%%DOCSDIR%%%%PORTVERSION%%/html/acl.html
+%%DOCSDIR%%%%PORTVERSION%%/html/aclpolkit.html
%%DOCSDIR%%%%PORTVERSION%%/html/api.html
%%DOCSDIR%%%%PORTVERSION%%/html/api_extension.html
%%DOCSDIR%%%%PORTVERSION%%/html/apps.html
@@ -174,11 +179,6 @@ share/augeas/lenses/tests/test_libvirtd.aug
%%DOCSDIR%%%%PORTVERSION%%/html/uri.html
%%DOCSDIR%%%%PORTVERSION%%/html/virshcmdref.html
%%DOCSDIR%%%%PORTVERSION%%/html/windows.html
-%%DOCSDIR%%-python%%PORTVERSION%%/examples/basic.py
-%%DOCSDIR%%-python%%PORTVERSION%%/examples/create.py
-%%DOCSDIR%%-python%%PORTVERSION%%/examples/error.py
-%%DOCSDIR%%-python%%PORTVERSION%%/examples/node.py
-%%DOCSDIR%%-python%%PORTVERSION%%/examples/uuid.py
share/gtk-doc/html/libvirt/general.html
share/gtk-doc/html/libvirt/home.png
share/gtk-doc/html/libvirt/index.html
@@ -303,8 +303,6 @@ lib/libvirt/connection-driver/libvirt_driver_vbox.la
@dirrm %%DOCSDIR%%%%PORTVERSION%%/html/internals
@dirrm %%DOCSDIR%%%%PORTVERSION%%/html
@dirrm %%DOCSDIR%%%%PORTVERSION%%
-@dirrm %%DOCSDIR%%-python%%PORTVERSION%%/examples
-@dirrm %%DOCSDIR%%-python%%PORTVERSION%%
@dirrm share/augeas/lenses/tests
@dirrm share/augeas/lenses
@dirrm share/augeas