aboutsummaryrefslogtreecommitdiff
path: root/devel/libvirt
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-04-04 04:53:26 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-04-04 04:53:26 +0000
commitc0c47dcd0cc0e65591a8af1ef4da414120e0fa51 (patch)
treeb585cb6e5fbef97c86cb5462ab12164bf9d9080f /devel/libvirt
parentb4cc6413dc8df9b8c2656168306b649287f3cc08 (diff)
downloadports-c0c47dcd0cc0e65591a8af1ef4da414120e0fa51.tar.gz
ports-c0c47dcd0cc0e65591a8af1ef4da414120e0fa51.zip
Notes
Diffstat (limited to 'devel/libvirt')
-rw-r--r--devel/libvirt/Makefile15
-rw-r--r--devel/libvirt/distinfo4
-rw-r--r--devel/libvirt/pkg-plist7
3 files changed, 18 insertions, 8 deletions
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index abbfbd4e75ab..48589fc46a1e 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libvirt
-PORTVERSION= 0.9.10
+PORTVERSION= 0.9.11
CATEGORIES= devel
MASTER_SITES= http://libvirt.org/sources/
@@ -18,7 +18,8 @@ LICENSE= LGPL3
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
gcrypt.18:${PORTSDIR}/security/libgcrypt \
xml2.5:${PORTSDIR}/textproc/libxml2 \
- gnutls.47:${PORTSDIR}/security/gnutls
+ gnutls.47:${PORTSDIR}/security/gnutls \
+ ssh2.1:${PORTSDIR}/security/libssh2
GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake autoconf
@@ -30,8 +31,11 @@ CONFIGURE_ARGS= --without-libssh2 \
--without-hal \
--without-udev \
--without-netcf \
- --without-network
-CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
+ --without-network \
+ --with-libssh2
+
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
USE_GMAKE= yes
USE_GNOME= gnomehack
@@ -65,4 +69,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|conf_DATA = libvirt.conf|conf_DATA = libvirt.conf.sample|' \
${WRKSRC}/src/Makefile.am
+regression-test: build
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} check
+
.include <bsd.port.mk>
diff --git a/devel/libvirt/distinfo b/devel/libvirt/distinfo
index ae0a4be1a281..db473fab2cb9 100644
--- a/devel/libvirt/distinfo
+++ b/devel/libvirt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libvirt-0.9.10.tar.gz) = 5b81d9f054ee4b395b0ab4f59845d082baaa6d6c2a038c966309156dde16e11d
-SIZE (libvirt-0.9.10.tar.gz) = 19085438
+SHA256 (libvirt-0.9.11.tar.gz) = ce98fe435f83e109623a021b1f714fe806c3ab556d0780ce959cf75c98766062
+SIZE (libvirt-0.9.11.tar.gz) = 19519376
diff --git a/devel/libvirt/pkg-plist b/devel/libvirt/pkg-plist
index d8548a533e85..1f7baa2bb92e 100644
--- a/devel/libvirt/pkg-plist
+++ b/devel/libvirt/pkg-plist
@@ -168,6 +168,8 @@ share/gtk-doc/html/libvirt/right.png
share/gtk-doc/html/libvirt/style.css
share/gtk-doc/html/libvirt/up.png
%%DATADIR%%/cpu_map.xml
+%%DATADIR%%/api/libvirt-api.xml
+%%DATADIR%%/api/libvirt-qemu-api.xml
%%DATADIR%%/schemas/basictypes.rng
%%DATADIR%%/schemas/capability.rng
%%DATADIR%%/schemas/domain.rng
@@ -274,8 +276,9 @@ share/gtk-doc/html/libvirt/up.png
@dirrm share/gtk-doc/html/libvirt
@dirrmtry share/gtk-doc/html
@dirrmtry share/gtk-doc
-@dirrm share/libvirt/schemas
-@dirrm share/libvirt
+@dirrm %%DATADIR%%/api
+@dirrm %%DATADIR%%/schemas
+@dirrm %%DATADIR%%
%%NLS%%@dirrmtry share/locale/zu/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/zu
%%NLS%%@dirrmtry share/locale/vi_VN/LC_MESSAGES