aboutsummaryrefslogtreecommitdiff
path: root/devel/libvirt
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2015-02-19 19:11:10 +0000
committerJason Helfman <jgh@FreeBSD.org>2015-02-19 19:11:10 +0000
commit8a548f82a5c5a378447e9e83213e5ba392156218 (patch)
tree8a9aec09da66576de6d81679835479076f3cc9b9 /devel/libvirt
parent844d6dbc7ff84998b01133a583c16d8e05c156b8 (diff)
downloadports-8a548f82a5c5a378447e9e83213e5ba392156218.tar.gz
ports-8a548f82a5c5a378447e9e83213e5ba392156218.zip
Notes
Diffstat (limited to 'devel/libvirt')
-rw-r--r--devel/libvirt/Makefile20
-rw-r--r--devel/libvirt/pkg-plist1
2 files changed, 13 insertions, 8 deletions
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index e288e13eecd5..69906d82adc9 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -21,8 +21,8 @@ BUILD_DEPENDS= dnsmasq:${PORTSDIR}/dns/dnsmasq
RUN_DEPENDS= dnsmasq:${PORTSDIR}/dns/dnsmasq
OPTIONS_DEFINE= DOCS NLS QEMU SASL
-OPTIONS_DEFINE_amd64= BHYVE
.if exists(/usr/sbin/bhyve)
+OPTIONS_DEFINE_amd64= BHYVE
OPTIONS_DEFAULT_amd64= BHYVE
.endif
QEMU_DESC= QEMU driver
@@ -36,8 +36,6 @@ QEMU_LIB_DEPENDS= libyajl.so:${PORTSDIR}/devel/yajl
QEMU_RUN_DEPENDS= dmidecode:${PORTSDIR}/sysutils/dmidecode \
qemu-io:${PORTSDIR}/emulators/qemu-devel
-BHYVE_CONFIGURE_WITH= bhyve
-
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
NLS_CONFIGURE_ON= --with-libintl-prefix=${LOCALBASE}
@@ -82,13 +80,15 @@ PORTDOCS= *
.include <bsd.port.options.mk>
-#work around an options bug (thanks mat@)
-.if ${ARCH} != amd64
-PLIST_SUB+= BHYVE="@comment "
+.if (exists(/usr/sbin/bhyve) && ${OSVERSION} >= 100051)
+CONFIGURE_ARGS+= --with-bhyve
+.else
+CONFIGURE_ARGS+= --without-bhyve
.endif
.if ${PORT_OPTIONS:MBHYVE}
-STRIP_FILES+= libvirt/connection-driver/libvirt_driver_bhyve.so
+STRIP_FILES+= lib/libvirt/connection-driver/libvirt_driver_bhyve.so
+PLIST_FILES+= lib/libvirt/connection-driver/libvirt_driver_bhyve.so
.endif
post-patch:
@@ -119,6 +119,12 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
+.if ${PORT_OPTIONS:MBHYVE}
+.for strip in ${STRIP_FILES}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${strip}
+.endfor
+.endif
+
.for dir in run/libvirt/network \
run/libvirt/qemu \
run/libvirt/lockd \
diff --git a/devel/libvirt/pkg-plist b/devel/libvirt/pkg-plist
index 4297888a91b7..3220f68e3b13 100644
--- a/devel/libvirt/pkg-plist
+++ b/devel/libvirt/pkg-plist
@@ -289,7 +289,6 @@ share/gtk-doc/html/libvirt/up.png
%%NLS%%share/locale/zh_TW/LC_MESSAGES/libvirt.mo
%%NLS%%share/locale/zu/LC_MESSAGES/libvirt.mo
%%QEMU%%lib/libvirt/connection-driver/libvirt_driver_qemu.so
-%%BHYVE%%lib/libvirt/connection-driver/libvirt_driver_bhyve.so
lib/libvirt/connection-driver/libvirt_driver_network.so
lib/libvirt/connection-driver/libvirt_driver_secret.so
lib/libvirt/connection-driver/libvirt_driver_storage.so