aboutsummaryrefslogtreecommitdiff
path: root/devel/libvolume_id
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
commit6f32add9a75efb180e462ffbdb0b080bc88088e3 (patch)
tree0fc7af36e22fc0dc7c1dc8aacabf6fe117e881da /devel/libvolume_id
parentb8d245fedd5842fb6d68d0bdc6539885555a84e3 (diff)
downloadports-6f32add9a75efb180e462ffbdb0b080bc88088e3.tar.gz
ports-6f32add9a75efb180e462ffbdb0b080bc88088e3.zip
Notes
Diffstat (limited to 'devel/libvolume_id')
-rw-r--r--devel/libvolume_id/Makefile3
-rw-r--r--devel/libvolume_id/distinfo6
-rw-r--r--devel/libvolume_id/files/patch-fat.c38
3 files changed, 4 insertions, 43 deletions
diff --git a/devel/libvolume_id/Makefile b/devel/libvolume_id/Makefile
index 0658217f5806..06487905df37 100644
--- a/devel/libvolume_id/Makefile
+++ b/devel/libvolume_id/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= libvolume_id
-PORTVERSION= 0.75.0
-PORTREVISION= 1
+PORTVERSION= 0.81.0
CATEGORIES= devel
MASTER_SITES= http://www.marcuscom.com/downloads/
diff --git a/devel/libvolume_id/distinfo b/devel/libvolume_id/distinfo
index 9cf44d0fe7b8..c7035610c20f 100644
--- a/devel/libvolume_id/distinfo
+++ b/devel/libvolume_id/distinfo
@@ -1,3 +1,3 @@
-MD5 (libvolume_id-0.75.0.tar.bz2) = 804d222ea29b9401fb4a6ba00a22b072
-SHA256 (libvolume_id-0.75.0.tar.bz2) = 54072554468f732e60dae024947efaa880cf7847df2651b6dfcc16f2a58832d8
-SIZE (libvolume_id-0.75.0.tar.bz2) = 19408
+MD5 (libvolume_id-0.81.0.tar.bz2) = d5a66bb607e9811f28d40ee3ac8580e0
+SHA256 (libvolume_id-0.81.0.tar.bz2) = 2f6b685893a15d2d4d578bd41692e3091dcfcf88973a23bb0c6b02b266b8f5b6
+SIZE (libvolume_id-0.81.0.tar.bz2) = 23274
diff --git a/devel/libvolume_id/files/patch-fat.c b/devel/libvolume_id/files/patch-fat.c
deleted file mode 100644
index 2780d613c9de..000000000000
--- a/devel/libvolume_id/files/patch-fat.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- fat.c.orig Wed May 30 16:16:49 2007
-+++ fat.c Wed May 30 16:17:12 2007
-@@ -277,7 +277,7 @@ magic:
-
- label = get_attr_volume_id(dir, root_dir_entries);
-
-- vs = (struct vfat_super_block *) volume_id_get_buffer(id, off, 0x200);
-+ vs = (struct vfat_super_block *) volume_id_get_buffer(id, off, sector_size);
- if (vs == NULL)
- return -1;
-
-@@ -294,7 +294,7 @@ magic:
- fat32:
- /* FAT32 should have a valid signature in the fsinfo block */
- fsinfo_sect = le16_to_cpu(vs->type.fat32.fsinfo_sector);
-- buf = volume_id_get_buffer(id, off + (fsinfo_sect * sector_size), 0x200);
-+ buf = volume_id_get_buffer(id, off + (fsinfo_sect * sector_size), sector_size);
- if (buf == NULL)
- return -1;
- fsinfo = (struct fat32_fsinfo *) buf;
-@@ -303,7 +303,7 @@ fat32:
- if (memcmp(fsinfo->signature2, "\x72\x72\x41\x61", 4) != 0)
- err("Found invalid signature2: 0x%08x", fsinfo->signature2);
-
-- vs = (struct vfat_super_block *) volume_id_get_buffer(id, off, 0x200);
-+ vs = (struct vfat_super_block *) volume_id_get_buffer(id, off, sector_size);
- if (vs == NULL)
- return -1;
-
-@@ -355,7 +355,7 @@ fat32:
- if (maxloop == 0)
- dbg("reached maximum follow count of root cluster chain, give up");
-
-- vs = (struct vfat_super_block *) volume_id_get_buffer(id, off, 0x200);
-+ vs = (struct vfat_super_block *) volume_id_get_buffer(id, off, sector_size);
- if (vs == NULL)
- return -1;
-