aboutsummaryrefslogtreecommitdiff
path: root/devel/libzrtpcpp/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-10-06 19:01:59 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-10-06 19:01:59 +0000
commite910cff1d282b557e8ddcb10ce1d5796769cc3b6 (patch)
tree1f123eb1eea88dc777abe3502c1f5c56ccd33c58 /devel/libzrtpcpp/Makefile
parent32d243feb23544b031c1719180f42a6bd5f235be (diff)
downloadports-e910cff1d282b557e8ddcb10ce1d5796769cc3b6.tar.gz
ports-e910cff1d282b557e8ddcb10ce1d5796769cc3b6.zip
Notes
Diffstat (limited to 'devel/libzrtpcpp/Makefile')
-rw-r--r--devel/libzrtpcpp/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/libzrtpcpp/Makefile b/devel/libzrtpcpp/Makefile
index b1581e430e60..8e94fe55eff0 100644
--- a/devel/libzrtpcpp/Makefile
+++ b/devel/libzrtpcpp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libzrtpcpp
PORTVERSION= 0.9.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR=ccrtp
@@ -30,6 +31,8 @@ USE_LDCONFIG= yes
post-patch:
@cd ${WRKSRC}/src && \
- ${FIND} * -type f -exec ${REINPLACE_CMD} -i "" -e "s|<malloc.h>|<stdlib.h>|g" "{}" \;
+ ${FIND} * -type f -exec ${REINPLACE_CMD} -i "" -e "s|<malloc.h>|<stdlib.h>|g" "{}" \; && \
+ ${FIND} * -type f -exec ${REINPLACE_CMD} -i "" -e "s|<stdint.h>|<inttypes.h>|g" "{}" \;
+ @${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>