aboutsummaryrefslogtreecommitdiff
path: root/devel/libzvbi/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-05-15 14:08:03 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-05-15 14:08:03 +0000
commit813226c98e894a35b47375b66f3bc1d01f9207b1 (patch)
tree7545cdfeb4c9930d6cd713a5e3b8b88acdd7759c /devel/libzvbi/Makefile
parente75cf91623f672999820ed5a0c19f478461a4b3a (diff)
Notes
Diffstat (limited to 'devel/libzvbi/Makefile')
-rw-r--r--devel/libzvbi/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/devel/libzvbi/Makefile b/devel/libzvbi/Makefile
new file mode 100644
index 000000000000..10c815a0fced
--- /dev/null
+++ b/devel/libzvbi/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: libzvbi
+# Date created: 15 May 2003
+# Whom: Oliver Lehmann <oliver@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libzvbi
+PORTVERSION= 0.2.4
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= zapping
+DISTNAME= ${PORTNAME:S/lib//}-${PORTVERSION}
+
+MAINTAINER= oliver@freebsd.org
+COMMENT= Routines to access raw VBI capture devices
+
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png \
+ intl.4:${PORTSDIR}/devel/gettext
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}/include \
+ --with-libintl-prefix=${LOCALBASE}/include
+
+CONFIGURE_ENV= CC="$(CC) -I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib -L/usr/lib"
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>