aboutsummaryrefslogtreecommitdiff
path: root/devel/lincvs
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2007-05-29 15:56:58 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2007-05-29 15:56:58 +0000
commitc156112be47f3adbb8d97ebc4e55fc5580924284 (patch)
tree27c6eb30f857884c125eda9642e32fb6565f4c56 /devel/lincvs
parent4df63ed77d8c4c3ba9cb675f20d96cd95f514c11 (diff)
downloadports-c156112be47f3adbb8d97ebc4e55fc5580924284.tar.gz
ports-c156112be47f3adbb8d97ebc4e55fc5580924284.zip
Notes
Diffstat (limited to 'devel/lincvs')
-rw-r--r--devel/lincvs/Makefile4
-rw-r--r--devel/lincvs/files/patch-src-PixmapTimer.h11
2 files changed, 11 insertions, 4 deletions
diff --git a/devel/lincvs/Makefile b/devel/lincvs/Makefile
index d741dcdefd38..dc1ca8f6d40c 100644
--- a/devel/lincvs/Makefile
+++ b/devel/lincvs/Makefile
@@ -27,10 +27,6 @@ ALL_TARGET= install
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
${WRKSRC}/src/main.cpp \
diff --git a/devel/lincvs/files/patch-src-PixmapTimer.h b/devel/lincvs/files/patch-src-PixmapTimer.h
new file mode 100644
index 000000000000..c344d4e7613a
--- /dev/null
+++ b/devel/lincvs/files/patch-src-PixmapTimer.h
@@ -0,0 +1,11 @@
+--- src/PixmapTimer.h.orig Tue May 29 17:05:42 2007
++++ src/PixmapTimer.h Tue May 29 17:05:59 2007
+@@ -84,7 +84,7 @@
+
+ public:
+ CPixmapTimer(QObject * parent = 0, const char * name = 0);
+- CPixmapTimer::~CPixmapTimer();
++ ~CPixmapTimer();
+
+ signals:
+ void signalTimeout(const QPixmap &);