aboutsummaryrefslogtreecommitdiff
path: root/devel/linux-js
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 09:17:03 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 09:17:03 +0000
commit36aec2ee4d4789c8cc6ad940264e1a101d8a7977 (patch)
treefadc33ad2f29c6931b7a10a46ca3d20a561a3331 /devel/linux-js
parent59642d1219c0fc9ff42830b664320824c78e3a3f (diff)
downloadports-36aec2ee4d4789c8cc6ad940264e1a101d8a7977.tar.gz
ports-36aec2ee4d4789c8cc6ad940264e1a101d8a7977.zip
Notes
Diffstat (limited to 'devel/linux-js')
-rw-r--r--devel/linux-js/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/devel/linux-js/Makefile b/devel/linux-js/Makefile
index 9850c63c45b8..45595e1aa9e0 100644
--- a/devel/linux-js/Makefile
+++ b/devel/linux-js/Makefile
@@ -21,9 +21,12 @@ MAN4= linux_js.4
PORTDOCS= joystick-api.txt
USE_RCORDER= jscal.sh linux_js.sh
-OPTIONS= LINUX "Linux mode support (i386/amd64 only)" on \
- JOY "PC joystick support" on \
- UHID "USB joystick support" on
+OPTIONS_DEFINE= LINUX JOY UHID DOCS
+OPTIONS_DEFAULT= LINUX JOY UHID
+
+LINUX_DESC= Linux mode support (i386/amd64 only)
+JOY_DESC= PC joystick support
+UHID_DESC= USB joystick support
MAKE_ENV= WITHOUT_DEBUG=yes
@@ -37,15 +40,15 @@ BROKEN= does not build
IGNORE= requires kernel source files
.endif
-.if defined(WITHOUT_LINUX)
+.if empty(PORT_OPTIONS:MLINUX)
MAKE_ENV+= WITHOUT_LINUX=yes
.endif
-.if defined(WITHOUT_JOY)
+.if empty(PORT_OPTIONS:MJOY)
MAKE_ENV+= WITHOUT_JOY=yes
.endif
-.if defined(WITHOUT_UHID)
+.if empty(PORT_OPTIONS:MUHID)
MAKE_ENV+= WITHOUT_UHID=yes
.endif
@@ -61,7 +64,7 @@ post-install:
.for s in 1 4
${INSTALL_MAN} ${MAN${s}:S|^|${WRKSRC}/|} ${PREFIX}/man/man${s}
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/joystick-api.txt ${DOCSDIR}
.endif